GPS stopped working

Will there be a US/North America location package? Either in the Jolla store or Storeman?

You probably get your current location from the new location package information and the blinking icon is just indicating the device it still in process of getting GPS lock. When it stops blinking the device has GPS lock and uses that for more accurate tracking.

Right. I had it sit on a window ledge for 5 h. Wouldn’t that be enough for anything? Still continued blinking. What next? :man_shrugging:

Well according to the posts in different topics related to this issue, it can take anything between 15mins and literal forever for the device to get GPS lock. I would assume if it doesn’t get it in 5 hours, it won’t get it at all. Depending if the phone is just being cranky or the phone sits in bad spot, you can try to either reboot the phone and hope RNGesus is on your side now or change the phone to position with better view to satellites.

If the guestimation by the offline cell tower positioning is enough for you, you don’t have to worry about not having the GPS lock, but navigation might be bit iffy.

1 Like

4.1.0 here. Three hours outside, and still no GPS lock… Doesn’t look too good… I did have the location package installed and settings as instructed, but no lock…


After upgrading to Kvarken I still had connecting issues, but when I switched to Googles SUPL server from SonyEricsson’s i was finally connected to GPS satellites.

Yeah, I’m also suspecting SUPL server first. Can we at-mention someone with Jolla who knows Location system and can comment on this? Why would Sony’s own SUPL server refuse us, or can we get better insight to this from logging subsystems?

1 Like

perhaps this could be asked by someone attending to get attention the IRC community meetings?

that’s indeed a good topic for one of the community meetings

Maybe Google SUPL servers work so well because Google already knows where you are all the time while SonyEricsson doesn’t :wink:

1 Like

To me it looks more like is simply switched off (or the name will only be resolved by some operators’ DNS):

% host -t ANY   
Using domain server:
Aliases: mail is handled by 10

Furthermore it seems impossible to simply switch SUPL servers, because the SOC insists in using TLS and there doesn’t seem to be a way to upload a new SuplRootCert. Maybe works, but wait …

% host -t ANY  
Using domain server:
Aliases: is an alias for



The update went smooth without problems. Location service: glad that the Jolla team worked on this. I tried it with MagicEarth and it worked! It took a little when GPS started, but then the guidance was fast enough. Thank you Jolla.

There’s no difference that I can see so far as the time for obtaining a GPS lock with the update to It still takes ages (circa 15 minutes) to get a proper lock.

I’d been holding off from changing the GPS Config file to change SUPL settings in the hope Jolla would make an official change. Sadly that doesn’t appear to have happened. All they have done it seems is to provide their own very abbreviated version of MLS Manager in the Jolla Store. This doesn’t fix the underlying problem for the XA2 so far as I can tell.

Yes, there is an quick approximate lock with an accuracy of 9000 metres (based on the GPSInfo app information). This is purely based on cell phone tower data without acquiring any satellites. I had this before the update. Unfortunately I need better than this. I suspect most XA2 owners do as well.


Install MLS Manager from Storeman. There are United Sates and Canadian packages there.

1 Like

Can you show us what text you put into the GPS.conf file?

Did these changes remain after a reboot?

I tried the changes @martinh suggested in post 197. Even though other people said they worked for them they seemed to make no difference for me.

Perhaps there’s other changes I need to make as well.

1 Like

I tried all those changes as well and proper testing (waiting a few days or even better change location a few hundred kilometers) showed no change at all to me.
So I am afraid that all those positive messages are just false positives, where the lock is reached earlier due to all the GPS runtime during that testing…

I guess we need to accept and get over it as there is new HW that needs all attention (10, 10 II)

1 Like

I doubt what I’m seeing here is a false positive but there are a few places to misconfigure the gnss system. If I get it correctly, configuring /etc/gps.conf is not sufficient, /etc/location/location.conf is also needed.

From geoclue-hybris lines 1119 and 1120 i guess that we need:


If you have a statically linked, aarch64-enabled strace, attaching it to android.hardware.gnss@1.0-service-qti will reveal, if the SUPL configuration is forwarded to the Snapdragon SOC, e.g.

# ps -ef | grep gnss
 3099 gps      {gnss@1.0-servic} ...
# ./strace_static  -f -o /tmp/gnss.trc -s 1024 -p 3099

Now run gpsinfo and wait for a few satellites showing up before stopping strace.

# grep -i /tmp/gnss.trc 
6172  sendto(11, "\0\10\1B\0\36\0\1\4\0\3\0\0\0\22 24\", 37 ...

If no line like that shows up, geoclue-hybris didn’t forward the SUPL configuration to the android subsystem. Running geoclue-hybris in debug mode might also help:

$ QT_LOGGING_RULES="*.debug=true" /usr/libexec/geoclue-hybris

Does this need to be uninstalled before installing

@peterleinchen I confirm. I have moved away gps.conf on both of my XA2 plus and I can get a fix in less than 1 minute (because I had a cold start of GPS in open field this morning: it took about 10 minutes to get a fix).

1 Like

Hi martinh,

SUPL is not working as expected for my case (Xperia X). After xtra data has been injected by mer hybris simply providing the SUPL host to hybris layer is not enough. I guess Jolla needs to implement SuplCA certificate injection, too or else and possible other SUPL providers using TLS will not work because of wrong or missing CA chain that needs to be injected into modem (see However here ( is nothing the like but Sony AOSP packages implemented it ( so it is required to make SUPL work.

That being said if SUPL ephemeris data can’t be downloaded because of TLS trouble it takes 30 seconds or even longer to fetch the ephemeris data from the GPS satellites to get a first time fix.

In contrast If SUPL would work that first time fix would be within << 10 seconds.

After the ephemeris data had been downloaded from the sattelites it’s cached and valid for some time so starting GPS after first time fix gets a position lock within << 10 seconds but alas that has nothing to do with a broken SUPL download.