[release notes] Kvarken 4.1.0

I can confirm that I experienced this (on Xperia 10ii dual sim following flash of 4.1.0) where my Wifi network password was not retained. There were also other situations where, following flashing the OS, initially logins and credentials weren’t saved. After a reboot however this seems to have fixed the issues.

Examples - Google Account sign in not saved. Audio recorder app appeared not to have saved recordings (In fact recordings were saved but were not shown under Recordings tab until after a reboot.)

Also I was initially unable to complete registration of Whisperfish (Reported under Whisperfish thread) until the phone was rebooted since the registration hung after input of the OTP Signal code.

Hope this is helpful in identifying possible cause.

Zendesk typo: In the notes it mentions that is a ‘stop release’ and it has a link to the Zendesk page: https://jolla.zendesk.com/hc/en-us/articles/201836347#4.1
The page has a typo as the Koli release is listed there as


With this release qr scanning in android apps (such as nextbike) works now for me. Nice!

Powering off my Xperia 10 is still impossible with the normal shut down. It’s always restarting.

1 Like

GPS Info did show wrong and chaotic permanently changing compass values after the update.
After deleting it and re-installing GPS Info from the Jolla shop, it works now.

That’s strange, I tried to shutdown twice on an Xperia 10 and it did shutdown as expected. No USB connected.

This has been reported in its own bug report:

already a month ago.
and now fixed :slight_smile:
but below is still valid)

So it really seems if a bug report is not marked as „filed internally” or noted explicitly as (to be) solved we need to ping someone at Jolla directly?
But whom? There was already a topic where this was asked for…

oh, and there are a few topics here where the release was also wrongly mentioned like
I corrected a few topic headings but the content of answers I am of course not allowed. It were about a dozen, so not that much work.

1 Like

Is it just me or does it seem that sailfish has become a lot more power hungry in 4.1? Looking at the power draw on my XA2 Plus before the update it was about 100 mA in flight mode, now it’s well over 200 with the same settings. Tested with all applications closed and android emulator stopped.

1 Like

That happened to me when USB was connected, but I haven’t yet tested without. Did you try without?

Same ‘feeling’ on an X.
Normally I would say/conclude it is tracker and friends.
But I have 4.1 on device since Wednesday and charged it already daily. Something I did not have to do earlier with this development/testing device.
Let us wait a few more charge cycles…

Of course I tried without USB-cable.

I’ve checked about everything I can think of. Like I said, I tested in flight mode, so it’s not related to any network connectivity. I checked for wakelocks (didn’t see any). I feel it’s probably due to the new kernel. It seems to be a build from February this year. Maybe some hardware option is not correctly set, causing a much higher power draw.


Updating from the previous 4.0 release, I did not get a list of all system packages to remove, but just these four:

  • feature-jolla
  • sailfish-content-configuration-jolla
  • sailfish-content-graphics-jolla
  • sailfish-content-graphics-jolla-z1.75
    I tried to see what pkcon has to say about these:
[root@Sailfish ~]# LANG=C pkcon remove feature-jolla sailfish-content-configuration-jolla sailfish-content-graphics-jolla sailfish-content-graphics-jolla-z1.75
Testing changes                                                                                                                                                                                                                                        
Fatal error: This request will break your system!

My cue ball suggested that this is probably a false alert, so I updated anyway. It appears to work.

bluetooth-rfkill does not work. rfkill works on its own.
did someone experience this?

It might be a known issue already, but on my XA2 I lose Internet connectivity on Android apps side. E.g. after reboot Vivaldi, Firefox and WhatsApp all work, but a day later or so, Vivaldi and/or Firefox lose connectivity, but WhatsApp keeps on working… It’s not just the first reboot, the situation persists.

1 Like

Mmmh, I would say that this behaviour (bug) is common to all AD- / SFOS-releases on all supported devices.
I.e., I regularly experience this since 2015 (when bought my first Jolla 1) on Jolla 1, Xperia X, XA2 and 10.

1 Like

Spotted exactly the same behaviour for the first time. After another reboot internet was restored. XA2 Dual Sim

A GUI method would be preferable.

Under the Xperia X it helped to restart either aliendalvik or reconnect to wifi/mobile.

Does anybody else have problems with Android-app-Support (here on Xperia XA2 Plus Dual Sim) with Kvarken
It’s the same issue like 2 updates before:
Starting Android apps leads to the tile with the loading-icon, it’s there for half a minute, then closing.
Unsinstall Android-App-Support with Jolla-Store, reboot, install Android-App-Support from Jolla-Store, reboot (with starting alien-dalvik at boot), same error…
The solution time ago was the sailfish-update. I let a post here to this topic but maybe it was on TJC, i could’nt find it here.
Kind regards!

PS: Aaaahh… found it, this was the thread describing my problem:

Thanks for reporting. I have fixed this typo.