[release notes] Koli 4.0.1

It’s only just been merged in, but if it all goes through the checks okay I’ll see what I can do (I’ll post any further info here).

updated smoothly on x II. uninstalled flatpak support before.
okboard has an issue again, like in previous version.

android works for me, deezer starts

nice update !!
like it. browser is really smooth and quick. very happy so far
the remorse time was rewoked ! thanks !

Update went fine here on an XA2. Finally we got a working multiple address books support, that’s really great \o/.

Had to uninstall sailfish connect before the update, as requested. Does anyone know why or what is blocking sailfish connect from working with SF4 ?

Did you try to install it back afterwards? I mean you could get information on what features are not working or is the app working at all. I had the same case with ChargeMonitor app which I tried to install back and noticed it didn’t show any battery related values anymore, basically just a blank UI. Maybe it could be related to Sailfish Connect too?

there’s a missing dependency when you try to install it after so I guess that must be the reason - libcontextkit-statefs-qt5.so

I succesfully updated my XA2 Ultra just now, but WhatsApp doesn’t start, not even after removing and reinstalling. AlienDalvik is up to date, reboot doesn’t help either. Anyone else with this quirk?

Edit: I started a separate thread for this issue: [] WhatsApp doesn’t start since it doesn’t seem to be a common issue at all.

1 Like

The whole android support does not start. reinstall from jolla store did not help. Settings -> android support shows the start button active and stop as disabled. Pressing start does nothing. WA tries to start but closes soon after.
This is on xperia X

I have the same issue.

I didn’t see this reported yet, but I’m having some issues with my Bluetooth headset after this update.

Specifically, after updating to the early-release of Koli, audio doesn’t seem to be forwarded to the headset anymore. It’s worked fine before the update, and I tried restarting the headset and removing & repairing it. It seems to pair just fine, just that audio isn’t played back over it (tried with music player, gallery, web browser). Audio works fine from the internal speakers. I was thinking this might be due to the added firejail sandboxing around the apps, if something went awry with the permissions, but find it a bit odd since audio playback works fine over the built-in speaker with the headset disconnected.

This is SFOS on the Xperia XA2 & connected to Bose QC35 II headsets. Curious if anyone else is having similar problems after the update?

Where is there documentation on the changed UI elements? Would like to fix buttons in gPodder but am grappling in the dark at the moment…


@FireFly This might not be related to this particular update but to updating in general. I had it on the update from 3.3 to 3.4. [] No sound with connected bluetooh headphones Bose QC 35 II

1 Like

What a nice update after the buggy 3-series.
Now fingerprint works on my XA2 plus “ro.odm.version=8.1.0_4.4_nile_v16” that didn’t have working fingerprint in the past and i also had the battery drain

It is stuck in “waiting for connection” for me. Are servers full?

1 Like

Will there be an emulator for Koli before the “main” release? I’d like to check if/how my apps are affected by the UI changes but I need my phone, so I can’t update just yet.

the download was complete, it’s probably rather conflicts that left the device in a broken state.

It showed me to remove an application, but it is not removing the mentioned application. And now it is in the “Waiting for connection” state. Do you know how to get out of that state?

A repo had an issue:

Unexpected exception.
/etc/zypp/repos.d/ssu_openrepos-osetr_release.repo: Section [openrepos-osetr]: Line 8 contains garbage (no '=' or ':/?|,\' in key)   

I moved this repo and refreshed with zypper. But still in “waiting” state.

If you tap and hold your Bose item at Settings > Bluetooth while the headset is connected and take “Show device settings” what do you get?

1 Like

I had a similar problem: Update to fails (Attempts: 1. partly downloaded[?], 2. "waiting for connection")

I managed to solve issue by removing Theme pack support:

pkcon remove harbour-themepacksupport
systemctl start aliendalvik