[release notes] Koli 4.0.1

It sure does work for me, now!

hybris-recovery.img from official Jolla download worked for me today on broken .1.45->.1.48 update.

Yes, approximately. hybris-recovery.img is a tiny linux system that allows you to boot your phone via fastboot (so it has to be corresponding to your hardware). It’s a very basic linux machine. This is not dependent so much on where you’re stuck with your ‘real’ system. Remember that you chroot into your real one and only kernel is shared between the two.

Opera is also based on Chromium. So the Chromium base can’t be the real cause. However, I don’t know exactly if this also applies to the mobile version. (Not “Opera Mini”! ).
I have been using Sailfish in conjunction with Opera as a browser for about 3 years now. Problems have not occurred so far.
However, I would like to switch to a native browser if the functionality is sufficient.

Yes, I can confirm I get the same in XA2 Dual SIM. Definitely a regression bug. I went to SIM default settings and selected “Always ask” for which card to use and the selection menu shows up for like half a second, so it’s impossible to use. I will go ahead and post a bug report…

1 Like

For me dynamic orientation in android apps broke after upgrade from 45 to 48 now i have to force landscape or portrait in settings or by opening an app with fixed landscape or portrait.
If i use opera browser then it forces landscape for full-screen video but then it’s stuck in landscape and i need to force portrait.
I didn’t have these problems in 45.
Edit after typing my answer i stopped and restarted android support manually and orientation started working.

I had to manually restart android support for dynamic orientation to start working, a reboot isn’t enough it need to be manually stopped and restarted.

This happened also during the 3.4.x update from EA to final release. It should be reported more detailed as a bug. On my xa2-dual.sim dynamic orientation and playing fullscreen videos in landscape mode worked in chrom-based and other browsers well, then stopped working on most browsers after update to final 3.4.x final release.

It is possible to change this message into another one. But to do so you have to change a system file with a hex-editor. It’s a little bit tricky but I brought it to work with the help of the community.

Please have a look at the thread

Disable message on unplugging the charger

in the ‘general’ category


I think it is for things like “Energy Star” markings and their European counterparts.
I wouldn’t be surprised if there are EU recommendations or regulations for that text and national regulations, also in many countries the fire department (government) also recommends always unplugging the charger when not charging as a safety measure.
It wouldn’t surprise me if it also is better for legal reasons since there are a country where you can sue a manufacture for everything (even your own stupidity) so it’s better to have the text.
Nokia had a text like that for as long as i remember and i think other manufactures got them as well.

1 Like

Am I really the only one having issues while using predictive text from Jolla?


Didn’t manually stopping and restarting android support fix dynamic orientation for you as it did for me?

No you’re not, just wanted to spend more time on investigation for a precise bug report. It started for me on already.

1 Like

The text prediction scrolls on my device with in both native Apps as well as in Android apps using

Dynamic orientation for Android apps is broken on my XA2 with, but works on my Xperia X with I’ve tried rebooting and restarting the Android service, tried forcing landscape mode, but nothing is working.

Any other ideas? Is there already a bug report on this?

Edit: I had reset my XA2 in order to enable encryption, and for some reason the default setting in AD Android was to lock the orientation. To fix it, I found a way to change the setting by going to Settings -> Android App Support -> Show Licenses, and then I could press the back button in upper left to finally get to Display and enable ‘Auto rotate screen.’

@jovirkku Thank you for the explanation. It is rather confusing when the software says it needs 500mb when it seems that the download size from to is only around 30 MB.

Despite the software telling me that there was insufficient memory it seems that the update took place (whether as part of a reboot (without the usual update routine) or not) but I now seem to be on

I still only have 276.3 Mb of System Data available on my XA2 so I hope that I don’t need to risk enlarging the root partition to install another update.

Upgraded to, but still the issue with Bluetooth dying every time BT has been switched off, or the device has been in airplane mode (needs restart to restore).

Regarding the terminal issue; the commands typed in the app don’t save in history, but commands entered over SSH do appear in the app’s history.

Regarding the charger messages; I am fine with the unplugging -message, but I am not fond of the message “! Unlock device first” everytime I plug in the USB cable to charge. It kinda leaves one wondering does it charge or do I really need to unlock first. I have set USB -> Charging only, so I feel it really should not ask to unlock, if it’s only going to charge.


Not a solution, but better than restarting, have you tried in terminal
devel-su systemctl restart bluetooth.service

Continuing the discussion from [release notes] Koli 4.0.1:

Thanks, now is working again

I’d suggest installing Sailfish Utilities from the Jolla Store and adding the shortcut to your Top menu. It’s a very helpful addition when the OS has one of those moments.


As @Garak told there seems to be something wrong with Android side cellular data. While Whatsapp runs OK, Signal does not. Today Signal could not send or receive anything while Wlan was off or on+unavailable and Cellular on.

With Sailfish utilities I restarted network subsystems, which did not help. Then I restarted UI which closes also all applications. After that Signal started working.

Phone: Sony XA2 single SIM. Sailfish version: