[release notes] Koli 4.0.1

I can confirm on Xperia 10. Can be solved (also after update) by

pkcon remove harbour-dyncal

…and if done after Sailfish 4 update a reinstall of the calendar app followed by a reboot. Calendar entries will not be lost.


The hosts file is indeed mapped into sailfish-browser’s jail. Just type file:///etc/hosts into the address bar and its contents will show up. What’s missing is the corresponding nsswitch.conf. If you add that to Internet.permission, the hosts file should be back to work.

Also missing is /etc/resolv.conf. Hence the local connman proxy is used instead of a blocking DNS server unless configured inside connman.


I have a JBL 750BTNC Bluetooth headset, and it works fine. Well, music works rather flawlessly, and while phone calls do work, the quality is sub-par, because SFOS doesn’t have this/these codecs and/or profiles… It is a known issue :sweat_smile:

X 10 updated all OK. XA2, had problems with “Unable to determine update size” first and followed the guide at https://jolla.zendesk.com/hc/en-us/articles/217190827--Unable-to-determine-update-size-unable-to-update-how-to-fix but it didn’t help. Updating at the command line revealed, however, that the problem was actually that there wasn’t enough space on home partition to download the update. Cleared some space, then everything ok.

@martinh Thanks.

So you say nsswitch.conf, resolv.conf is missing for --private-etc=?
But hosts is listed?

Not really knowing much about firejail (yet) but is this not worth to be filed as a separate bug to make Jolla aware?
(will then also fix defender again)


Yep, I had that previously with the QC35’s too when the mic is used too, I expected that!

I continued the thread on the QC35 issue in the separate thread by @spark since it turned out to not be directly related to this update, to keep this thread focused :slight_smile:

Backup to onedrive still does not work : 3.4.0 Manual Backup to OneDrive

Yes. You can check the contents of a jail by running

$ firejail --list

to figure out the name of the jail (number at beginning of line) and now

$ firejail --fs.print=NAME

will list the contents, e.g.

$ firejail --fs.print=14840 | egrep "nsswitch|hosts"
Switching to pid 6150, the first child process inside the sandbox
clone /etc/hosts
clone /etc/hosts

Without nsswitch.conf the resolver will not even look at /etc/hosts as you can check by moving it away and running e.g.

$ strace nc localhost 99

resolv.conf is not that important since it usually points to localhost anyhow and nameservers can be overwritten per service with connmanctl or other dbus clients.

Probably, but that’s up to @martijntje, who spotted the problem.


I also noticed that bash 5.0.18 gets activated once you remove busybox-symlinks-bash.
That means Jolla no longer sticks to the bash 3 version which still has a non-GPLv3+ license.

This draws me to the conclusion they wanted to get rid of the old bash 3, but did not want to install anything using the GPLv3+ license, so they opted for the busybox bash as a default install.


Signal is borked after update . recorded audio is slow and distorted . also the option to disable screen timeout is gone, max is now ten minutes . i miss the option for never :frowning: beautiful update otherwise ! very nice gui improvements :slight_smile:

1 Like

It is the first version of browser I really enjoy go use.


Which wasn’t present in 3.4. already . so this must have been removed before already (can’t remember if I ever used it)

I’m not sure exactly what’s gone wrong, but the update seems to be treating my entire installation as so alien, everything must be purged.


Installation went smooth on my XA2 dual sim. Until now the browser has been a good experience and did not see any issues with performance where the browser cause all other running apps to crash but one of the pages that often crash it, I can no longer login past pay wall. The page is https://www.berlingske.dk/, I had previously same problem but that many browser updates ago.

I am using Battery Log app from jolla store to track state of charge over the day and it gives visual overview of power drain as a graph, but that feature is no longer working. I wonder if it a bug or interface changed so they need to update the app? I tried install the alternative Hunger Meter and it had same issue about state of charge it just show —mWh and 100% where Battery Log can show the correct %.

The previously update I had to be careful to leave browser open since it caused heavy battery drain, depending which pages open, It is harder to test now so not sure if it still an issue.

DAVx5 is working fine under Koli 4.0.1 :star_struck:
so we can use Android Calendars, Task lists, or Address books again.
Syncing with nextcloud, in my case.

1 Like

same here, I can open patchmanager but zero patches can be applied. The Web catalog is accessible.

well the message window background colour is the invert of the ambience:
white when ambience is dark and vise versa.
so it is on purpose and not 100% breaking the UX as i.e. the white buttons in e-mail app no matter what ambience you have.

1 Like

I had the same message on a completely fresh 3.4 (literally reflashed minutes before). I proceeded anyway, and so far no issues.

1 Like

i did try only 2 and both failed.

need only one realy urgently: no home carousel
that one should be really an option in sfos !

The update has failed several times at the flashing phase. Does the update process leave any sort of log for us to diagnose the failure?