Q: Is it possible to remove the animation after unlocking the device?

Q: Is it possible to remove the animation after unlocking the phone / waking up the phone from standby?

After unlocking there comes the first 4 icons of the app grid from the bottom of the screen and the missed calls + SMS icons from left, for a second, and then they disappear again.

While this animation runs, no operation is possible. This is annoying, after using SFOS for more than 2 years I really know where the apps and the missed calls messages are!

Can I do some hack in some config files or is there some patch to remove this?
A simple message ‘phone unlocked’ on the screen would be great! If not possible, better nothing than this animation!

1 Like

That doesn’t happen to me - i need to touch a free space in the multitasking view to trigger that. And i can most definitely start doing things in the middle of the animation, but perhaps they are a bit slower to react.

Edit: Are you maybe running a bent Xperia 10?

File is /usr/share/lipstick-jolla-home-qt5/layers/launcherLayer.qml.

Change it at the end to say this
edge: PeekFilter.Bottom hintHeight: 0 hintDuration: 0

1 Like

@Levone1 Thank you! Exactly that did what I wanted. Restarting the screen by Hilfsprogramme was also needed, but now the annoying animation is gone.

@attah No surely not! I always treated my X10’s like a raw egg, and I really wonder why this animation doesn’t occur on your phone always after unlock with fingerprint, like on mine.

1 Like

Strange indeed. Since i was comparing with a 10 II, i fired up my old and bent 10. I did get that animation at first boot, which probably is fine even if it blocks interaction. On unlocks 3 and onwards i only really catch the tail end of the animation (or a different one?) just zooming in, no hints. And here it does block interaction.

So i got curious; XA2 and X both display this behaviour - zoom-in animation only, no hints, blocking interaction.
Then back to to the 10 II, and now it also behaves the same :open_mouth: Strange.
I’m sure i managed to trigger a zoomed-out cover yesterday.

What is a zoom-in and zoom-out? I had my problems on unlocking the device from standby, not with zooming anything.

The animation you refer to slightly zooms out and in on the cover grid, right?
For me it just starts zoomed out when i unlock, and then goes to full size.

I refer to this:
Device lies on the table and is in standby with dark screen,
I want to do something with the device,
I take the device and push the power button to wake it up,
Then I put the finger on the FP reader to unlock it,

At this point, as device is unlocked, after 1 second an animation started that shifts the top 4 starters of app grid (first line) from bottom up into the screen and also some notifications from left side (2. second), then shift them out of the screen again (3. second).
This animation is now gone and therefore I’m happy. It annoyed me really! because I always had to wait till it is finished before I could do what I wanted to do with the phone.

Yes, and as part of this animation, other than the first 4 apps popping up, and the notifications peeking in, is not the cover grid also zoomed out and in again?
So what i’m saying is that for me only half of that part seems to happen, and it still gives me a similar problem (albeit quite brief).

This to make 2 points (apart from that i couldn’t reproduce it at all at first):

  1. I agree that blocking interaction is not nice.
  2. I get a shorter animation - wonder why that is.

On my phones (Xperia 10) always only first line / 4 starters did pop up ftom bottom. Never more of them, while I have 35 starters on the app grid.
Additionally, the notifications came from left. But nothing else, never.

Not talking about app grid - but the cover grid, multitasking view, call it what you will, the page that said 4 apps and notifications come in onto. This probably isn’t noticeable if you have no apps running.

Might be here, (/usr/share/lipstick-jolla-home-qt5/layers/homeLayer.qml):

See line 237
NumberAnimation { duration: 250; easing.type: Easing.OutQuad }
Maybe change “250” to “0”. I can’t test at the moment, but probably later on…

1 Like

Ok, it’s line 200 of homeLayer.qml. it says
readonly property real inactiveScale: Screen.sizeCategory >= Screen.Large ? 0.9 : 0.83
change it to
readonly property real inactiveScale: Screen.sizeCategory >= Screen.Large ? 1.0 : 1.0

Hmm, i guess there is no need to keep the ?: conditional then…
But yes, changing it to have no scale change on inactive also stops that animation… (but only for the relevant transition).
I’ll go for a 100ms animation and see how i get on with that.

But the bigger question is why @Seven.of.nine gets a longer more involved animation… strange!
And to me it looks like that would be the hintAnimation in EdgeLayer.qml, which has a 2-second pause in the middle of it. Definitely not something you want at every unlock. Surely that must be meant to run only once per session, at first start.

Are you on the same device? Maybe variation in Jolla official device files?

I’m glad you brought this up - I wouldn’t have thought of it, but it’s much nicer with that animation disabled. Transitions feel much more comfortable and smoother…

1 Like

@attah I had my problems with

and could solve it setting the values in the last 2 lines to 0, as @Levone1 wrote in his post #3 above.

I didn’t change anything in
/usr/share/lipstick-jolla-home-qt5/layers/homeLayer.qml .

On my phone, only wake up the phone with power button but not unlock it, shows a screen with short animations:

  1. Time and date move to their position, coming from top (0,5 sec)
  2. An arrow from right tells me to swipe left to enter the number field (disappears after 1 sec),
  3. Number of missed calls + SMS on the left side (permanent)

#'s 2+3 I like as it is, that’s nice.

Regarding #1: How can I set this in a way, that simply the time and date appears immediately without any moving or animation?

The animation I think he’s referring to happens not just when unlocking, etc., but anytime you go from an app to home screen, or any time you tap a card on the home screen to open an app. The app card will sort-of zoom out a bit, and then zoom back in. I giess it’s just some eye candy by Jolla or something … Anyway, I disabled it and I like it much better.