Q: Can I run Linux software on the SFOS phone?

Maybe a solution for the problem with the lack of available apps:

Considering that the SFOS is a linux system, and the screen has a resolution of 1080 x 2520 pixel, shouldn’t it be possible to run software packets available for desktop and laptop computers, after compiling it for the ARM64 used in the Sony Xperia X?
(pixel res. of the X10 is more than a standard 1920x1080px desktop monitor)

maybe it’s also possible, to connect a USB Mouse and USB keyboard to the SFOS phone.to improve useability and comfort.

Does anybody here see a chance to do so?

Maybe create something like the Synaptic packet manager I have on the linux system, and then run standard linux software at the SFOS phone?

Workaround idea for the mouse: tap and hold on some point, than can appear a dialog that asks the user for leftclick, right- middle of doubleclick…

This may be of interest for you: https://youtu.be/faw3zoNLl_s

2 Likes

Thanks very much!
This is the github address mentioned in the video:


in the video it is not visible good.
I’m working on it… and will report as soon as I have results…

edit: I visited the link, but there is nothing to download. Could also not find the page shown in the video.
Do I have to make an account on github? Is this available for public?
(sorry, I am new with these things…)

edit: created Github account and found what I was searching in “main”

1 Like

Shouldn’t this be the link to the video?

The other link seems to point to CLI setup.

1 Like

Oh, I clicked on the link, downloaded it and a few other interesting videos, too…
Then, from the video download folder, i played the video Flatpak on SailfishOS.mp4, what was also there :wink:

You can even run a full linux distro if you want, have a look here https://talk.maemo.org/showthread.php?t=101080
and here https://old.reddit.com/r/linux/comments/hpai9k/lxc_containers_are_now_working_in_sailfishos_demo/

1 Like

I did now try to install like explained in the video. The 1st and 2nd command did work but at the 3rd line it didn’t find the package.

Here a copy from the terminal:

andrea@andrea-TravelMate-P249-M ~ ssh nemo@192.168.0.1 nemo@192.168.0.1's password: Last login: Fri Aug 28 13:24:59 2020 ,--- | Sailfish OS 3.3.0.16 (Rokua) '--- [nemo@Sailfish ~] devel-su ssu addrepo rinigus-flatpak http://repo.merproject.org/obs/home:rinigus:/flatpak/sailfish_latest_armv7hl
Password:
[nemo@Sailfish ~] devel-su pkcon refresh Password: Refreshing cache Refreshing software list Finished [nemo@Sailfish ~] devel-su pkcon install flatpak-runner
Password:
Resolving [ ] (0%) Package not found: flatpak-runner
Command failed: This tool could not find any available package: No packages were found
[nemo@Sailfish ~] devel-su pkcon install flatpak-runner [nemo@Sailfish ~]

Did I make a mistake or is package no more available?

I was a little surprised that the 1st command gave back no feedback or confirmation, simply after one or two seconds the prompt appeared again. Is this normal? Or had I to wait and because I did not, it failed?

@Seven.of.nine, you used the wrong repo. Correct URL is

http://repo.merproject.org/obs/home:/rinigus:/flatpak/sailfish_latest_armv7hl

1 Like

Aha, I see, I forgot at least one slash…
Thanks very much, Rinigus!

edit: In the mean time I tried again and took care to make no typing errors.

It worked!!! Step 1 + 2 was the same as before, on step 3 it lists a lot of files, asked for proceed y/n, and on y it lists 10 steps and ended with “finished”.

edit: Flatpak is now visible on the grid and the app starts perfect. Standard settings, extensions and about is available. I reboot the phone now…

edit: have rebooted, everything looks OK. wanted to proceed with the next step, and got a big error message:

andrea@andrea-TravelMate-P249-M ~ ssh nemo@192.168.0.1 nemo@192.168.0.1's password: Last login: Fri Aug 28 17:52:44 2020 from 192.168.0.2 ,--- | Sailfish OS 3.3.0.16 (Rokua) '--- [nemo@Sailfish ~] flatpak remote-add --user --if-not-exists flathub https://flathub.org/repo/flathub.flatpakrepo
Usage: gpg-connect-agent [options] (-h for help)Usage: gpg-connect-agent [options] (-h for help)Usage: gpg-connect-agent [options] (-h for help)[nemo@Sailfish ~] [nemo@Sailfish ~]

Then I tried the same command as devel-su, then came this:

andrea@andrea-TravelMate-P249-M ~ ssh nemo@192.168.0.1 nemo@192.168.0.1's password: Last login: Fri Aug 28 17:52:44 2020 from 192.168.0.2 ,--- | Sailfish OS 3.3.0.16 (Rokua) '--- [nemo@Sailfish ~] flatpak remote-add --user --if-not-exists flathub https://flathub.org/repo/flathub.flatpakrepo
Usage: gpg-connect-agent [options] (-h for help)Usage: gpg-connect-agent [options] (-h for help)Usage: gpg-connect-agent [options] (-h for help)[nemo@Sailfish ~] [nemo@Sailfish ~] devel-su flatpak remote-add --user --if-not-exists flathub https://flathub.org/repo/flathub.flatpakrepo
Password:

Note that the directory

‘/root/.local/share/flatpak/exports/share’

is not in the search path set by the XDG_DATA_DIRS environment variable, so
applications installed by Flatpak may not appear on your desktop until the
session is restarted.

Usage: gpg-connect-agent [options] (-h for help)Usage: gpg-connect-agent [options] (-h for help)Usage: gpg-connect-agent [options] (-h for help)[nemo@Sailfish ~] [nemo@Sailfish ~]

Have I forgotten or done wrong something?

1 Like
flatpak remote-add --user --if-not-exists flathub https://flathub.org/repo/flathub.flatpakrepo

is correct. you get gpg-noise due to the old version that we have on SFOS. Just ignore it and continue with the installation of apps. Currently, I suggest to add kde repo as well and then install apps, which has Angelfish (that one was a reason I have worked on making Flatpak for SFOS).

PS: basically, follow README and ignore gpg noise

1 Like

Thanks again very much!
I did previous highlite the commands with the mouse and copy, then paste into the terminal by right click. Maybe i took some spaces and/or invisible charakters with me and so the copied commands went wrong in the terminal…

Now I copied everything with 3x-click, and it did work fine!

You have to install the app first:

flatpak install --user org.kde.mobile.angelfish

after install, I would suggest to start flatpak-runner from the app grid. This will generate app grid icon for Angelfish as well

1 Like

We have cross posted before… Then I read the error message again and saw what nonsense I wrote… and deleted it…

Thanks for this command, I pasted into the terminal and download is now running on the phone!

This command was not clear for me on the installation webpage, so I thought,

flatpak-runner org.kde.mobile.angelfish

will install it.

edit: download was successfully finished, I made the suggested settings scaling = 3 and dpi = 120.

Angelfish runs perfect! Thanks a lot!

Is there a list of programs I can install now? Where Ican I find this?

edit: found https://flathub.org/home webpage…

edit: What have I to do or how have I to modify the command

flatpak install --user appname

to install other software? I did print the flatpak --help page and tried with some program names. Searching for “angelfish” indeed gives back Application ID org.kde.mobile.angelfish.
But all other program names I tried there comes always No matches found.
Wildcards, e.g. ang* did also not work. So I have to know the exact name to enter here.

So I assume that ‘appname’ in the example command stands for the Application ID.
Is there anywhere a list of available Application IDs?

Thanks very much! I looked there but this is too complex for me.

I found the commands in https://flathub.org/apps/collection/popular (and categories on the left side of page), for each program there is the command on the bottom of the page.

I tried to install two webradio apps, Goodvibes and Shortwave.
Both made each 4 file downloads,

    ID                                         Branch           Op           Remote            Download
  1. [?] de.haeckerfelix.Shortwave.Locale stable i flathub 63.9?kB / 57.3?kB
  2. [?] org.gnome.Platform.Locale 3.36 i flathub 31.2?MB / 323.0?MB
  3. [?] org.gnome.Platform 3.36 i flathub 203.1?MB / 291.7?MB
  4. [?] de.haeckerfelix.Shortwave stable i flathub 8.6?MB / 8.7?MB

Installation complete.

and

    ID                                        Branch           Op           Remote            Download
  1. [?] io.gitlab.Goodvibes.Locale stable i flathub 67.7?kB / 210.0?kB
  2. [?] org.freedesktop.Platform.Locale 19.08 i flathub 10.3?MB / 318.3?MB
  3. [?] org.freedesktop.Platform 19.08 i flathub 30.7?MB / 214.7?MB
  4. [?] io.gitlab.Goodvibes stable i flathub 2.0?MB / 2.8?MB

Installing 4/4? ??? 100% 222.2?kB/s 00:00

I think there went something wrong, Goodvibes crashes with error 1 and Shortwave crashes with code 101.
What can I do, what have I done wrong? (Tried also restart of the screen)
Now I can’t even uninstall everything, uninstall command does not work.

edit: the download worked and the terminal didn’t report any error and prompt appeared again. Nevertheless I think that already the download didn’t work correct because of the incongruent data sizes e.g. 10.3?MB / 318.3?MB. OK, it was a try…

there is very limited number of applications that we can run. See https://talk.maemo.org/showthread.php?t=100909 for discussion

in case of odd errors, try

flatpak repair --user

1 Like

Thanks a lot Rinigus, I slowly see more clear what Flatpak does… I hope I did understand right:

I assume now, that the Flatpak is more or less something like a shell or emulation, and every Flatpak app brings at download its own set of libs from the original OS, it was originally written for… And then Flatpak makes all this running in SFOS…

I also read something like this before in your description, but was not really sure because I am not very experienced in such things. Did I now understand this right?

Because with the Shortwave app were 2 huge Gnome.Platform files and with the Goodwave app were 2 huge Freedesktop files.

This observation leads me to a question: Is it possible - e.g. for 2 Gnome apps - to download the gnome.platform + gnome.platform.locale only once and use it commonly for 2 apps? (to save abt. 600MB memory space)?

And what can I do to remove the unuseable 2 radio apps from the memory of the phone? I tried the repair option and the uninstall option of the flatpak command but both did not work.

That doesn’t surprise me, since the radio apps seems to be not supported by Flatpak.

The Angelfish browser runs fine! But, as browsers usually always do, Angelfish sais it is an old version and crys for update.

So I am in doubt if I can push the update button or shall better leave it as it is and ignore the update message. What would you suggest, update or not?

Gnome apps don’t work, as discussed in that thread. same thread describes storage requirements.

should be possible to uninstall apps by flatpak uninstall --user ...

re update button: I am not aware of any. flatpaks are updated through flatpak update

1 Like

I’ve been getting familiar with containers, and working well, but tricky to figure out display issues … I’m not familiar witusing Xwayland, etc. For example, I have Chromium installed and running fine, but I can’t get the whole picture on the screen…

1 Like

To run desktop programs on the phone, it is not enough to install a flatpack. Without a suitable window manager (e.g. Phosh) with scaling options, the result will be poor. See also “mobian”:

https://wiki.mobian-project.org/doku.php?id=apps

Tested programs that can be started, but are hardly usable due to various errors (display doesn’t fit, objects cannot be clicked, keyboard can’t be used…). Right now it’s just a dream to run desktop programs on a phone without changing any code. Flatpacks weren’t made for that either. Don’t expect miracles.

I don’t want to take away any illusions, but these are exactly the problems that even “real” Linux phones have to struggle with. Without code adaptation against a mobile framework, there is no reasonable result.

It’s a long way home :wink:

2 Likes