Pure maps and OSM Scout server instalation

I didn’t find relevant info, so I am creating special thread.

  • I installed OSM Scout Server from Chum.
  • OSM Scout Server complained about missing fonts part. It was not found on chum, I found on Jolla store. So I installed it from there
  • After that OSM Scout Server is able to run. I downloaded maps
  • I installed then Pure maps. That one from Chum complains about something, so i installed it from Jolla store (yes, chaos/mess with repositories. why ? )
    Now pure maps reports error HTTP status code 500
    Why ? How to solve it ? Looking from help
1 Like

It is in Chum, just search for it in Chum GUI app. However, you probably selected map server profile including raster tiles. Unless you have some very old map client, it is not of much use and just takes larger space on device for maps. I would suggest to select default profile instead.

Awesome bug report. Very helpful and can be surely fixed. I suggest to install Chum version. If there is some issue with install, try to run pkcon install in terminal and see error message. Act accordingly to it.

However, that said, Jolla Store version should work as well, its just limited.

Which map service are you using? Online/offline? Does it fail for all of them or something specific. Try to run Pure Maps in terminal and see what’s written in output. Write down the details and file an issue in Github repo.

1 Like
  • You are right. It is there, but you need to know what to do. I had checked option “show application only” in Chum gui app and then OSM scout font part was not found. I didn’t know that, found by accident.
    And yes, I had profile with raster. I guess it was preselected. Anyway I changed it to default profile, and then pure maps start to run !
  • I cannot tell you more about the problem, because it was displayed in the above corner of the screen only for short time. I tried it again and catch it. It was about missing “mapboxgl-qml”. I checked between packages in Chum, and it was there. It required some other library which was also there. Afterwards I was able to install Pure maps from Chum !
  • and the error is gone now, as I switched to default profile. It seems to work fine now
  • I was also able to make to work TTS engine. It works only in english. I installed Mimic tools, and that engine is selected by Pure maps. Do you know how to make to work also other languages ?
  • and last but least, best regards for working on this nice project. Great work !

Great to hear that it is sorted out now. Although, Pure Maps dependencies in Chum should have been pulled in automatically.

Re TTS: you can use picotts - that one is available at Chum and has few more languages.

1 Like

I already installed picotts, but so far I haven’t find a way how to select it in the pure maps

picotts will be used automatically if you choose language that is not provided by mimic

1 Like

I see now, but not all languages have TTS engine.
Thank you for your answers