Problems migrating to Xperia 10 III from Xperia XA2 Plus

I tried to migrate from Xperia XA2 Plus to Xperia 10 III but it wasn’t successful

I started by taking a backup of my XA2 Plus on my SD-card that i moved to the new device to restore it (both devices use
I couldn’t restore my backup from my old phone it failed on notes.
I tried again and i saw a message at the top that i think mentioned account (for some reason i can’t click om the message and read it when it tries to restore the backup.
I then logged int to my account that it had restored and tried again but it failed on notes once again.
I had made one note before trying restoring backup so i deleted it but it failed at notes.
I then changed language to english and tried again but it failed at notes.
I did reboot a number of times that’s not mentioned above.
When i later tried once more it was able to restore the backup, success at last or at least i thought so.

I checked my notes on xperia 10 III but there is no notes.
I then checked people app but there is no contacts in people.
I made manual backup of my contacts on my old phone invoker --type=generic /usr/bin/vcardconverter -e /home/<user>/Documents/backup_contacts.vcf and tried to import it people app “settings>apps>people>From contact file” but no contacts get imported.
I also tried the all.vcf from my backup but it seems that i can’t import any contacts.
How do i migrate notes an contacts to Xperia 10 III?
I checked the backup both contacts and notes has the right information.

Since i also needs my mms history with pictures i did copy commhistory folder (~/.local/share/commhistory) and restored it on the new device successfully going from Xperia X to Xperia XA2 Plus.
I tried it on Xperia 10 III but it didn’t work as before, i had the messages and i could see every message that had a picture but the pictures wasn’t linked to the message so it only showed an empty box with timestamp.
How do i migrate my complete messages history with mms and pictures to the new device?

1 Like

No experience with notes, but the steps to export and import contacts documented in the Sailfish OS Cheat Sheet | Sailfish OS Documentation have worked for me multiple times in recent couple of days. (Note: mandatory to run the commands just as written there, with devel su -p)

1 Like

Did you try doing the contact export manually with devel-su -p vcardconverter --export contacts.vcf and importing that? I don’t think invoker --type=generic /usr/bin/vcardconverter -e /home/<user>/Documents/backup_contacts.vcf has the necessary permissions to access the contact database without devel-su, causing an empty .vcf to be created? (Did you check with a text editor if the backup_contacts.vcf actually contains something?)


This is a bug caused by the username change from nemo to defaultuser on new installs since 3.4.0 .
Older installs have their data located on /home/nemo compared to /home/defaultuser on the newer.
When trying to restore the older backups, it fails due to the nonexistance of the former directory.

As directed in the link below, creating a temporary symlink while doing the restore, should enable it to complete successfully:


Tried symlink and restored the backup once again and it completed successfully but still no contacts or notes.
I tried to import contacts to people but it still doesn’t work, tried both from a shell and from the app.

I didn’t export it with that command i used an already exported .vcf file that was empty so you are correct i also had the all.cfv from the backup and must have mixed them up when checking the files.
I tried exporting devel-su -p vcardconverter --export contacts_xperia10iii.vcf and then importing it with devel-su -p vcardconverter contacts_xperia10iii.vcfand it worked i now have contacts.
I would also like my notes back

1 Like

Ok, nice to hear. Unfortunately I haven’t used notes at all so I don’t have experience or known-to-work suggestions for them. However, I wonder if they could be manually copied by transferring the whole directory ~.local/share/com.jolla/notes/QML/OfflineStorage/Databases to the new phone (although I’m not 100 % sure if that is even the right directory).

I tried copying and cat the files but it seems to be different versions/format, i had no success with it.
I did use the files from the backup and they didn’t work.

I then tried following the description and copied the files from my old phone to my new and it worked, i now have my notes.

The only problem remaining is seeing images in old messages (MMS).

1 Like