Problem receiving mms

I can’t receive mms messages on my XA2, Apparently it tries to download the media, an image, but keeps being stuck forever with only a revolving circle to show for it. The mms settings are filled out correctly. Is this a problem anyone else is encountering?
EDIT: I notice that I need some additional settings from my provider, that don’t exist in the mms settings menu in SFOS. These are:

MCC: 238
MNC: 02
APN Type: default,supl,mms

Is there a configuration file for the mms settings that I might hand edit to include these settings?

This might help. As far as I remember I used the instructions from the last comment.

Thanks, I made the change, but alas the problem stays the same.

I had the same problem with the 10 III. I set it up, got the welcome message from my provider (Telekom DE) and that didn’t download the included picture.

Nevertheless this reminds me that Sailfish OS still needs support for RCS messenging…

Hi, when i was in 4.3, i have tried to downgrade to jolla-messages- as it is suggested above, but it did not solved.
So i have upgraded the OS to
I am now in the same situation than @mortenbo. Also, i dont know how to set additional settings from my provider (SFR in France).