Phone reboots after it is turned off

HARDWARE: Xperia 10 DualSIM


Phone reboots after it is turned off. Sometimes it takes several trials to finally turn it off.


Phone is turned off


Phone reboots


HARDWARE: Xperia 10 DualSIM

This is an old problem of SFOS, I had it also for many years… but since the last update to SFOS it is much better than before but not yet fixed completely.

Was your phone plugged to the charger as you tried to switch it off?
Just now I tested to switch off my phone to see what happens. Result is:

If the charger is plugged in, then the phone shuts down and then reboots.
If the charger is disconnected, the phone shuts down and stays off (does not reboot)

As said, this is an old problem and it means not, that there is a major error. You can confidently ignore this, and if you really want to switch off the phone, then unplug the charger.

It happens even if phone is not being charged. I haven’t found any consistency. But when aptoide is installed it seems more frequent.

In my experience it might be related to touching the fingerprint sensor during shutting off. Moreover this is a known issue, see

1 Like

It is not caused by touching fingerprint reader. I also thought it is caused by this. It is very annoying and would be nice if there is some workaround or if Jolla aknowledges this issue.

Not an answer, but a workaround to be able to switch off immediately: I’ve noticed switch off succes is 100% when the phone is locked: lock phone => press and keep powerbutton untill the Goodbye! appears.

1 Like

Unfortunately this doesn’t work for me. This is very annoying. I even reflashed the device but it is still the same. Is there any way to let Jolla know?

Also been happening to me. Jolla should, theoretically, know about it by it being posted here, (but they wouldn’t care about me, since my device is unofficial, so I’m glad you brought it up). I am able to power off by Sony built-in button combination, (hold power and volume up for 8 seconds), but that’s only if the phone is unplugged. Any time there is a cable connected, it always reboots. I will test with the workaround mentioned above…

For me it worked to type init 0 in a terminal window.

This problem happens to me, too.
“shutdown now” in terminal seems to work.

1 Like

Jolla is aware of this. There is an internal bug about this. The problem hits some devices but not all (like can bee seen in this thread). The reason for the issue seems to be deep in the system. It is not easy to fix in Sailfish but we will try.

But the forced power down should work for all:

  • press both Power and VolUp keys down at the same time
  • keep them down until you feel the vibrator play shortly 3 times (the is one short play before that).

Hi, this issue is still present in 3.4. Force ahut down also does not work every time. This bug is the most annoying.

Hi, thank yoz for answer, I am wondering when is this bug going to be repaired? The is quite nice upgrade, especially browser, but this issue is quite invonvenient and impacts basic funcionality of a phone.

On my phone (X10 Dual SIM) occurs also this bug, as long as I remember. But only with connected charger. If i disconnect the charger and then power off by long pressing the button, it stays off.

Hi, this issue is still present on SFOS, even worse than before. My device (Xperia 10) was able to turn off before update quite normally, but after update I am not able to turn it off. I have to use the above mentioned workaround with volume up and power button. @jovirkku is this issue about to be solved? It seems like I can’t even trust my device.

Does anyone figured out what is causing this?

I experienced this behavior during install of latest update, the phone was charging in the laptop. After that I’ve only tried to reproduce it once, but if the phone is charging when I turn it off, it reboots. Not charging, no problems turning the phone off (but it does seem to take a while longer to start up again than when rebooting while charging). I have a Sony Xperia X, SFOS, no Android-support, no openrepos, no patches.

I think this is normal behavior, but my Xperia 10 reboots even if it is not charging. It seems it is only Xperia 10 related?

For me, it is only Xperia 10 related. None of the other devices are affected (Jolla 1, Jolla C, Xperia X, XA2, Tablet, XZ3)

1 Like

Bringing this topic to light once again, as it got even worse after upgrade to Does anyone have a solution? I am quite disappointed about this. Does anyone have experience with installation of Ubuntu Touch on Xperia 10 as I am thinking about switching to it?

1 Like