Patchmanager patches in Koli 4.0.1

Launcher Combined:

https://dpaste.org/aeX9

thx for the effort, I moved the unified_diff.patch from the original launcher-combined patch and put the one you provided → ‘installation failed’ when applying the patch

Maybe something went wrong while pasting the code.

Here is a link to my file: Launcher_Combined - unified_diff

thx a lot, this works.

In general i hope that the patch system via webcatalog directly from patchmanager will continue to work. Otherwise for non-freaks not really manageable.

I think it works. At least, I updated the compatability of my patches and re-intalled them from the catalog. But PM does not inform of such updates.
I guess @miau can’t update @coderus 's patch, and didn’t want to create a new fork.

If it’s not possible in the short term to handle jailed apps with patchmanager3, perhaps the best way forward to have easy working patches again is to re-release patchmanager2? Just add in the web catalog and we’re good to go. I don’t care that it’s a less elegant solution.

1 Like

@coolc there’s an armv7hl 4.1.0 build of patchmanager2 from elros34 here, State of Repository sailfishos_4.1.0.24 for home:elros34:sailfishapps / patchmanager - SailfishOS Open Build Service - but I don’t think it has web catalog, can you test it?

Thanks for your changed unified_diff file. But I have no root access since SFOS4 with a file browser. How can I remove this file in /usr/share/patchmanager/…?
I try it with terminal “cp -u /home/nemo/downloads/unified_diff.patch usr/share/patchmanager/launcher-combined” but no chance.
Thx in advance

Settings->Developer tools->Enable
In terminal devel-su cp source destination.
I think the path should be …/patchmanager/patches/patch.

Thx for your help! I tryed follow and it’s not work :frowning:

[nemo@Xperia10-DualSIM ~]$ devel-su
Password:
[root@Xperia10-DualSIM nemo]# cp /home/nemo/Apps/unified_diff.patch usr/share/patchmanager/patches/launcher-combined/unified_diff.patch
cp: overwrite 'usr/share/patchmanager/patches/launcher-combined/unified_diff.patch'? y
cp: can't create 'usr/share/patchmanager/patches/launcher-combined/unified_diff.patch': Path does not exist
 [root@Xperia10-DualSIM nemo]#

I think it is a problem with the root rights. I the file manager I can see this file but I canot delete or rename this.

BR Ralf

Try like this:

cp /home/nemo/Apps/unified_diff.patch usr/share/patchmanager/patches/launcher-combined/

or,

mv /home/nemo/Apps/unified_diff.patch usr/share/patchmanager/patches/launcher-combined/unified_diff.patch

But before that I would make backup of original patch. And test it if works. Also made sure that I’m able to ssh into device if something brokes. So I could reinstall lipstick.

edit

Tried it, worked sort of. Folders was missing number of items in.

Thx verry much - I found this way and it works perfect.
cp /home/nemo/Apps/unified_diff.patch /usr/share/patchmanager/patches/launcher-combined
now the launcher patch is fixed. Only the folders shows no smal icons. I will try to found the reason for this…

What about typing correct destination like
**/**usr/share/…

1 Like

Hello miau - I tested you changed patch file and it works fine! Thx.
I ask me wyh I can not sie the spezial folder icons with children icons. Isaw, that you leave out follow lines in the diff file. Why you leave it? Make this trouble?
I am affraid to test it.

337 +                            FolderIconLoader {
338                                 id: folderLauncherIcon
339                                 anchors {
340                                     centerIn: parent
341                                    verticalCenterOffset: Math.round(-Theme.fontSizeExtraSmall/2)
342                                 }
343 +                                folder: launcherFolder.model
344 +                                index: model.index
345                                 icon: "image://theme/icon-launcher-folder-" + (index >= 9 ? (index+1) : "0" + (index+1))
346                                 pressed: folderIcon.pressed && folderIcon.containsMouse
347                                 opacity: icon.indexOf(launcherFolder.model.iconId) !== -1 ? Theme.opacityFaint : 1.0

greetings Ralf

The above patchmanager3 build is now available in chum too, but only for 4.0 and 4.1 sailfish versions.

My understanding is that 3.4 was the one introducing the change in the location of systemd units (/lib → /usr/lib) but it was and 4.0 that broke the compatibility.

So this build is not compatible with Sailfish OS 3.3 or earlier for sure.

I would like to get feedback if you used either the version from Index of /obs/home:/b100dian:/patchmanager or the one from chum with Sailfish OS 4.0 and 4.1 and if you had any issues (except the sailjail one, let’s take that separately).

I’d like to propose a version bump for the sfos4 branch (e.g pm3.1) to distinguish between the two based on this info.

2 Likes

Yes, see the SFOS 3.4.0 release notes, section “Technical changes” (second bullet point there).

… for many Patchmanager Patches: Yes.
And it introduced additional issues for the Patchmanager proper.

Just installed the busybox version in my Xperia X. And modified /etc/firejail/whitelist-common.local as proposed above.

Before reboot, I was able to install patches from the web catalog, but I could not apply installed patches by tapping the bullet before the patch name in the patch list. I had to use the apply in the context menu. And Restart preloaded services didn’t work.
But after reboot it works as expected. And patches also firejailed apps, like calendar. But clicking the patch name does not open patch info but gives an error, if the patch does not come with main.qml.

Thanks @hsjpekka for the info - so if I understand correctly you had one issue with the first run (which I agree did not test for some time) and another with the clicking the patch name - do you know if that used to work in sfos 3.4 differently (no device to test) - i.e. is it a new or existing bug?

1 Like

Yes. In more detail: before rebooting, tapping the list bullet tried to open main.qml - just like tapping the patch name. After reboot, touching the bullet applied the patch - as expected.
In earlier PM-version, tapping the patch name opened the patch info if main.qml wasn’t available. Can’t remember if this broke with sfos 3.4 or 4.0.