OTA Update to 4.5 crashes - What to do?

EDIT: I did not read the screenshot slow enough :slight_smile:

Try to collect logs for sending to Jolla,
Collecting logs of the failed update

The second link for removing the cache is still useful:

Download starts but gets interrupted before complete

1 Like

Why do that?, the error message shows its a repo in openrepos, we’ve known for a long time now that we need to disable/remove repos in Openrepos before updating. Having said that, I did not disable/remove any repos and my update went quite well. It is mentioned in the release notes nearly every release, disable repos.


What to do?

Slap yourself on the wrist for installing an early release? I think the release notes basically say don’t use sfos-upgrade.

OTOH, thanks for highlighting a problem that may have bricked my phone instead. :sweat_smile:

We need a 4.5 feedback thread.

From the release note:

Start the update from “Settings > Sailfish OS updates”. Avoid running updates on the command line, please.

Voila, have created it just now.


Thanks, I did that and the repository in Storeman is gone, but when I try pkcon refresh I still get the same error message about that one repository as though its still there. If I try to refresh the repositories through Storeman it just hangs forever. :pensive:

Not sure I understand your point. I did attempt the update using the Sailfish UI at ‘Settings → Sailfish OS Updates’ Then top pulley menu for Check For Updates, then Download, then Install. Nowhere in my posts above did I say I used the command line, so not sure why you think I did?

1 Like

I didn’t use sfos-upgrade. See OTA Update to 4.5 crashes - What to do? - #12 by Steve_Everett above.

1 Like

Because I apparently have two separate issues:

  1. The upgrade to 4.5 crashed mid-install, leaving the root partition with not enough free space
  2. When I tried to delete some apps to get back some space on the root partition I found I couldn’t; hence why I tried to refresh the repositories as advised in another thread on this forum.

There’s plenty of advice here saying you can basically ignore the package removal errors before updating, and I have done through multiple SFOS upgrades from 3.xx and it has always been fine - no problems whatsoever. This is the first upgrade where it might have caused the upgrade to abort mid install - although there is no evidence the upgrade failure was due to this; it could have been something else.

Anyway, I have solved the root partition space problem by following @emva 's post above to clear the cache. However I still can’t delete any apps, nor refresh the app repositories for some reason?

I had the weirdest experience.

Update went fine and i can use nearly everything except:

  • keyboard is not working in any setting or app, cant create notes but on the shell it works
  • Jolla store does not load
  • Update Jolla page is in a loading loop

What i tried as devel-su on the shell is pkcon refresh and pkcon update.
It downloads a lot of packages with “refresh” but when i then try to “update” i get the notification: Fatal Error. The installation has been terminated as instructed.

OK, the phone just crashed in use now and all I get is the Sailfish OS logo screen when I reboot. Nothing makes any difference power+volup, power+volup+voldown.

It seems like the phone is completely bricked now.

The failed 4.5 installation must have screwed up the original 4.4.72 installation somehow. Its a shame that SFOS is still so fragile after all these years.

Oh well, I don’t have time to do yet another reflash for a while, so its back to the iPhone unless anyone has any ideas of how to get the thing to boot beyond the Sailfish OS logo?

Always download a flash image of the previous SFOS version early enough before it disappears from the SF homepage, so that you can reflash the phone with old version if new one doesn’t work.

Can you ssh into the device?

One try you could make is to use the recovery mode.
So power your device off and hold the volume up key and plug in your usb cable to connect the device to your computer. In the jolla shop there should still be the recovery image for 4.4.0 to boot into recovery mode. Make sure to get the one that matches your installed version.

From there start a shell and post the log from /rootfs/var/run/systemupdate.log

Can you open the file manually (with nano, as root) and check the file yourself? I had a similar issue once and there really was garbage on the line.

No, ssh isn’t possible - I don’t think its booting up far enough for the network stack to be operational. All I get is ‘host unreachable’. I’ve ssh’d into the phone successfully before, so I know all of the settings are right. I can’t even get the blue light to do a reflash, just the red one. I think it really is fried for good sadly, which would be a pity as it cost a lot of money and is only just over a year old. I’m all out of ideas.

Funnily enough, I got my old ‘standby XA2’ out of the drawer, and although it complained of literally hundreds of packages that needed to be removed (screens and screens of them) during the pre-upgrade check, which I completely ignored, the actual upgrade went very smoothly with no problems whatsoever. The Android app icons lost their folder assignments (but strangely not the SFOS ones) but everything works.

Bit of a contrast with the much newer, and better supported, 10 III which was a disaster for me.

Sadly, no way of getting anywhere near any file on this brick now.

OK, so after a week of mucking around trying to fix things and multiple attempts I finally got a telnet connection into my Xperia 10 III and was able to reset the phone back to factory settings. I then re-flashed the latest 4.4 release from the Jolla website, logged into my Jolla account and did the official OTA update to 4.5 using the GUI.

So, a good clean 4.4 installation from fresh based on the recommended Android 11.4.19.v9a lena binaries with no apps other than the stock Jolla apps, no patches, no openrepos or chum, etc, and then upgraded to 4.5 via the official Jolla OTA update.

Compared to my XA2 update (above) its a bit of a disaster …

  • Android apps almost always have no connectivity on mobile data - so little change from 4.4

  • Office 365 email accounts, whilst not reporting the old ‘Account Signed Out’ error, consistently fail after a reboot or just a period of time, reporting ‘Connection Error’ - the only way to recover the situation being to delete the accounts and set them up again from scratch. So again no real improvement from 4.4. This has happened three times in the last week as the phone has switched from mobile data to wireless or vice-versa.

  • Bluetooth to car or speaker or … anything no longer works. Although bluetooth seems to be active no pairing or connection seems possible, whereas it was in 4.4

  • Videos no longer play in the web browser most of the time (e.g. BBC News), or if they do there is no sound

The XA2 has the Office365 issue, the android connectivity issue and the video playback issue, but not the bluetooth issue

So, bearing in mind that 4.5, for me, seems to introduce more problems than it fixes, maybe I should go back to 4.4 …? is out, it fixes Browser video playback issues.

The Bluetooth pairing should be possible with terminal: Broken pairing, no connection with Bluetooth car kit [10 III,] - #10 by wetab73