On my XA2 (Torronsuo) and XA2 plus (Koli) radio apps do not work anymore. Not one Sailfish radio app is usable. Why is this? How to solve?

Not one radio app works on my two phones and it doesn’t matter in what update the phones are.I tried them all. There seems to be a problem with the connection to the browser. When searching for a channel in order to get one installed, the wheel keeps turning and nothing happens. The only thing I can do is deleting the app to stop this turning. How can this be solved?

2 Likes

Did you try Receiced from openrepos?

Did it ever work on that device?
Assuming you mean FM radio, it is listed as a known issue that it has not yet been implemented.

No,.not fm, but internet radio.Yes I did install Received and Allradio from Storeman. I have had Received for years… It doesn’t make any difference. Allradio does not open, Received does but search doesn’t work and typing urls doesn’t work either. Wheel keeps turning until I delete the app.
RadioDroid works, but sends me sometimes to a website that isn’t safe.

For me, SailWave is still working. Maybe with the other Apps, the database with the URL of the radio stations is missig or broke. Apparently the latter applies to AllRadio that doesn’t work anymore for quite some while now.

Received works for me without issues

I brought my XA2 to factory setting, installed al apps plus accounts again, then I tried all radio apps, including Sailwave. Typing a url makes the wheel turning.
My XA2 is in Torronsuo, my XA2 plus in Koli. That doesn’t make any difference, for in Koli I have the same problem.
RadioDroid works though, but that one logs and send me to a casting website that is not safe.
Compared to the Jolla 1 with wich I could use a satnav and with which all the Sailfish radio apps worked well, I am worse off now, because GPS doesn’t work either.
I really want to pay for Sailfish, but now it’s too disappointing, too dysfunctional.

I want to add that Jolla/Sailfish is my dayly driver for almost seven years. Besides that I use an old ipad mini.

I am quite happy with my XA2, Koli and Received. Did you try different networks?

I am at home most of the time. We have the best modem available in our country. It doesn’t work on wifi. I haven’t tried radio on mobile .

Yes, and on Jolla 1 too.

1 Like

Would you please try it out on a mobile network only setting?

Thank you for thinking with me.
I went outside and installed Received and SailWave.
I also did location on.
Then I changed the seach engine form Qwant into Bing and thereafter into Duckduckgo. This didn’t make any difference.
I typed urls of radiostations from several countries in SailWave, but got ‘The stream url is not valid’, ‘no validation’,
In Received the wheel keeps turning with search and after typing a url. I don’t know, is there something wrong between the apps and the browser? As I said, a few updates ago Received worked for years.

When I started Received today on my XperiaX only with WiFi on, then I could only play my favorites that were already created. If I wanted to search or browse for other stations, I only got the spinning wheel. With mobile data on and WiFi off, I was then able to look for new stations again. Now this works again also with WiFi only.

On my XA2 the German Radioplayer works fine with wifi at home as well as via mobil data.
Have you tried a reboot?

Yes, I rebooted several times. Annoying enough. Did not help, so if you are satisfied because the Sailfish apps work for you, better do not reboot!
In the meantime I installed Transistor, a simple radio app in F-Droid, comparable to SailWave. This worked immediately. It is a puzzle.
Thanks for trying to help.