No mobile data Xperia 10iii []

So, I switched my SIM back to Sailfish OS on my Xperia 10iii a bit over a month ago, after a few years on Android (Lineage OS). I’m running Struven ketju Version

Two days ago mobile data stopped working for me. Not just 4G, but any access to mobile data. I’ve read through a lot of the advice in [4.4.0] [X10III] VoLTE breaks IPv6 connectivity, slowing IPv4 down, too, tried the three methods of resetting ofono, and even double-checked that the problem isn’t with my SIM card by putting it back in my Android phone, where mobile data functions. The odd thing is that I tested this in two Xperia 10 iii devices, and the problem is present in both devices—and both devices previously worked with mobile data.

Could someone point me to what to troubleshoot on my phone to restore mobile data access? The phone shows 4G status, but then when a call comes through it drops back to 3G for the call. SMS functions normally.

This happened to me (10iii) a few months ago. There was no apparent reason and it started working again after 2-3 days. I don’t have more information, at the time I assumed the problem came from my operator.

1 Like

You could try setting mobile network to ip V4 only or deactivating VOLTE

1 Like

Deactivating VoLTE doesn’t seem to help. I looked for the setting to limit the mobile network to IPv4 (I know I saw it once) but I can’t currently find it. Would someone remind me where it is?

I also reached out to Jolla’s official customer support, since I’m running a licensed copy of Sailfish X, but so far there’s no response.

Could you ping any DNS server ( or ?

Settings:Mobile Network: Data Access Point: Protocol

I couldn’t ping anything. The root terminal gave me a “no network” error message.

However, in spite of having no network connection via my SIM card, I suspect something is messed up with the DNS settings in my phone. When I connect to a WiFi network, I can ping or, but pinging or other domains fails. (From my laptop on the same WiFi network I have no problems pinging Internet domains.)

You sure have messed up your DNS settings. It happens that certain networks force you to use the dns provided by dhcp.