No HW acceleration in video playback

Thanks! There is some progress, all sites I’ve tried now play both video and audio (,,,,, etc).

However, there is no longer hardware acceleration for video decoding, as far as I can tell. With 4.4.x, I was able to play YouTube 1080p with no dropped frames on my XA2. With 4.5.x, even 480p videos on YouTube are dropping frames. Please see the attached images for comparing the nerd info on the same YouTube video before and after the updated to 4.5.x.

(You might think it’s the change of video codec for the served video, but I’ve tried forcing VP9 on and it didn’t play 1080p as before anyway.)


Sigh. I’d be happy if the browser STARTED normally. Youtube tests have shown what you’re seeing also on the Volla22/GS5. However, invidious shows 1080x720 videos at full rate with no dropped frames. Not sure.

I’ve also tried Invidious, both the default streaming and the DASH-based one. It was smooth for me only at 360p with SFOS 4.5. On SFOS 4.4, I’m using Invidious daily at 720p, very nice experience even without JavaScript, but it was dropping lots of frames on my XA2 with SFOS 4.5 no matter what combinations of Invidious settings I’ve tried. Maybe your hardware has a more powerful CPU and copes better with this change?

Correction, 1280 x 720. The GS5 has a more powerful processor. On the other hand, on opengl is broken on this port :0 Still, the browser has a number of issues. Given what @nephros has discovered on the sony devices (blue tint doing web-rtc video like jitsi) which I do NOT see, I think there is a compositor bug on the sony phones. But there is something else broken, too.