No Autofocus on Xperia 10 III

My new Sony Xperia 10 III smartphone (with SFOS 4.5.024) is really good - with one exception. The photos from the built-in camera are blurred. It looks as if the autofocus is not working. Since I haven’t deliberately adjusted anything and haven’t found anything on the net, I’ll ask around to see if this is a bug or if I’ve overlooked something.

On my Xperia 10 III, the autofocus works, but it is rather slow. I can’t compare to the stock android version (I don’t have an android at hand), but as far as I remember, on android it was quite useful.
It works ok on Sailfish OS for static pictures in good light, everything else is rather pointless and, I would say, on the level of a 20 year old digital consumer camera.

This may improve once Camera2 API is implemented, but I can’t well if and when this will be the case.

If you have no autofocus at all (try it under good lighting condition on a high contract subject), then there is probably something broken. Did you test if the camera worked before you flashed Sailfish OS?

There are a couple of threads about this already.


Don’t expect a great or even good experience taking photos with a SFOS phone.

1 Like

I always tap manually with advanced camera so that works for me

1 Like

Reflections seem to completely thow the focus mecanism.

(I suspect Sony’s camera library relies on sharp edges to determine when it’s in focus. And bright reflextions tend to be starkly contrasted)

I have now found a simple workaround - I have activated the triple camera according to the SFOS docs. Now simple photoss are possible under advanced camera, but no selfies. This is temporarily bearable. As expected, the quality is not great. Thanks for the tips.

I have used Sony Xperia X Compact, Sony XA2 (both with official SFOS) and now Sony XZ2 Compact (SFOS community Port).
My observation with Jolla Camera App on these 3 Hardware-Platforms are always the same. It doesn´t seem to utilise the Hardware-Distance-Sensor (Sony call this “Laser Autofocus” for the X- and XZ2-Compact) for fast and correct Focus. So it seems it has its own Software-Implementation (Zoom and compare contrast boundaries) which isn´t fast and gives the optimal result in most cases.
Maybe theres no access to the Depth-Sensor it or its buggy in the AOSP-Blobs.
I experience a similar behaviour on LineageOS with the Sony XZ1 Compact and the Sony XA2.

AdvancedCamera seems to handle this better Softwarewise but can´t utilise the Hardware-Camera-Button.

So things will improve maybe with CamperaAPI 2.0 hopefully.

Please correct me if statements are wrong.


Never had an autofocus problem with the main 10 iii camera. Still haven’t ‘unlocked’ the other two. Still having problems with HDR though I have finally taken photos as good as my XA2. 10 iii’s camera works better under low light too, and vastly better than the XA2’s native SF apps.

The Camera works out of the box? What do mean with not activating the other cameras? Have you changed some code?

This just happened to me: The Camera has stopped autofocus. I am trying to use it to pay things with the use of android apps. It has always been a little problematic but suddenly it does not work at all.

Even when I open the normal Jolla camera app it has stopped auto focusing. It just does not do it. Is there a way to disable and enable autofocus to see if that helps?


In Advanced Camera there is a setting for focus mode.

Edit. Oh i forgot, versions 0.9.5 and above are in Chum.

Out of the box means I haven’t changed any code or installed anything relevant. Fresh installation of on Android 11.
In short, you either have a screwed-up installation or bad hardware.

Android 13 is now recommended. If no-one here can suggest anything, I’d backup what you can, reinstall Android 13, test and, if that works, reinstall

As I understand it, only one of the 3 cameras works on SF. There is a hack to switch to the others.

Reposted because can’t edit the bad advice to reinstall Android 11. :wink:

Then you must not haven taken many pictures. It’s actually kind of impressive (in its own sad way) how poorly the autofocus works on this phone. I used to think autofocus was a ‘solved problem’ 20 years ago, but here we are…

Would you kindly point where is this recommendation?


My problem is solved. Or kind of.

When I turned off Android App Support my Autofocus works again.

When I turned Android app support on again the autofocus doesn’t work again. Could MicroG be causing problems?

Just tried it now, (x10iii4.5.0.24) I have aas and ug on, and AF is working.

I have found that incredibly slow picture taking is caused by AF. If it doesnt think it has focus, it wont fire the shutter

Yes, that has been a problem for a long time. Extremely irritating to never be able to take an action shot. When my children are playing football or I am on a buss/train, it won’t take the photo.

However, more recently the AF has not worked at all. It never focuses, even though it says it does. There is the blue circle but the image is really blurry. When I turn off Android app support, the auto focus works as normal.

yes, it want that the focus is set otherwise it just won’t take a picture.
I get a bit frustated by this behaviour actually.

You could call it a community recommendation, but it fixes a significant aesthetics problem with the screen.