NextCloud HowTo Sailfish OS Backup

Hi community and sailors,

is there a step by step description how to install and configure NextCloud for the Sailfish OS backup?

(Sailfish 3.4.0.24, XA2 single sim)

I managed to install NextCloud on my Synology NAS (youtubeguide) and I get a connection witch an android app (even with a two way authenticator), but it does not work with SailfishOS. Creating an account is possible, but it is not working. Are there some tweaks I have to know, or to setup in the createt acount in the account settings, that differ from standard Sailfish settings?

It would be great if someone who knows how to set it up could make a HowTo guide for beginners.

Or is there a bug that is currentliy making this NextCloud-backup thing not usable?

When Jolla introduced Nextcloud integration, there were a few issues which have been discussed at https://together.jolla.com/question/224331/330-issues-with-nextcloud-integration/ and similar threads. For instance, it was necessary to run Nextcloud in the webserver’s root instead of a subdirectory.

Just for clarification: ist it just backup that’s not working or the Nextcloud account in general? Topic title suggests your problem ist just tied to backup, but the text sound like there are general problems.

For just backup problems: as far as I remember you need to set the the backup folder in your Nextcloud first. Sailfish backup doesn’t create that folder, and when you set up the account on sailfish you can’t chance the destination folder. But it might work if you add a folder in your Nextcloud that matches the standard backup path provided by sailfish nextcloud account setup.

Well, if you create a new account for nextcloud at 3.4 the backup path is setup correctly. If you have created the nextcloud account a release earlier, than there won’t be the correct path and you have to set it manually (Nextcloud-backup-client fails to upload). But this assumes a working nextcloud server.

1 Like

Standard path from sailfish default is
/remote.php/dav/files/Username/Sailfish OS/Backups.

As Sailfish doesn’t create folders you’ll need to create a folder
Sailfish OS/Backups
in your Nextcloud files to get it working. That was what I wanted to say.

Nevertheless following your link I discovered that the account settings/path can be changed later from advanced settings… Wasn’t aware of that.

Well, If I remember correctly, the Sailfish is creating the set path at the server correctly…
It worked at least for me.

Hi, sorry for the late reply. Well ich checked all the paths and created some for the backup (the Photo Path was standard).

I checked the WEBdav path settings, and they are simmilar to the ones in the Sailfish acount settings. (or I mede them simmilar :slight_smile:

sample: https://xxx.xxx.xxx.xxx (IP)/nextcloud/remote.php/dav/files/MyCloud/ => created folder=> SailfishOS/backup

in the nexloud android app the syncing works fine. the created sailfish OS folder is shown and usable.

the system-backup of Sailfish does stil not work. Also no photos have been synced. No idea what I am doing wrong. that is why i ask for a step by step ducumentation how to set it up the right way, or how Jolla is thinking it should work…

Syncing ist supposed to work only in my local area network. without wifi even the Android app is not syncing.

I had the same problem with nextcloud running on DSM. It is not a sailfish issue, for some reason webDAV does not work on nextcloud on top of DSM if you do not run it in the web root folder. I soved this by using a virtual host. Alternatively you could move your nextcloud instance to the web root. Forwarding via htaccess seems not to work, at least I read that.

Solved my problem with backup file on Nextcloud.
My certificate configuration is:
root-certificate -> ssl certificate
error uploading file was: apache 401 (could not upload file - access denied)
I have to place my root-certificate on the phone directory ‘/usr/share/pki/ca-trust-source/anchors/’ (pem format).
Then i use ‘update-ca-trust’ script to place the certificate to the right destination (verifying on settings -> certificates -> tls).
Now backup works fine :wink:.

It seems not to be possible to import own root certificates on the frontend :thinking:. But maybe this is not desired …

I too am having issues with getting the Nextcloud account to work.
I’m running a fresh NextCloudPi instance, and have ticked the “Ignore SSL-errors” option in the account settings.

The logging in succeeded when creating the account, but it is throwing HTTP 401 left right and center behind the scenes (journalctl).
Both when doing synchronize in the account settings, and when opening the backup page.

e.g.

maj 07 19:55:21 Xperia10-DualSIM nextcloud-backupquery-client[31047]: [W] unknown:0 - Nextcloud "nextcloud-backup" sync for account 10 finished with error: "Remote directory listing failed (http status=0)"
maj 07 19:55:21 Xperia10-DualSIM nextcloud-backupquery-client[31047]: [C] unknown:0 - Nextcloud Backup sync failed: 401 ""

The WebDAV path is (automatically) set to /remote.php/dav/files/ncp which is consistent with what the web GUI tells me to use for files.
The folders “Sailfish OS” and “Backups” beneath it exists and have the same permissions as e.g. Pictures.
I have enabled automatic filesystem sync, so they show up in the web GUI.
The backup path is set to /remote.php/dav/files/ncp/Sailfish OS/Backups
…so it should work?

Any ideas what i might have missed?

Edit: and the nextcloud instance works with my file browser on my desktop, nemo ( :slight_smile: ) so at least there is something right about the setup.