Nextcloud backup still broken for host.tld/nextcloud

REPRODUCIBILITY (% or how often): 100%
BUILD ID: 3.3.0.16
HARDWARE (Jolla1, Tablet, XA2,…): XA2
UI LANGUAGE: English
REGRESSION: (compared to previous public release: Yes, No, ?): Yes

DESCRIPTION:

When using a nextcloud installation hosted at host.tld/nextcloud instead of nextcloud.host.tld backup does not function.
End of log error message looks like this:
Status = Finished
Removing working files in /home/nemo/.local/share/system/privileged/Backups-tmp/units/sailfish_backup_2020-09-13T14-59-38Z
[UI] Triggered backups upload to cloud account 5 from dir /home/nemo/.local/share/system/privileged/Backups/cloud
[UI] Uploading backup to cloud service
[UI] Sync error: , details:
[nemo@XperiaXA2 tmp]$

PRECONDITIONS:

STEPS TO REPRODUCE:

  1. Setup test account at host.tld/nextcloud
  2. Try to backup

EXPECTED RESULT:

Backup at my nextcloud server

ACTUAL RESULT:

Backup fails with above error message

ADDITIONAL INFORMATION:

Filesync works fine with Android Nextcloud application I also have installed on this XA2 and another Android phone.

Previously discussed here: https://together.jolla.com/question/224331/330-issues-with-nextcloud-integration/

3 Likes

The integration is still badly broken in 3.4.0.24. But I found one thing that can explain a bit of the seemingly illogical behaviour in the new version: Even if I change the parameters in the Advanced section of the account setup, the integration will still use the old settings from somewhere!!! Even tried a reboot after the change. Still old paths in the Nextcloud access log. The only way to really change the paths was removing and then reentering the account.
Using a Nextcloud server with

  1. Selfsigned certificate
  2. Direct path to Nextcloud with no subpath

But ATM the situation is like this:

  • Calendar seems to work
  • Address sync seems to work
  • Uploading a photo seems to work but no auto upload of new photos, let alone syncing of all photos.
  • Backup to Nextcloud fails. Cannot even find any logging any more.
  • No way to manually upload/download a file to Nextcloud

Was really expecting more from the update.

I also installed NextCloud on my Synology NAS and tried to conect to via acount settings in Sailfish OS. It failed. I have used 2 users in NextCloud. One with a two way authenticator, the other without. The Android app works fine, even with two way authenticator. The connection i use is via Local Area Network, so i can not connect otside my WiFi. Is there somewhere a “howto” guide for connecting NextCloud to Sailfish OS?