No Backup possible on Nextcloud in local network

REPRODUCIBILITY (% or how often): 100
BUILD ID = OS VERSION (Settings > About product):
HARDWARE (XA2, X10, X10 II, …): X10
REGRESSION: (compared to previous public release: Yes, No, ?):


I have a nextcloud server in my local network ( just a network with access points without internet connection). When I connected to the network and want to perform a backup, the gui tells me “Connection failed. An internet connection is necessary to perform a backup at a cloud provider” so I am not able to make a backup on my own nextcloud server. The server works fine, i sync my cal and contacts with it on the phone. There is an issue to, that the phone does not recognize it, but it seems to work, when the sync is not triggerd manually but with auto sync every 15 min, but that is a different topic. I want just to ensure, that the nextcloud server works fine and is right configured on the phone.


Setup a nextcloud account and run it in a local network without internet access. Configure it on your phone and try a backup.


see above


A backup is performed on a local server, even when the local network has no internet connection


not possible to perform a backup


i am pretty sure, that the problem will relate in a check, whether you are connected to a network or not. But instead to check the connection to a network, the connection to internet is checked.


it seems to me that this is related to other reports that several Android apps don’t work if you don’t have a full internet connection. When you connect to a network, connman (?) pings to test whether the connection works or not. If it fails, due to a missing internet connection, firewall, ipv6-only network or any other reason. connman claims to have a limited connection which in return let other applications stop operations.

I’m not sure whether to blame connman or the apps that refuse operation though they could work.


Is there a chance to see this fixed in the next release? I would be great to connect to any account running on a server independent from a connection to the internet.
Best regards

Problem still exists in :cry:
Has anyone an idea, how to perform a backup on nextcloud server in a private lan without internet connection?

One rather dirty workaround, possibly with nasty side effects, would be that you add an entry to your local /etc/hosts file that points to your local host, i.e. Hence conman will assume that you’re online and you can try to run the backup again.

Be aware, I don’t know what conman does when it thinks it’s always online. If I run such an experiment I would connect the phone via USB to your PC and connect to the phone through an ssh connection via your USB line. So you can make your changes and fix them if conman gets confused.

Thanks for making this report @lukas_jolla2015, and for the helpful suggestions @jollajo. I’ve created an internal report about this and so have also tagged it as “tracked” here. If there’s progress to report on it, we’ll do our best to share it with you here.

This Bug still exists in
I am pretty sure now, that the check for internet connection causes the problem.
Here you see a screenshot from backup menu when in my local lan:
You can see all nextcloud options are marked red.
Here you can see, what happens, when I configure a autobackup nevertheless:
It works! The same behavior on CalDAV Account on this nextcloud. Manual sync does not work, auto sync works. So it seems, as if there is no or an other kind of checking the internet connection.
Furthermore I tried the following. I connected to an AP, which was connected with the internet. Then I plugged the AP ethernet cable from internet to my local lan. Here we go:
simulated connection
In this case every backup options are available and are working as they should.
So again my request. Change the check of internet connection. Maybe you can ping a server through internet, but when you dont get an answer just ask the user “do you want to proceed because you are in a local lan?”.


Hello Lukas,

did you ever find a solution for this? It seems even in it seems that local nextcloud-sync doesn’t work…

Kind regards,


well, no real solution, but a working workaround as I described above.
You have to connect to your local LAN and the wait until an automatic sync was performed. You will not see it on the phone, but it syncs.



Could you please copy your Nextcloud account settings? Offcourse, with fake domain/IP name
Thank you!

Hi Lukas,

thanks for your reply, which is really helpful.

I accomplished to get backups into nextcloud (even reported on the notifications page :wink:), but no sync of contacts yet.

Will have to dive into the logs of SFOS and NC…



contacts should work, what I do not get synced are calendars. Therefore I added a CalDAV/CardDAV account, which does the sync of the calenders.
@calinutzzz: here are my settings:

  • Serveradress: http://myIP/
  • SSL faults disabled
  • 2 way sync activated
  • “if content changed on device aotmatic sync” active
  • all kinds of content to sync active exapt of calenders and the last one

under advanced settings:
Webdav: /nextcloud/remote.php/dav/files/username
contacts: /nextcloud/remote.php/dav/addressbooks/users/username/contacts
calendar: empty
pictures: /nextcloud/remote.php/dav/files/username/Photos
backup: /nextcloud/remote.php/dav/files/username/Sailfish_OS/Backups

username has to be replaced by yours.



1 Like

Thank you very much @lukas_jolla2015 !

your are welcome :slight_smile: 20 chars