Network connection freezes in WLAN with FritzBox

REPRODUCIBILITY (% or how often): nearly every day, but not in predictable time
BUILD ID = OS VERSION (Settings > About product): 4.2.0.21
HARDWARE (XA2, X10, X10 II, …): Xperia X
UI LANGUAGE: En
REGRESSION: (compared to previous public release: Yes, No, ?):

DESCRIPTION:

Since half about half a year my XperiaX freezes it’s network connections when I’m in my home-WLAN. All other WIFI-Connections seem to work fine - e.g. at work I have no problems.
When the connection is frozen there is no more network activity possible:
* I cannot turn on/off WIFI, Mobile Internet, Bluetooth or FlightMode
* The Connection-Icon shows a Wifi-Connection is active
* Even if I leave the house it still shows a wifi-connection.

To get a new connection I need to restart the phone.
The timing of this seems to be random. Sometimes it’s nearly instantly broken and some rare days it works without interruption.

Receiving an SMS or Phone-Call seems to interrupt the connection instantly.

Are there any useful logfiles I could take a look at?
Is there any way to reset my network connections without rebooting the whole device.

ADDITIONAL INFORMATION:

My home-Wifi is powered by a FritzBox 7490. No other device seems to be affected. In any other WIFI there are no problems.

Thank you.

I can confirm exact the same problem with Fritzbox 7530 AX. I have a X10 with current OS 4.2.0.21, too.
Would also be very interested in how I could investigate the problem.

No problems here with Fritz!Box 6591, 6490, 7170, 7560, 7590 and some more.
Maybe it is some configuration issue?

I can confirm exactly the same behavior on my Xperia-X (F5121, SFOS 4.2.0.21)
Unfortunately, the complete loss of network connections is not indicated.
Usually I only notice when I open the Sailfish-Browser and see that most of the favorites icons are no longer displayed.
Then only a soft reset (Power+Vol.Up) helps until the next crash.
But this is not a new bug, it was already reported in the old Jolla-Forum.
https://together.jolla.com/question/205934/sailfishx-wifi-firmware-crash/
https://together.jolla.com/question/225927/xperia-x-complete-connectivity-freeze-with-accesspoint-steering/
Unfortunately without a practical solution.
It has been suggested that it has to do with AP-Steering (802.11v/k)
This assumption could be correct.
I use an AVM 7560 as access point and an AVM 2400 repeater with mesh steering.
Since I cannot deactivate the AP-Steering because of the other WLAN users, I only have the option of not using the WLAN with my Xperia-X
Therefore I would be very interested in a solution or at least in a workaround.

My setup here: XA2, Verla and Fritz!Box 6591 with two meshed 2400 repeaters. 2.4 and 5 GHz Network, WPA2 (CCMP), canal auto selection, about 70 2.4 GHz Networks and about 14 in 5 GHz range nearby. Normally 3-6 active devices.

This worked similarly well with my Xperia X when I had a 6490 and only one repeater.

I have these problems since I started to play with the configuration of the router. To be sure, that all problems concerning this are gone, I have reseted the router to production settings.
Where are the configfiles of the different known wifis stored on the phone. Maybe not everything is deleted by using the “forget” function. Due to the fact, that all other devices work fine with the router and my phone works fine with every other router, the problem must be in the configuration of the wifi of the fritz router.

I started having the same problem since the very moment I added two Fritz-repeaters and established a mesh-network into my home-network. So for me its obvious that it’s a problem with the mesh: my wifi freezes on the phone when it seems to change the access points. Before that, without a mesh-network, everything went fine for years.

I have a mesh network with two repeaters here. Works.
But we throw a lot of wireless bandwidth in our 85 square meters apparent.

I have the same problem with my Xperia X Compact, seems to be caused when i’m moving in the house between access points of the mesh network (fritz box router, fritz powerline network)

Maybe we have got two issues here. I am thinking so, because my problem does not deal with the mesh function; I am just using the router without any APs.
So my situation is, that I had a working setup, “played” with the router, problems ocured and because of that I made a factory reset of the router. I expected a working setup again.
Does anyone know, where the wifi network configs are stored? To my mind in my case the problem has to be there. I do not want to flash by phone due to this problem…

Take a look under (SFOS 3.2)
/home/.system/var/lib/connman
But it might have been relocated to
/home/$USER/.local/share/system/…
on newer SFOS version, not sure and cannot check ATM.

Thank you very much for that info, I found the folder using find -name connman in /, forgot, that we have linux here :slight_smile:
“Unfortunately” the forget function of a wifi network seems to work fine. When I use it, the config file disappears…
I tried now, to forget all networks, reboot the phone, and add network again. Right now it works, the question is, how long; I will inform here.
Really strange behavior.
@chris.adams: maybe you could give us a hint, where to look for the root of the problem?

:sob:
Changed nothing. After a few minutes the freeze is back. No Internet, not possible to switch off wlan, only vol up + power helps…

just a guess: does your fritz router switch automatically between different bandwidth? (like 2,4 / 5 ghz)? Maybe this could cause the same problem than changing access points.

@petervandeninseln That was a good hint.
I’ve deselected some settings in my Wi-FI Channels Settings in my Router-Configuration:


Previously the four checkboxes where active. And now it seems to work (at least for the last four days).

Thanks a lot.

After several days of functioning without any problems, the network connections crashed again.
Before, my Xperia-X had been out of WiFi range and had a cellular data connection.
After WiFi was available, it had successfully connected to the repeater,
but 15 seconds later the network connections crashed.

In the access point logs I can see that the frequency band and the access points were successfully switched several times during the days before.
At the time of the crash, no band- or AP-steering took place.
So I can’t see any direct connection between the AP- or band-steering and the crashes.

The Wi-fi channel settings of the Mesh Master were previously set to automatic.
Now I have adopted the setting which matebovate describes, with the exception of Checkbox 2 (switch automatically between 2.4GHz and 5GHz). Because the deactivation makes the mesh function useless for me.

Furthermore, I have adjusted the sailfish system logs to persistent, to hopefully get more information from the Journal next time. Does anyone have any idea what to look for in it?

Let’s see if this lasts longer, I’ll report here again.

@petervandeninseln, @senders : Thank You very much for the hint! These settings work for me, too.
Is the switching between 2,4 and 5 GHz described in the wifi standard? I am asking, because that would simply meen, that SFOS currently just do not support the latest standard. If not, it is an implementation bug.
Thank you again and best regards,
Lukas