Mounting Samba/CIFS folder working?

//192.168.1.2/folder    /home/nemo/123     cifs    ro,noauto,user=username,uid=100000,gid=100000,vers=2.02 0 0

Password for username@//192.168.1.2/folder:  ***
mount error(22): Invalid argument
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)

Anybody has it working?
PS Xperia 10, 3.3.0.

My J1 does not even have a mount.cifs binary … but the kernel module is available:

[nemo@Sailfish ~]$ zcat /proc/config.gz | grep CONFIG_CIFS=
CONFIG_CIFS=m

it’s in the cifs-utils package, not on stock fw.

cifs-utils is not packaged for J1, not available in the repos. You lucky guys with AOSP based devices!

woouldn’t this work?

@remote Oh, I’m sure it does (for others at least), thanks for the link. I hadn’t enabled that repository while searching for the package. Whilst being over six years old, it should still work.
Regarding your original question: what happens if you play with the mount arguments a bit, by omitting them one by one, to identify the one your mount.cifs binary doesn’t like?

I’ve tried, nothing helps.
If I remove ‘vers’ then it shouts with error 95.

So I’m not sure it works on SFOS, hence the question.

If the PC is not windows, you could mount with SSH

sshfs user@192.168.1.1:/some/path     /some/local/path

then to unmount

fusermount -u  /some/local/path
1 Like

I just installed NielDK’s cifs-utils package on my J1 and can confirm the EINVAL (error 22) for vers=2.02 only. If I omit this, I get an EACCESS (error 13).

I have a suspicion that this would have worked on an OS earlier than 3.3 … but I have no such device here to test.

1 Like