MMS On XA2 (Ultra) Not Downloading

Hi, not sure where to post this, as not sure if it’s a bug. Happy to move it on request.

When I get MMS messages on my relatively new XA2 it spins for a while saying “Waiting” then “Downloading”, then eventually, after some time, fails.

I moved my account across from an Xperia X using back-up & restore and have the same SIM as in the old phone. It worked okay there. I have done a reset on the APN settings and compared them to the listed ones for my phone provider (3 in the UK), and they look fine.

Is there some way I can troubleshoot this to find out the issue, or is this a known problem?
I’ve tried it on both Wifi & Mobile Data & Both.

2 Likes

Not sure about ‘3’ but some (a lot of) providers need you to send a MMS from that device to register/accept it as a MMS receiving-able phone.

1 Like

Thanks for the reply. I don’t think that’s the case here as I’ve never been able to send MMS due to tariff restrictions, though could receive them. I’ll try sending one (it will fail) and see if I can receive any after that.
EDIT: I’ve checked my tariff and though they’re not covered, they should work but just cost more. I’ve tried to send one, but it also failed after a long time trying. So it looks like MMS just isn’t working. I’ve gone through the 3 troubleshooting (fwiw) and there’s nothing obviously wrong.

Is anyone here on 3 using MMS successfully?

Here’s the settings:
Connection Name: 3 MMS
Access Point Name: three.co.uk
Protocol: IP
Authentication: None
Proxy Address: 217.171.129.2
Proxy Port: 8799
MMS message centre address: http://mms.um.three.co.uk:1002/mmsc

I would turn to network operator. I have XA2 and they work for me. At least receiving daily as I don’t send them much.

1 Like

I’ve had the exact same issues as the OP with receiving MMS messages on an XA2. When I first started using SFOS it didn’t work, then it did work for a few months, and has since stopped working again. All on the same device with the same SIM card, operator, and phone plan.
I don’t use MMS a lot and it isn’t a deal-breaker for me, so I haven’t invested very much time into debugging it (there is a guide on debugging MMS issues on the Jolla helpdesk site, but I haven’t tried it). I’ve seen and read numerous threads on TJC about MMS issues though, it seems to be a fairly widespread problem. I’ve also double- and triple-checked my MMS settings with my providers settings (Hallon in Sweden) and they are absolutely identical.

2 Likes

Thanks. I don’t know how well they’ll respond to a query for a non-Android/iOS phone. If I run out of other options I’ll contact their support though. See where we get.

Thanks for that - that’s useful to know. I’d missed the helpdesk guide and will check it out.
It’s not huge for me, as I only ever get them from one person about a sports club, but it’s irritating when I get three failed messages in a row in the run up to an event, and have to check to find out what they were. If it wasn’t for that, I’d probably not bother more than I have up to now.

EDIT - might have seen that guide, bits look familiar but bits don’t. I’ll try the MMS Logger.

I’ve been having a similar situation for years with T-Mobile in the U.S. but have found a workaround (of sorts). For me, the problem of receiving MMS messages only happens when Wi-Fi is enabled, so if I temporarily turn WLAN off, I can receive the message. It has something to do with IPv6 vs. IPv4 and my WLAN configuration, but I’ve never been able to figure it out, and since I rarely get MMS messages my workaround has been good enough.

If anyone has any ideas or needs me to post MMS config info, let me know.

3 Likes

I have the same problem on my Xperia X on Three in the Uk. Thing is, it used to work fine for years…but then stopped working a few months ago without me changing anything. Then I fiddled with the settings and it started working for a little bit…and then stopped again. Had a dig with the MMS logger and it seems that the connection just gets cut off. Could well be Three’s end.

2 Likes

When I have this issue, Wi-fi off and even with wifi off, I need to cancel and restart it. It then downloads immediately.

1 Like

Thanks for all of the replies, there’s a few things to work on and some useful info. I’ve been a bit busy but hopefully will get through all of this in the next week or two. I’ll post back on here if/when I get any progress (or fail to).

1 Like

Think I worked something out. I’ve been playing with it this evening and managed to affect things - set the MMS to use IP6 only, and make sure the network you’re connecting to supports IP6. For me, that means I have to be using mobile data - if it’s connected to my wifi it doesn’t work, probably because I have IP6 disabled.

2 Likes

I had similar problems with Smarty (which runs on the 3 network and has very similar settings). I used the settings from this site: https://kenstechtips.com/index.php/mobile-internet-apn-settings#Three which was the only one that mentioned the proxy configuration for Smarty… After that I was finally able to send and receive MMS on my XA2( Dual Sim). I can see you have IP configuration only for the protocol, I would switch it to Dual and restart the phone just in case… Hope you fix it soon…

2 Likes

Thanks for the extra replies, I’m going to try them over the next week or so. The problem I have at the moment, is that the only person who sends me MMS’s hasn’t for the last couple of months.

If I don find success though, I’ll come back and update. If none of the things I try work, I’ll try and update too.

Okay, I successfully recieved an MMS onver mobile data, using the same settings as above, but with the protocol set to “Dual”. I’ve only been sent the one MMS recently, so I don’t know how sticky this fix is, but I’ll assume for now that the issue is resloved.

Thank you to everyone who helped.

1 Like

Just be wary that any fix seems to be intermittent - I’ve thought I’d fixed it numerous times, yet I’m once again sitting here trying to get it to download a MMS I was sent today.

1 Like

I find that if I cancel the download and restart it, it works every time.