MMS download Xperia 10 II dual

REPRODUCIBILITY: 100%
OS VERSION: 4.4.0.58
HARDWARE: Xperia 10 II dual SIM
UI LANGUAGE: French
REGRESSION: I don’t know

DESCRIPTION:

I can’t retrieve MMS files or text

PRECONDITIONS:

I’m using network of a french Orange MVNO (named Telecoop)

  • The problem existed with the first version flashed on the phone, the latest 4.3, but I had to try to update
  • It took a month of various tests with the operator support service to be able to send MMS; I thought it was a network configuration fault. MMs aren’t critical but it’s a nice feature to have, especially receiving because I can’t answer everybody to never send me MMS
  • The only thing not working is downloading MMS data, sending is now OK (two days ago)
  • I search the forum and tried some of the solutions I found (setting to IPv4 only, IPv6 only or both, removing the proxy, restarting the phone (on almost every setting change), adding text to the picture, retrying multiple times, having data access on and off …)

STEPS TO REPRODUCE:

  1. Share a picture
  2. Send it by MMS to myself
  3. Receiving notification of MMS waiting to be downloaded
  4. It stalls on “waiting”
  5. Same thing while trying to retrieve MMS from a contact

EXPECTED RESULT:

  • Downloading picture and text

ACTUAL RESULT:

  • Stalls on “Waiting” and never downloads data (nor picture nor text)

MODIFICATIONS:

Nothing special

ADDITIONAL INFORMATION:

I used MMSlog and found this while waiting for the download:

2022-04-22 23:01:11 [dbusaccess] Name ':1.92' timed out
2022-04-22 23:01:13 [dbusaccess] Name ':1.11' timed out

Those are the last lines for a long time before I give up downloading

The numbers after the dot may change, I just got :1.96 and :1.8

Thanks !

3 Likes

Oh ! :astonished:
I was trying one last setting before giving up …

I activated “Download MMS automatically” and… it worked ! (at least for an MMS sent to myself, I can’t ask someone to send one at this hour) :no_mouth:

Its really cool, but could I find info why it’s not working without this ?
I still can’t retrieve past MMS and that’s why I would like to make it work both ways, in case I receive MMS in a “no data” network zone, I’ll have the notification but won’t have the file.

I’m sure the timeout is the key, but I don’t understand why would it make a time out when retrieving manually and not when it’s automatic :thinking:

Thanks !

1 Like

This has been a long running issue on a number of devices and carriers. It’s not universal, it seems, but most people who have it, and fix it, seem to have it return at some point. There are a few threads on various MMS issues, but I reported a very similar issue to this a while back:

FWIW I have the “Download MMS automatically” turned on, so I would be very interested to see if this issue returns for you. I do hope it doesn’t though.

1 Like

Thank you for your answer and link, your post was one I missed during my search (I did read some of the answers in search though)
I’m sad and relieved to see I’m not alone with this issue, hope they’ll be able to fix it soon.

I’ll come back to tell if the problem returns while “download automatically” is still turned on.

(did you check MMC and MNC parameters automatically configured with those your provider asks for ? See here: https://github.com/sailfishos/mobile-broadband-provider-info/blob/master/mobile-broadband-provider-info/serviceproviders.xml
The update might have changed one it shouldn’t )
Thank you !

1 Like

Still does not download on 10 II (auto dl enabled, parameters set)

2 Likes

Hi, I’ve repeatedly checked the parameters and changed them manually. I only get MMS every now and then, so it’s hard to find any patterns. That said the one (or two) times I did get it to work, it broke again and the settings I had for it to work, were still in place, so I’m thinking it’s not a problem with the settings, but something in the OS - it may be a race condition that’s almost device dependent (just a guess).

As I say, I hope your case is different and it’s just that setting.

Very interesting, thank you for your replies

Are your devices in 64 bits or not ?
XA2 is not if I’m not wrong, mine is

1 Like

Apparently it is 64bit: Sony Xperia XA2 Ultra - Specifications

“every now and then” could mean that you have a host name for MMS proxy (not to be confused with message center URL!) which only works when/if it can be resolved. Sailfish OS doesn’t support DNS name resolution over MMS data connection.

If that’s the case, then the fix would be to replace the host name with its IP address resolved via public DNS.

1 Like

Hi, thanks for the suggestion. The Proxy is the IP address - and I’ve also just double checked it’s correct.

Just to clarify, as my message was ambiguous, but what I mean is, I only get sent an MMS message every now and then. The failure rate is a lot more consistent than that, with hardly any working. I

This is a serious strange bug because MMS is still essential for some and it worked until 4.3 without any issues.

1 Like