microG on Xperia 10 II

Good Morning,
I am trying to use MicroG : I have installed
MicroG parameters,
microG services
UnifiedNlp legacy

In the autoverifaction section i do not have “playstore (phonesky) installed” ticked
I can’t find it on Fdroid and (secondary problem : i cant use Yalp).

Anybody can tell me where to find the phonesky app ?

1 Like

Hello,
Install ‘fakestore’ from F-droid.

thank you phklrz,
I have installed this “fakestore”. I Have it ticked as installed now but I still have 2 boxes unticked which are “Phoneskyhas the good signature” and at the bottom “enable this app to work instead of others”.

By reading the forum i found this method :
https://together.jolla.com/question/209300/how-to-microg-in-sfos-31/

I don’t understand the sentence " Install Coderus’ Aliendalvik control"
What am i supposed to do with this link ?

Sorry this must look very basic questions to some of you but i am totally new to the “play with your phone” game.

You do not need to install Aliendalvik Control because you can simply start the Android settings from the Terminal with
apk-launcher com.android.settings

their must be something i do wrong :
i get the invite :
defaultuser@xperia10plus-DualSIM ~]$
i type your command defaultuser@xperia10plus-DualSIM ~]$ apk-launcher com.android.settings
the phone answer is :
/bin/bash : apk-launcher : not found
do i have to log as root just as in my computer ? If yes what are the logins and password ?

Sorry, there was a typo :frowning: The correct command is

apkd-launcher com.android.settings

The “d” in “apkd” was missing

That’s not working anymore. This works:

apkd-launcher com.android.settings/com.android.settings.Settings

4 Likes

Thank you both : It worked I now have signature spoofing on green.
Sadly the app i do all this for need Location and the GPS on my phone does not work -or I have never found the way to make it work-.
In microG’s location modules it propose Mozilla location service. Is niminatim a good “adress lookup” ?

I might as well hijack this thread: I’m trying to install MicroG on my Xperia 10 II running the latest Sailfish update. I followed all of the steps in the TJC thread linked above, and all boxes (except the ‘foreground’ box) in the Micro-G self-check are ticked, but when I check the permissions section of the Android settings, 0 apps show up under the ‘enable system package replacement’ permission, so I can’t give FakeStore or the MicroG Service Core the permission. I’ve already tried restarting the Android App Support, but it doesn’t help. I suppose I’m doing something wrong… but what?

Indeed, you cannot check ‘enable system package replacement’ in permissions section of Android - but in my case MicroG works anyway. What does the Signature Spoofer Checker say?

Thanks for the hint! I just checked with Signature Spoofing Checker, and it said spoofing was enabled, then I tried one of the non-working apps again and… all of a sudden it works. Weird! Still can’t check ‘enable system package replacement’, but apparently it isn’t necessary.

it’s exactly the same here … initially it bothered me a bit but since everything is working fine I don’t care anymore

Well, all of a sudden it doesn’t work anymore, apps are complaining about missing Play Services again. Signature Spoofing Checker still says spoofing is enabled.

any update on this? i have the same problem “enable system package replacement” has 0 apps to enable

Yep, “enable system package replacement” is empty too for me, but you can enable options directly from “Spoofing checker”. You only need to tap on options to enable them

1 Like

I have the same problem like nthn and Simerax . @carmenfdezb how does your solution work? If I open the androidsettings for fakestore or the microg-service it doesnt show the option for “enable system package replacement”. And like nthn wrote, under the android-settings opened through terminal has “0 apps” in this section.

Open microG settings, go to ‘Self Check’, scroll down till end and tap on “Battery optimizations ignored” (tap on text) to enable it. Then, scroll up and just enable every option.

Thats it - thank you!