MicroG on SFOS 4+

I’d like to switch to SFOS from android and I am worryed about some apps. I already use android with microG that I need for some applications. I saw this on YouTube: SailfishOS Podcast: MicroG + GoogleMaps install - YouTube and it looked to easy XD. Can anyone here tell me if it really works? Are there some things I should know before? Thank you

1 Like

Works just fine for me. Didn’t watch for specifics in the video, but procedure looks familiar and Leszek knows his stuff.

Do you use microG? Is there a different way to install it?

Yes, it works fine as far as i can tell.

I guess you could do some similar offline-shenanigans as those who sideload the real Play Services.
But the way in the video is the normal/“easy” way.

OK, thanks a lot. Didn’t know you could sideload apps. I think issue solved then

Sideloading apps via FDroid and Aurora Store is easy - and with MicroG in place I have yet to find an Android app that does not work. Apparently some Bluetooth services are missing for some Android apps but I did not miss any so far.

Thanks for sharing your experience. Did you install with the methon in the video?

I followed the instructions of DrYak: How to install MicroG

To get to Android settings, I launched them manually in the terminal: apkd-launcher com.android.settings

I had to enable Allow apps to see account in aliendalvik control → settings → Accounts->my gogl account->Personal info & privacy. Before that I wasn’t able to use google for storing Whatsapp backups. When signing in I got something like “you already have signed in”-message, but I wasn’t able to choose the account. I think this is missing in DrYaks instructions.

Unfortunately, Aliendalvik-Control is not available for aarch64. Does anyone know, how to access Android settings without it?

You can access Androis settings via terminal (see above):

I suppose you enabled developer mode so you have the terminal …

Sorry, did not see your previous post. Yes, dev mode is enabled and Backup works as expected. Thank you!

I am happy it is working!

I get this on sfos4.1 aarch64:
Screenshot_microG
and I can’t enable System Package Replacement under android permissions.
But I can download any app I’ve looked for and they work ok…so just out of curiosity is the System Package Replacement permission necessary or not?

Probably it’s not that important

I just checked with my Xperia 10 ii, SFOS 4.1: system package replacement is not enabled (at least Android settings say so), but everything appears to work, so as @CarloAlberto said, it’s apparently not important

Happy to know for sure that now. I’ll buy my Xperia 10 II as soon ad possibile then

on 4.0 this was solved by editing a file that had defaultuser/nemo problems but I understand this has been fixed. I won’t bother until I find an app that doesn’t work