MicroG / Fake Store on SFOS 4.5

After I have updated to SFOS 4.5 Fake Store (MicroG) dispread.

I have tried to install it again using the method described in page: “Installation · microg/GmsCore Wiki · GitHub”.

I have also added the Depots mentioned in page “F-Droid repository - microG Project” to F-Droid (again) and installed from here.

Northing of above will install Fake Store, any other with the same issue or is it me doing something wrong.

Its looks like FakeStore is installed but no icon is present. I have just tried with BlankStore and here same issue.

Note this issue is when using SFOS 4.5.


Do you have the “disable android package checking system*” ticked in the android setting subsection ?

*No sure of the actual text my phone is in French

FakeStore isn’t supposed to have an icon. That does not mean it isn’t installed or that it isn’t working. If you want to check whether it’s installed you can use android settings for that.


sanginteret: Yes I have, did not check that but now I have.

vige: I did have an icon when using SFOS 4.4 and I still have on my Xperia XA2, so why I have an icon I do not know. When using Aptoide I can see that FakeStore is installed in F-Droid.

I have exactly the same issue:
Screenshot from my XA2 with sfos 4.5:

Screenshot from my 10 II with sfos 4.4:

In addition, microg isn’t working fine on sfos 4.5. In particulary, sevici app (needs microg) was working fine on sfos 4.4 and since I updated to 4.5, doesn’t work:

1 Like

Same here - confirming the issue

dito here, MicroG Cloud messaging no longer works for me for Signal and Threema, and Share-Now (carsharing app) e.g. complains about missing google services. OTOH some apps sometimes seem to be able to register for cloud messaging (e.g. Myfritz, Unifi) - but not always. This worked fine in 4.4, and “disable system verification” is enabled here as well.

Some apps which complain about missing google services need the latest version of FakeStore (0.1.0). Unfortunately F-Droid by default installs an older version, you must specifically choose the correct version.


Thank you, worked for me so far!

Thank you so much!! Updating fakestore from here worked for me too!!!

Thanks a lot! Updating fakestore to 0.1.0 worked for my problem with the carsharing app, and after deleting the microg data and re-enabling eveything egain in microg, Signal and Threema now use cloud messaging again (in Threema I had to manually disable Threema Push, which was possible now)


Google Meet says “Failed to load accounts”, even after updating FakeStore as instructed above.

I wonder if this is a different problem?

I did upgrade from version 0.0.2 to 0.1.0 with same error, BUT after I have tried again A notice that I missed a checkmark in MicroG and now its working :slight_smile:

Hmmmm - It seems that I have to re-install to earlier version for reason below mention.

For some users who have problems with VoLTE, do not upgrade to 4.5.

First VoLTE is not working and when not using VoLTE the other part cannot hear what you are saying – A REALLY NO-GO.

New in this.
Here is what I did:
1. Open Terminal and run “pkcon refresh && pkcon update”
2. Login as Root “devel-su”
3. I have zipper installed so run” zypper ref && zypper dup” (zipper uninstalled the lates version of Chum)
4. Run “zypper ref && zypper dup” again and Repositories was changed from Chum to others.
5. Run “version –dup”
6. Restarted the phone
Now the Microphone is working again :blush:
What of above points that did help I do not know, maybe the last point or all points :blush: