Main camera does not start

Yeah. Same here. I don’t face this issue in my Aqua Fish.
In my Sony XA2 alone often I get cannot open camera error, flash light failing to get started.
So I configured to turn off and turn on AD around 12:00AM and as a result the number of times the issue happening has reduced.

I guess it’s a issue with the new 8.1 AD and it lacks few features(like sending/reading SMS) that was present in 4.4(it was robust too).

1 Like

@jovirkku

Please see attached output. First part is when not working, second part is after my workaround kill commands.
Do you see anything?

NOT working 
[nemo@ ~]free -m; ps aux | awk '{print $2, $4, $11}' | sort -k2rn | head-n 20total        used        free      shared  buff/cache   availableMem:           2639        2160          51           2         427         377Swap:           511         420          9121903 10.0 /usr/bin/sailfish-browser6586 6.9 /usr/bin/lipstick7823 2.8 system_server27645 2.5 /usr/bin/jolla-camera6989 2.4 /usr/bin/voicecall-ui24173 2.2 com.whatsapp23707 2.0 /usr/bin/jolla-email8136 1.9 com.android.systemui9031 1.8 /usr/bin/fingerterm15578 1.6 com.tripadvisor.tripadvisor6962 1.6 /usr/bin/maliit-server21301 1.3 com.stickify.stickermaker27815 1.3 booster8228 1.2 com.android.phone21075 1.1 /usr/bin/harbour-advanced-camera8410 1.0 com.myriadgroup.home8757 1.0 com.google.android.gms26795 0.9 booster5129 0.9 /usr/bin/jolla-notes8423 0.9 com.myriadgroup.inputmethod.remote

Working (after my 'workaround'j
[nemo@ ~]$ free -m; ps aux | awk '{print $2, $4, $11}' | sort -k2rn | head -n 20total        used        freeshared  buff/cache   availableMem:           2639        2233          632         343         305Swap:           511         439          7221903 9.4 /usr/bin/sailfish-browser6586 6.8 /usr/bin/lipstick25329 2.4 /usr/bin/harbour-advanced-camera7823 2.2 system_server6989 2.1 /usr/bin/voicecall-ui8136 1.7 com.android.systemui9031 1.6 /usr/bin/fingerterm26795 1.5 /usr/bin/harbour-shellex23707 1.4 /usr/bin/jolla-email24173 1.4 com.whatsapp6962 1.4 /usr/bin/maliit-server8228 0.9 com.android.phone29257 0.8 booster5129 0.8 /usr/bin/jolla-notes8410 0.8 com.myriadgroup.home8436 0.8 android.process.media15929 0.7 de.dwd.warnapp6954 0.7 /usr/bin/meecastd8423 0.7 com.myriadgroup.inputmethod.remote8757 0.7 com.google.android.gms

Sorr for any missing new-line breaks. But that is another story / shortcoming of SFOS clipboard…

Another occurence of flash light not working just now.
@jovirkku
I did not run the terminal commands.
But I had only sf browser open and a terminal.
I closed the browser window and flash light was working again.

@jovirkku
Another occurence.

I had only terminal, email and browser open.

Flashlight and cam did not work.
I closed email (as having browser under suspicion) . AND flashlight/cam worked.
I re-opened email but everything kept working.

So I remembered that I had WhatsApp open this morning and opened that as well:
Bam, flashlight/cam not working.
I closed WhatsApp and it worked again (looking to me as some bad memory handling, see above already mentioned link. See logs:

free -m; ps aux | awk '{print $2, $4, $11}' | sort -k2rn | head-n 20total        used        free      shared  buff/cache   availableMem:           2639        2284          46           9         308         246Swap:           511         468          4322928 10.2 /usr/bin/sailfish-browser6586 7.6 /usr/bin/lipstick7823 2.5 system_server25024 2.0 /usr/bin/jolla-camera3159 1.7 /usr/bin/jolla-email793 1.6 com.whatsapp9031 1.6 /usr/bin/fingerterm6989 1.4 /usr/bin/voicecall-ui6962 1.3 /usr/bin/maliit-server8136 0.9 com.android.systemui14025 0.7 booster6954 0.7 /usr/bin/meecastd13340 0.6 booster29108 0.4 /vendor/bin/hw/android.hardware.camera.provider@2.4-service6956 0.4 /usr/bin/harbour-ringingrestorer7042 0.4 /usr/bin/messageserver57814 0.4 /usr/libexec/tracker-extract8228 0.4 com.android.phone7812 0.3 /usr/libexec/tracker-store8410 0.3 com.myriadgroup.home
free -m; ps aux | awk '{print $2, $4, $11}' | sort -k2rn | head-n 20total        used        free      shared  buff/cache   availableMem:           2639        2307          67           1         264         231Swap:           511         508           322928 7.7 /usr/bin/sailfish-browser6586 7.0 /usr/bin/lipstick7823 2.2 system_server14903 2.0 com.whatsapp25024 2.0 /usr/bin/jolla-camera3159 1.7 /usr/bin/jolla-email9031 1.6 /usr/bin/fingerterm6989 1.3 /usr/bin/voicecall-ui6962 1.2 /usr/bin/maliit-server8136 1.1 com.android.systemui14025 0.7 booster6954 0.7 /usr/bin/meecastd13340 0.5 booster8228 0.5 com.android.phone29108 0.4 /vendor/bin/hw/android.hardware.camera.provider@2.4-service6956 0.4 /usr/bin/harbour-ringingrestorer7042 0.4 /usr/bin/messageserver58410 0.4 com.myriadgroup.home8423 0.3 com.myriadgroup.inputmethod.remote8436 0.3 android.process.media

Another one, BAD:

free -m; ps aux | awk '{print $2, $4, $11}' | sort -k2rn | head-n 20total        used        free      shared  buff/cache   availableMem:           2639        2204          94          25         340         311Swap:           511         498          1322928 10.7 /usr/bin/sailfish-browser6586 7.9 /usr/bin/lipstick6147 3.7 /usr/bin/jolla-email7823 2.8 system_server14903 2.6 com.whatsapp9031 1.6 /usr/bin/fingerterm6962 1.5 /usr/bin/maliit-server6989 1.5 /usr/bin/voicecall-ui8136 1.5 com.android.systemui13340 0.9 /usr/bin/jolla-notes8228 0.9 com.android.phone8410 0.8 com.myriadgroup.home8423 0.8 com.myriadgroup.inputmethod.remote17940 0.7 booster6954 0.7 /usr/bin/meecastd8436 0.7 android.process.media8757 0.7 com.google.android.gms15929 0.6 de.dwd.warnapp6956 0.6 /usr/bin/harbour-ringingrestorer8507 0.6 com.google.android.gms:locservice

After killing all cam processes still does not work(???):

free -m; ps aux | awk '{print $2, $4, $11}' | sort -k2rn | head -n 20total        used        freeshared  buff/cache   availableMem:           2639        2289          4522         305         228Swap:           511         509           222928 14.7 /usr/bin/sailfish-browser6586 7.9 /usr/bin/lipstick6147 3.1 /usr/bin/jolla-email7823 2.6 system_server14903 2.3 com.whatsapp9031 1.7 /usr/bin/fingerterm17940 1.5 /usr/bin/harbour-shellex6962 1.5 /usr/bin/maliit-server8136 1.5 com.android.systemui6989 1.4 /usr/bin/voicecall-ui13340 0.8 /usr/bin/jolla-notes24798 0.8 booster8228 0.8 com.android.phone8410 0.8 com.myriadgroup.home6954 0.7 /usr/bin/meecastd8423 0.7 com.myriadgroup.inputmethod.remote8436 0.7 android.process.media15929 0.6 de.dwd.warnapp8757 0.6 com.google.android.gms25019 0.5 /usr/bin/jolla-settings-system-flashlight

And after running again
my kill cam command I do see some native applications killed (!), which MUST NOT happen, especially terminal!!!, and it is working…

free -m; ps aux | awk '{print $2, $4, $11}' | sort -k2rn | head -n 20total        used        freeshared  buff/cache   availableMem:           2639        2235         1029         302         295Swap:           511         497          1422928 14.2 /usr/bin/sailfish-browser6586 7.9 /usr/bin/lipstick27226 2.8 /usr/bin/jolla-camera7823 2.2 system_server28458 1.8 /usr/bin/fingerterm24798 1.6 /usr/bin/harbour-shellex6962 1.5 /usr/bin/maliit-server26470 1.3 com.whatsapp27878 1.3 booster6989 1.3 /usr/bin/voicecall-ui27752 1.0 /vendor/bin/hw/android.hardware.camera.provider@2.4-service8136 1.0 com.android.systemui27601 0.9 booster6954 0.6 /usr/bin/meecastd27100 0.4 /usr/bin/jolla-settings-system-flashlight8228 0.4 com.android.phone8410 0.4 com.myriadgroup.home6956 0.3 /usr/bin/harbour-ringingrestorer7042 0.3 /usr/bin/messageserver58423 0.3 com.myriadgroup.inputmethod.remote

And another, look at RAM and swap used…This time I attach txt files …… oh no I cannot attach other than pics! :frowning:If you need more details let me know how to send you…
Oh, and you see: missing line breaks! I copied text from already written post from browser and pasted into browser!

1 Like

On my device this is related simply to activation / deactivation of android support. Can anybody try on theirs too?

  • Make sure the fllashlight (or camera on picture mode, not video) opens up at first try.
  • Close every app and start android support from settings. When it’s activated you can test again if the flashlight/camera works (but most times it does).
  • Close everything, and deactivate android support.
    There we go, flashlight does not work at first try or camera shows a dark screen (test with one of the two app at a time).This behavior can be reproduced 100% of the times on my XA2 on rokua.
2 Likes

I can more or less confirm this.

Whereas on my device (XA2 dual SIM, 3.2.1.20) it is a bit different. After deactivating android support cam/flashlight works. But after activating it cam/flashlight does not work.

With uptime of

uptime16:02:58 up 13 days, 14:27, 0 users, load average: 7.04, 7.00, 6.93

and mem situation of
working, Andy off

free -mtotal used free shared buff/cache availableMem: 2639 1902 174 1 563 638Swap: 511 333 178

not working, Andy on

free -mtotal used free shared buff/cache availableMem: 2639 1877 50 2 712 662Swap: 511 340 171

working, Andy on, after running my kill cam script

free -mtotal used free shared buff/cache availableMem: 2639 1879 300 2 459 660Swap: 511 359 152

1 Like

Thanks for testing… It would be interesting to know if everyone who has this problem is tinkering with android support or keeps it always on…

P.S. You gave me the idea to test it after a full reboot and still my camera does not start after deactivation of AS… weird indeed…

I’ve got the same problem, camera and flash/torchlight mostly not working on first try. Closing one or more apps often helps, but not always immediately. I have a XA2. I am not using Whatsapp but using Firefox, Telegram, Tutanota Mail (all Android) and Tidings which are running most of the time. I keep Android support always on except there is a problem. No “tinkering” with AD.
I did a quick test right now. Opening camera didn’t work, closed camera app, stopped AD, opened camera again and it worked. Started AD, camera didn’t work again. So it seems there may be a connection between blocked camera and running AD support at least for me.

2 Likes

Thank you. If this is confirmed by more people at least we have a 100% reproducible scenario, which might be useful to the devs.
I have been testing for a few days without ever activating AD support and never had the issue.
So far we have:

  • 100% reproducible either on activating or deactivating AD (both required to get 100%).
  • Occasional to frequent when keeping AD on
  • No issues without AD (apart from the first time after deactivating it).
    More tests needed, obviously…
2 Likes

So after a reboot today I tested that once more and it really manifests that after closing aliendalvik the camera/flashlight does not work when called the first time.
Tested after reboot and only settings applet opened.
Ad started --> all works
AD closed --> on first try black screen, second try works
AD started and it repeats…
So 100% reproducible

1 Like

Thanks for testing this. We have updated the bug report.

1 Like

I’m seeing this also, and AD seems to have absolutely no impact on it. This happens on a freshly booted device.

  • I boot with AD turned off (my default) --> Camera black
  • Turn on AD --> Camera black
  • Turn off AD --> Camera black

SFOS: 3.3.0.16
HW: Xperia 10 Dual-SIM

nemo@PGXperia10:~ $ jolla-camera
[W] unknown:0 - Focus mode selection is not supported
[W] unknown:0 - Focus mode selection is not supported
[W] unknown:0 - Focus mode selection is not supported
[W] unknown:0 - Focus mode selection is not supported
[W] unknown:0 - CameraBin error: "Failed to allocate required memory."
[W] unknown:0 - CameraBin error: "Internal data stream error."

(jolla-camera:25684): Tracker-WARNING **: 10:50:25.340: tracker-backend.vala:211: Falling back to bus backend, the direct backen                                                                                                             d failed to initialize: Locale change detected (DB:en_GB.utf8, User/App:en_GB.utf-8)


nemo@PGXperia10:~ $ free -m
              total        used        free      shared  buff/cache   available
Mem:           2672        1174         661          24         836        1506
Swap:          1023          16        1007

So for you it does not work also without touching AD… it’s good you are reporting this, I could not get this issue for days as I keept it off after a reboot (i am testing on an xa2).

However you seem to be confirming it also does not work after activating/deactivating AD. If that is 100% reproducible, it could be good starting point for debugging.

It’s even weirder: When running AD, I can display the camera image using Alien Dalvik Control’s “Camera” function. But while this is working, the native one still does not.

I mean I can switch between the Alien Dalvik Control window, see the camera picture, close that, open jolla-camera and the latter’s image still shows black. Close jolla-camera, open ADC again, image displayed OK.

1 Like

Another (maybe completely unrelated but yet to do with camera) observation:

from time to time I felt that my XA2 gets warm even not heavily used, just some browsing and mails open
did not really bother …

But this morning it got warm right after switching on
it was switched off and charged over night
I did my normal mail and browser check, felt it getting warm and shut down apps
then a few hours later I heard this well known sound, checked battery and it was down to 10% after maybe 5h
I checked with top and found the android process consuming 24% CPU

cameras+ 3297 21.1 0.6 153868 16444 ? Sl 01:46 160:33 /vendor/bin/hw/android.hardware.camera.provider@2.4-service

I opened camera app --> black window
switched to selfie mode and back --> cam working
checked with top, normal
temperature went down soon

Bump.

Any news on this?

What can I do to assist in debugging?

1 Like

Well, update to 3.4.0.24 solved this magically…

for the record, on my device (xa2) this is still present on 3.4.0.24

3 Likes

As @enrish I still have the problem with the camera. I have a XA2 (single SIM) with SFOS 3.4.0.24. Yesterday I tried to evoke the error. But it wasn’t possible. But after charging I tried the camera today morning and it didn’t work. So I did what @peterleinchen recomanded (in terminal on the phone):

devel-su -c kill -9 $(ps aux | grep .*android\.hardware.camera.* | tr -s ' ' |  cut -f2 -d' '); killall -r .*camera.*;

I got the error:

kill: sending signal to 22552 failed: No process found
cameraserver(8354): Opteration not permitted
.*camera.*: no process found

But anyway afterwords the camera worked again.

What can I do to fix the camera problem? Or how I can help to solve it?

I wrote above command from memory.
Both kill needs to be executed as root!
So better to do devel-su first and then issue both commands.
As one-liner (updated):
devel-su; kill -9 $(ps aux | grep .*android\.hardware\.camera.* | grep -v grep | tr -s ' ' | cut -f2 -d' ') || kill -9 $(ps aux | grep .*android\.hardware\.camera.* | grep -v grep | tr -s ' ' | cut -f3 -d' '); killall -r .*camera.*; echo done; exit

Good, so android can server is/was the culprit.

No idea, this is up to @Jolla!
(I still believe in bad menory management or misuage from Android side…)

1 Like