[Release notes] Verla 4.2.0

The first post in this thread is updated whenever a new release is rolled out. Check the Release notes post for each version to know the latest one available, EA or public.

I’ve experienced two strange deteriorations with the update from 4.2.019 to .21 on my X10 II:

  • Bluetooth connection with my car doesn’t worky anymore. I can make and receive calls but don’t hear anything and cannot be heard by the other participant. Seems that audio is not transmitted. If I switch to phone speakers during call, it works. I have repaired it, but did not help.
  • I cannot record videos with Advanced Camera anymore. If I want to record a video, there seem to be insuffcient resources.

Both worked fine before the update. Anbody else with these problems?

The video AND main camera in Advanced camera stopped working for me too, after the update, while the front camera still works.
Sony XA2

The opposite for me. Sometimes the back camera did not start (black screen) and needed to switch to front and then to back again. Now it takes some seconds to start, but it always starts. XA2 Plus.


Upgrade went without hiccups, now enjoying Calendar improvements :slight_smile: Thank you, @dcaliste and whoever has been working on this!

I have this problem, too, on my Xperia X - actually I think it started already with 4.1. Sadly it seems the big improvement re:edge swipes, that arrived in 3.0.2 Oulanka has been lost recently. I hope it can be brought back!


@jameson If you need to restart the camera, it seems to me like you’re running into an old bug:


I have run into it also with Camera apps and the flashlight.

With Verla though, on my device Advanced Camera (front) just stopped working, no matter how many times I restart it, I just get to see the buttons on a black screen.


Thank you, I had not noticed this bug report. It looks like this is the case. It went away with 4.2 though.

1 Like

the connectivity seems worse than on 4.1. I’m using Xperia 10 II with german Provider Drillisch. Not only the connection is gone after a call (again/stil) also there is a difference in the behavior of connectivity between sailfish OS Apps and Adroid Apps. Mobile network is missing although 4G is shown in the right corner. will this be fixed with the new update?


The improvements in the browser engine didn’t fix the website of my bank and thats bad :no_mouth:

Hopefully 78 makes it next release.


I’m also unable to view some sites which I was able to use on 3.4. https://zeit.de for instance.

I tried debugging by turning on the console debugging and running it in a terminal but saw no errors. I had made certain to whitelist the ad server and sundry crapola that the site loads.

1 Like

Same here. The “Einverstanden”-Button to agree to ads is missing. It works in Fennec 92.1.1, though. (Which certainly does not help). :crazy_face:

Yeah, and it doesn’t appear to be a javascript file not loading (I checked running in the terminal). I’ll post it as a bug report and add cli output.

1 Like

I can confirm that it is not JS.

This site works for me…but I am not logged in.

Took me a while to come back to this, but now I did try.
And failed…

A lot of fastboot problems. Eventually I found a usb-port on which fastboot recognised my device, but when I sent commands, my Xperia 10 just rebooted or it just did nothing…
So I gave up, for the time being.

I did manage to install sailfish 4.2.0 by removing some apps, though I had to try twice.
Seems to be working though!

Thanks for your reply.

1 Like

I’m on Drillisch too and have the same behavior (complete connection loss after a call & Android apps claim to be offline despite I’m online).

My first workaround for Android apps claiming to be offline was trigger mobile data to be off and then on again. I had the suspicion the issue is with Drillisch / O2 since it seemed to start not after a Sailfish update, but in between updates.
Since I switched from dual to ip (settings / mobile network / data access point) at least this problem was gone for me. For now there’s no obvious downside by ditching IPv6 support. I wonder how long…
So it might work for you too?


Since I switched from dual to ip (settings / mobile network / data access point)

Wow, this works for me too! Could you make a new post about this? This would help lots of people!

1 Like

The related Topic is:


Ok, but hard to find if you don’t know what to look for exactly (i.e. most users suffering from this issue).

thank you! I tried that. It seems to be better but in fact it isn’t. Stil the same bahaviour… the Phone is simply not usable in this state. :frowning: i hope jolla will fix that with 4.3! If not, that would be a verry poor situation in terms of letting all users down who bought a new phone and payed 50€ for a licence. It is completely unacceptable to sell a Software that does not work in such basic areas like moblie data connectivity or Mobile notwork connectivity. I am meanwhile pretty pi***ed about this currrent Situation! It can be dangerous to use something like that as daily driver.