Loving on the Xperia 10iii except for a couple of things

Hi all, I am one of the community devs from back in the days of Maemo and I have been completely out of the hands-on loop for years with SailfishOS. I have however been watching the Jolla team from the sidelines like a proud uncle and waiting for hardware support to get flagship-ish.

12 hours ago, I installed a license image of Vanha Rauma on my 10III (after having nothing but build failures for the past 4 months) and I am loving it so far except for two software (likely Google services) related issues.

  1. I am trying to install an android app that I have used on the same hardware under Android 11 but the installation fails with the following message.


1 Like

…2. I have also installed the Sony Headphones Connect app which has also been tested on Android 11, again on the same hardware. Under SailfishOS it seems unable to detect and hence control the handset’s bluetooth hardware.
Bluetooth is already on and working just fine when I pair the headphones:

Sony Headphones Connect still asks to turn it on so it clearly can’t see the hardware:

then gets stuck trying forever:

I feel that these may be easy fixes compared with the issues others are having but I would still really appreciate a bit of help on these two matters.

I will continue to explore the new build in the meantime and see if there is anything else not working quite right.

Android apps generally don’t have access to BT in SFOS

oh… that is a massive oversight. It would indeed be a pity to not be able to manage the Sony XM4’s from my Sony Xperia 10III because the OS can’t provide the app with BT access, however well managed and controlled.

Maybe there is an opensource alternative to Headphones Connect for managing Sony BT ANC headphones?

Not that I would know of.

I own Sony WH-1000XM4 head phones but never felt the need to manage anything, maybe because there never was a SFOS app for that :grin:

Well I have mine paired with 4 devices and often need to select the one to connect to by default in between calls in addition to managing some of the other features of the unit.

Having the app on the main mobile is a bit more than convenient for me.

What is more pressing is the first issue I mentioned of the virtual sim app that won’t install without the com.google.android.maps library.

I would like bit of input on this, whether this error message is familiar to anyone and what the fix may be.
I have already tried installing Micro-G and many of the other recommendations I have found in public search results but most of those discussion threads are years old so I assume there are slightly different circumstances at play here with Vanha Rauma.

Is that Cloud SIM app?

What does it even do?
If the Android runtime doesn’t have lowlevel access, why should it work?

1 Like

Im case it is, seems to install fine from Play store:

No idea if works as not putting my number in there. For play store used one of the scripts that can be found on the forum as microg wouldn’t work (maybe this one? Google play services on Sailfish 4.1 )

A bit offtopic, but is there a working google cam port for X10 III?
The pics on X10 II are awesome with it, all 3 cams supported

yup, it is indeed CloudSimApp.

Try the script from mega, it worked fine except account login after restart would keep restarting itself over and over when you try to swipe away to desktop, but once you do manage to login and close leftover windows it works