Jolla Phone black screen after update to 3.4 (early access)

REPRODUCIBILITY (% or how often): Unknown
BUILD ID = OS VERSION (Settings > About product): Jolla Phone with Saimaa 2.x latest
HARDWARE (Jolla1, Tablet, XA2,…): JP1


Hallo, I recently tried to update my Jolla Phone to the 3.4 update.
I did the manual mode to get the update mode, and then installed the 3.4 early update version, via terminal.

Everything apparently ok, the phone listed all the old steps needed and it took a long time. But at the next reboot, after the Jolla logo…
The black was black. Then while charging, I received a call (ringtone) and understood that was a black only issue.

I did some attempt with the recovery mode, but the telnet address was not responding…
How can I solve this? There is a way to flash a Jolla Phone from a PC/mac?



For some reason the Jolla Phone wasn’t capable to update OTA to Sailfish OS 3, using the menus


  1. Pick up a JP1
  2. Manual ask update via terminal
  3. Install and reboot


Maybe this might help;

1 Like

Thanks, I will try the older trick at the bottom.
Sadly telnet is not answering for me, that was so simple.

Hi bro,

did you get any solution please. the same problem after update. telnet is not working.

But my phone is switching on, wallpaper showing, after enter the passcode home screen comes within 6 seconds all screen goes black ., what But notification and Whatsapp pop up display displaying coming clearly on top in black screen. what is the exact problem I don’t know?

am having this Jolla phone more than 5 five years very carefully. Because of a very rare phone. but today got upset even though I have iPhone 11 pro, Jolla is my favourite due childhood N9 user I am.

please anyone help me.

I am stuck there. I have to say I didn’t dedicated too time on testing everything in the help page. I am trying again this evening but sadly the Jolla Phone 1 is missing the possibility of a manual flash from PC terminal…

Thank you for reply bro. am also trying . if wifi is on state we can’t user PC recovery mode and finding different options. am trying different methods, I will update you if I got the solutions. Thank you

See here: The screen goes black and that's it

It is caused apparently by “overlay” apps, like phonehook, battery-overly and others.
Remove the offending RPMs in recovery mode and reboot.

Hi Bro, Thank you for reply. am tried into recovery mode. i couldn’t do . am using wifi laptop and it’s not detecting phone. i tried both MAC and Windows. So just Jolla screen is on mode that’s all.

So do we have any other option to access the recovery mode or any option to reset using buttons please.

Thank you

Do you have developer mode enabled? If yes maybe you can connect to the running phone using USB Networking.

As soon as you have a login shell, you can remove the packages and look around.

I tried first your way, I installed the driver for RNDIS device, and it shows as “other devices”. PC Windows 10.
Then I get timeout error with Putty.
JP1 is in recovery mode, with logo and fixed LED…

Then I tried the @Edz way but after enabling telnet (works with test adresses) on PC,
the Jolla telnet address is not answering…

Really there isn’t an offline flashing option?

Nothing new.
Jolla phone bricked by 3.4 update.