Jolla account don' t work



Connecting to jolla store show the following:
Problem with store
There was a serious problem with app registration.

Trying to install an app gives
“store not responding”

Deleting the account and recreating it does not help.







1 Like

Related to this bug report: Impossible to install Predictive Text Input

At Impossible to install Predictive Text Input there is an issue installing one specific app from jolla store. But I can no longer install any app at all.

Yeah, that’s the reason why I used te word “related”. He had an account issue, too.

As you can’t enable the developer mode the easiest solution is to flash your device once again.

1 Like

That means installing sailfish completely new?
I find it difficult to see this as the easiest solution.

Have you tried clearing the package cache? The easy way is via Sailfish Utilities (when already installed).
Can you still install packages via storeman or chum gui? Or possibly via the command line?

@xmasjos: commandline is unreachable, as the developer mode can no longer be activated, it hangs with the message “changes will be prepared”. I don’t have storeman app installed.
How to clear package cache without commandline?

Is it possible, that this account issue is caused by a server side problem at jolla. As I can create the account with correct user and password a connection to jolla server could be established. But all functionality is not available.
Does the message “No net” on the homescreen point to the account issue too?
Can this issue be caused by a hardware problem, sim card or so?

I wouldn’t say this is a hw issue.
Have you got access to internet with both wifi and mobile data for e.g. surfing with the browser?

I don’t remember if I installed something, probably, but I can become root with the su command even with developer mode disabled. Maybe can you try, if one day you installed this package.

Really crazy, I can’t find what package provides me su. I’m sure it’s evident but I feel blind.
sudo is not installed and running rpm -qa | grep su or ‘root’ or ‘super’ gives me nothing interesting.

The idea could be for you to download and install a package from Openrepos that would give you access to the developer mode in order to debug, but I’m drying…

You were told to clear some cache with Settings => Utilities, which comes pre-installed on new SFOS versions. Not with CLI.

@ohnonot : Thanks, now I cleared package cache, but didn’t help, still “there is a problem with the store” and “no net” on the homescreen.
So still no developer mode available.


Yes, wifi and mobile data are working.

Simlar problem: SF is no longer able to log in to DropBox. The process requires logging in via the browser. The website has changed I think and SF no longer recognises it. This breaks sharing to and backing up to Dropbox.

But this is about the jolla account. I can create a new account and that works. So the connection to jolla is established. But after that nothing does work with this account.

You should open a ticket with Jolla support.

And/or you could provide some journal output. Pretty sure the docs have some general troubleshooting advice.

Open a ticket with Jolla support will be a good idea.
I found some support docs relating the jolla account, but they describe how to setup the account und to check if it is working, but no hint how to troubleshoot a problem with the account. Some hints are based upon the developer mode which I can’t activate.

I’m wondering if you can bypass the developper mode with the installation of an alternative terminal like ToeTerm.

Yes, indeed, Toeterm + the su command.
That’s what I used to do as secondary user having no Dev mode.

1 Like

Jolla support advised me to reflash my device with the latest OS release. To bypass the whole flash procedure I did a factory reset and installed all the following updates. This does work and no I could install and jolla account, store and developermode does work also.

1 Like