Impossible to install Predictive Text Input

HARDWARE: Xperia 10 ii
UI LANGUAGE: Irrelevant (tried a couple already)


Using a paid Licence, I am able to install all Jolla Apps from the Store, including Exchange, FortiVPN, etc. except for the Predictive Text Input. It hangs for a while (about one minute) then it reports a problem with the Store.

As stated: I am able to install applications (any other application) either coming from Jolla or from other developers. This is the only application whose installation does not work.


Paid Licence


  1. Go the Application Store
  2. Search for Predictive Text Input and Tap.
  3. Pull down to install.


App gets installed successfully just as any other


Hangs a while, then throws an error. This can go on forever (i.e. I have tried often enough)




Please advise me on how to log this!

1 Like

Hold down sounds odd to me. It should install after short tap on the icon in the Jolla shop.

edit: I mean, short tap opens description page, pull down will offer installation.
It’s normal that installation of Android support takes a few minutes, so don’t worry about this. It’s several hundred MB in size.

Thanks, but the thread is about Predictive Text Input, not Android support :slight_smile:

Sorry, I didn’t read carefully enough. But installation is similar, you shouldn’t press and hold down the button.

no prob, I clarified my original post by substituting ‘press down’ with ‘pull down’


If you have Developer Mode enabled, you could try installing it via terminal

pkcon install jolla-xt9

Thanks for the tip! Here’s what I have done so far.

pkcon won’t find package jolla-xt9. It did find jolla-keyboard-settings-xt9, which I installed just in case

After that, thinking there must be something wrong indeed with my package index, I did a pkcon refresh, hoping that I would be then able to install xt9, either from the command line or from the app store, but nope. It was of no use.

If you want to do more than just complain, sharing the error message (from the terminal) would be a good idea.

You opened a terminal, typed the command devel-su to get root access, and then typed the following command, right?

pkcon install jolla-xt9

Asked is the result of the above command :slight_smile:

1 Like

Install zypper and list all repositories:

zypper lr

I can see you edited that. Good.

(edit: oh no, you didn’t. You doubled down with fewer insults. What the [slur_you_used] do you think this is going to achieve, you [slur_you_used]?)

Now, when and how did you install SFOS? What did you do after installation? Register yourJolla account? Restore a backup from another SFOS?

What about Android app support, is it enabled/available?

Attah’s passive-agressive comment wasn’t exactly constructive either. Rsoto even bothered to used the bug template and I saw no whiny complaining here. For all we know he could have even just forgot to include the error message ( which is not the case but could have been).

If reception to noobs is like this on the forum, less people will want to ask for help and may feel sailfish is not usable enough for them, which will bring less money for Jolla which makes more work for community developers when Jolla can’t afford to handle even basics like browser.


Lets stop the meta, and continue the debugging.

@rsoto, please try the following from the terminal and let us know the output of each:

ssu s
ssu lr | grep jolla
pkcon resolve feature-xt9
pkcon download /tmp feature-xt9
ls -l /var/cache/pk-zypp-cache/raw/ | grep -v openre

Aha, pretty interesting: ‘ssu s’ prints ‘Device registration status: not registered’. As stated: all other Jolla apps, including but not limited to Android App support, are already installed…so this really comes as a surprise.

pkcon resolve feature-xt9 apparently succeeded ‘Resolved’ . But pkcon download /tmp feature-xt9 threw me the same error as before (package not found). Output of the last command is:


That’s normal and can be ignored. It has nothing to do with the “licensed account” stuff.

Apparently? What was the exact output?

It looks like you’re missing the xt9 feature repository, but as you keep not giving the exact outputs even when asked, it’s hard to debug further.

1 Like

My UI is not English, this is why I provide sloppy translations of the output. In this case, there was no further output other than ‘Resolved’. No errors, warnings, etc.

Oh wait, I executed this command two times. The first time, the exact output was: