Is it just me, or has Android internet connection degraded in Verla?

Massive issues on 10 II up to the level at which SFOS is usable on mobile data only, as any switch to/from WIFI will result in the phone being offline, both in Android AND Linux. Fix is to reboot.

XA2 Ultra works much better, but still experiencing disconnects.

1 Like

Had an Xperia X till yesterday and since today a 10 II as a daily driver. I’m really disappointed about this bug. On Xperia X everythg works and on Xperia 10 II I had problems the whole day, both with Verla. After a phone call the mobile connection is gone too.
This bug should be tracked by jolla immediately. It’s a pity to pay 50€ for a phone license to get an non working phone…

Pls investigate!

1 Like

Sailfish OS 4.2.0.21 at Xperia XA2: Android apps after some time seem to stop resolving DNS,
temp fix:Settings->Androidtm App Support->Actions->Stop, wait until Start button is enabled, press Start button, as mentioned by Is it just me, or has Android internet connection degraded in Verla? - #15 by jollajo

Are you in a country where 3G support has ceased, for instance Germany? This would explain why the mobile connection is interupted in case of a voice call: the phone needs to switch to 2G for voice calls since there is no VoLTE support yet.

1 Like

Yes, i’m in Germany with E-Plus. I’m not sure if this is a 3G thing only. On Xperia X everything is working, but 10 II looses the connection when switching from wifi to mobile network and after phone calls for a while. Today it was a little bit better, but I still had to reastart android service after leaving my wifi at home to be online again.

I can cornfirm that 4.2 causes more trouble WRT data connections and mobile network than 3.4 does. The temporary loss of a mobile data connection during a voice call appears to be inevitable to me as long as there is no VoLTE. However, reconnecting (i.e. switching back to 4G and establishing a new moble data connection) takes way too long. And then there is the loss of network access for Andriod apps from time to time …
There is some room for bugfixes, I guess

Same here, I virtually can’t use internet on the phone when at work and the company lately either restricted access or the phone can’t connect to the wifi anymore as it happened after the 4.2 update due to a low signal that fluctuates between none and 60% of 4G. 3G network in the area is not present and 2G has about 20% which takes ages to load a page in the stock browser because Opera won’t work. This was caused by one of the pre-4.0 versions and getting worse with every update. XA2 is the phone…

I’m also having issues with internet in Android when going out/in and changing from wifi to 4g and vice versa.

Yes, I’m getting What’sapp texts the next day. This is not an issue this a freaking disaster!!

In xperia 10 I have a more curios issue. In wifi, some applications like browser after a while stop working until I restart the android layer. Other applications like whatsapp are not affected by this.
And maybe it’s all related but sometimes wifi stops working after a time you are connecting and disconneting although it is connected to the wifi. This issue needs a full reboot.
Conclusion, for now wifi connection is useless