Connectivity issues related to IPv4 addresses while IPv6 works

REPRODUCIBILITY (% or how often): Seem to be random
BUILD ID = OS VERSION (Settings > About product): (Verla)
HARDWARE (XA2, X10, X10 II, …): X10 II
REGRESSION: (compared to previous public release: Yes, No, ?): ?


I have rencently using only mobile connection with my phone to see if it would help the connectivity issues when changing between wifi and mobile connection.

Now I have few times came to a strange issue where some sites work but some don’t. For example testing random bigger pages around the world like,, and seem to work and reply but at the same time for example,, or do not.

When I start a terminal and try to ping or traceroute the pagest that do not respond, they are all replying with IPv4 addresses and with message “Network is unreachable”. The ones that do reply are all exposing their IPv6 address.

It does not matter whether I use jolla browser or firefox as both of them work/do not work with the same pages. There are similar issues also with different softwares. Protonmail-client is unable to connect to the server and at the same time the finnish teletext application is working.


Use mobile connection without WLAN.


I cannot be certain but restarting android support, restarting network stack, reconnecting to mobile network seem to cause this sometimes.


Browse, ping and traceroute all sites as usual and receiving response


Some sites work and some sites don’t.


Added a sample image, replies as it uses IPv6, fails with IPv4, replies with IPv6 and fails with IPv4

Have you tried this 192.168.l.l IP?

Just logged in to report that the similar behaviour exists also on on random occasions.

Very often some individual IPs are blocked. Have you tried this 192.168.l.l IP? This is the public IP address that many wifi routers use. I would recommend to use one of those IPs as it is safe and easy to contact support if needed. You should also pay attention to your router. Is it in good working order? This is often the cause of problems, including

I tried with a data connection without VPN and with WIFI being off. XA2 4.4
I could access all these sites with the browser.
When pinging them, I just had to add www before but otherways, all gave an answer. Reddit was IVP6 tho.

So, I was not able to have problems following the procedure.
(Generally, I am very able to have problems ;–))