IPv4 mobile data connection not possible

When using sim slot2 i’ll get an IPv4 adress, but VoLTE is failing and i can’t connect to the net.

Have the same problem now.
After i deactivated SIM slot 1, only limited connection with mobile data on slot 2.
IPv4 and IPv6 address is assigned, but no internet connection possible.

[root@Xperia10III defaultuser]# ifconfig
rmnet_data1 Link encap:UNSPEC  HWaddr 00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00  
          inet addr:  Mask:
          inet6 addr: fe80::b05d:a509:8007:1ea/64 Scope:Link
          inet6 addr: 2a01:59f:a810:a080:b05d:a509:8007:1ea/64 Scope:Global
          UP RUNNING  MTU:1500  Metric:1
          RX packets:11 errors:0 dropped:0 overruns:0 frame:0
          TX packets:220 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:1272 (1.2 KiB)  TX bytes:15956 (15.5 KiB)

[root@Xperia10III defaultuser]# ip -4 route | grep default & ip -6 route | grep default
default via dev rmnet_data1 
default via fe80::bd9e:6812:c963:e4cb dev rmnet_data1  proto ra  metric 1024  expires 65487sec

[root@Xperia10III defaultuser]# ping -4 dns.google.com
ping: bad address 'dns.google.com'

[root@Xperia10III defaultuser]# ping
PING ( 56 data bytes
--- ping statistics ---
27 packets transmitted, 0 packets received, 100% packet loss

[root@Xperia10III defaultuser]# ping -6 dns.google.com
ping: bad address 'dns.google.com'

[root@Xperia10III defaultuser]# ping 2001:4860:4860::8888
PING 2001:4860:4860::8888 (2001:4860:4860::8888): 56 data bytes
--- 2001:4860:4860::8888 ping statistics ---
21 packets transmitted, 0 packets received, 100% packet loss

Unfortunately, reactivating slot 1 doesn’t help.

After hours of testing, the only certain result is that sooner or later the mobile data connection will stop working properly or break off completely.

The mobile internet is currently not working at all for me when using SIM slot 2.
Although an IPv4 and an IPv6 address have been assigned, “limited connectivity” is displayed under “Mobile network” and the mobile Internet does not work. See above

I experimented a bit more and found the following workaround for using mobile internet with SIM slot 2:
By switching the network mode to “2G only”, the connection is re-established and “Connected” is now displayed under “Mobile network”.
If you then switch back to the “4G preferred” network mode, the mobile data connection remains “Connected” and the mobile Internet connection works correctly with 4G.

When connecting to a WLAN, the mobile data connection is disconnected as expected. After logging out of the WLAN, the mobile data connection is correctly established again.

So far so good, but unfortunately after restarting the phone or after toggling the flight mode, the previous problem reoccurs and the above process has to be repeated.
And of course VOLTE still doesn’t work with SIM slot 2.

But better than nothing and finally a reproducible behavior.
However, this trick does not help with the actual problem with SIM slot 1 (no IPv4 mobile data connection).

Thanks, @senders for the interesting reporting and for the suggestion for a procedure IPv4 mobile data connection not possible - #2 by senders which I attempted to execute, but with, not with While it did not work for me on SFOS I managed to make IPv4 work on Android 11 / Xperia 10 III, albeit it did not work out of the box on Android, either, with my operator’s SIM.

The default APN (Access Point Name) settings on Sony’s Android 11 were :

  • APN Protocol = IPv6
  • APN Roaming Protocol = IPv4

I am not sure has my operator communicated to these values to Sony or to Google, or both but these values are not the same as my operator promotes on their configuration help pages.

Interestingly, the default set of parameters is not editable in Sony Android 11’s Network & internet → Mobile network → Advanced → Access Point Names. There was another ASN profile, for the professional clients of the operators, in which the above settings were:

  • APN Protocol = IPv4
  • APN Roaming Protocol = IPv4

(For good reason, since in professional usage VPN connection is often requested and the VPNs - that I know - use IPv4. Even a dual protocol IPv4/IPv6 support that SFOS suggests by default, would just create a leak of IPv6 in case the VPN software cannot turn it off.)

In the contrary to the SFOS, Sony Android 11 allows to create a new APN profile in the above menu, and it was possible for me to set a new profile using the values from the help pages of my operators. Not surprisingly, the values on the self-help page are, for APN:

  • APN Protocol = IPv4
  • APN Roaming Protocol = IPv4

After activating the newly created profile, Sony Android 11 installation started to work as I expected, also with the VPN and with the sites with non-public, fixed IPv4 IP-addresses.

After a couple of reboot and re-testing of this Emma flashed Sony Android 11 62.0.A.3.109 all remains good and I attempted to flash (again, yes, it is tiresome to spend one’s life doing this).SFOS

Of course, it did not work, and even it was still claiming the APN Protocol being “Dual” (i.e. IPv4/IPv6): no change in this parameter changed anything: ip -4 route remains, desperately empty.

There is no mention about the APN Roaming Protocol in SFOS.

I can understand that Jolla is interested in recovering Google/Android/Sony knowledge about different operator’s settings, bur frankly, the sheer idea of having dependency for this on an underlaying Android installation is on a quite slippery surface what comes to the configuration control:

At least, Jolla should provide a full power APN profile viewer and editor/creator like Sony Android 11 is providing. Now we are shooting in the dark.

You are also right, @senders that probably not enough interest is generated to highlight this issue, since for most people the IPv6-only works and it may go unnoticed for the majority of people that they do not have IPv4 on mobile data, only on WiFi.

But if Jolla is claiming that they are strictly security oriented, they should make IPv4 APN protocol working for all and provide a way to suppress IPv6 altogether.

Unless they can make all the VPN providers to switch to IPv6 tomorrow.


Yesterday i reflashed Android12 and SFOS about a dozen times, with no luck. I only once got my IPv4 address back and this was gone after a reboot.
Maybe Jolla get this fixed.


Thanks to @PeegeeTips, various mobile data issues will be addressed at the next community meeting.
This bug report is also mentioned in the topic description.
Hopefully this helps draw more attention to this issue.

PS: Could someone with the appropriate rights please remove the ‘fixed’ tag which I sadly set prematurely.
Or forward the request accordingly? Maybe @pherjung


Are all Xperias concerned? I can confirm this bug for a Congstar SIM in both, a Xperia ii and Xperia iii, both running Both do not have any connection problems with a Vodafone SIM. I have not tried the XA2 yet, but will do so tonight.

1 Like

The XA2 is not affected - it’s my backup devices (XA2 Ultra) currently until the Xperia III is fixed :frowning:


cf. #sailfishos-meeting: Sailfish OS, open source, collaboration -- 18th August 2022 point 5 (n.) to (t.)

1 Like

I was following today’s SFOS meeting for exactly this issue. The data connection problem is mainly discussed with respect to the Xperia 10 iii. However, the Xperia 10 ii is affected similarly.

If I am not mistaken, the connection problem only arrived at the Xperia 10 II with SFOS, the first release with VoLTE for the Xperia 10 ii. Therefore I wonder whether the connection problem with the Xperia 10 II/III with Telekom/Congstar DSIM is related to VoLTE support

Someone else had a similar suspicion, see this thread as also hinted to by @Fubo although @flypig said it was fixed " ** For issue 3, a fix was introduced to work around the fact that VoLTE can create new IPv6 interfaces with potentially broken routing data (this is carrier dependent). This fix was rolled out in Sailfish OS (flypig, 07:22:35)* "


My Xperia X (F5121 - Single SIM) is also unaffected.
Is your XA2 Ultra the dual or single SIM version?

This could be an important clue.
At first I had a suspicion that it had something to do with dual SIM.
But if the IPv4 mobile data connection worked with the xperia 10 II and the Congstar SIM up to version and the problems only occurred after the VOLTE implementation in version, then I would rather bet on VOLTE.

As requested, ofono-logger, journal data provided to Jolla Zendesk customer service as explained in https://jolla.zendesk.com/hc/en-us/articles/203294343-How-to-collect-oFono-logs. The logs, basically say Aug 18 20:38:55 Xperia10III connmand[14442]: ofono: 0x1876a400 DUAL no IPv4 address set everywhere, but let’s hope that the logs reveal also something else than what we already know.


I really hope I am recalling correctly but I am pretty sure that my connection problems on the Xperia 10ii arrived with

I did a short search in this forum and my impression is that the Xperia 10iii had connection problems with Telekom SIM starting with while the problems with Xperia 10ii only started with

As I said I hope I am not mistaken

1 Like

Likewise (dual sim XA2 Plus in my case), using the old phone with a talkmobile.co.uk SIM until the 10 iii is ready to be a phone.

1 Like

I really don’t get it. I inserted my t-mobil sim card today. I didn’t use my Xperia 10 iii during the last weeks. Everything works now! :flushed:
As i wrote above i processed the procedure of reflashing to android described by @senders but it didn’t help me a few weeks ago.
Today i inserted my t-mobile card in slot 1, wifi and mobile data have been turned on. I started the Phone and now Telegram gets connected even if wifi is turned of. I got the Message “Your phone number is …” after startup.
I shut down the phone, inserted my congstar sim card in slot 1 and my t-mobile sim card in slot 2, started the phone and every thing stil works! Now I got the Message “Your phone number is …” for the congstar sim card after startup.
Ipconfig still shows that i got no IPv4 address assigned but i don’t care as now everything works.
I really tried round about 50 times all combinations of sim cards and settings a few weeks ago!
I really, really don’t get it but wanted to inform you guys about this. :thinking:

1 Like

This is pretty confusing. Have any of you any idea why some 10 IIIs work and others don’t?
I have my 10 III since August, 1st. Did the installation by the book, reimported my data from.my XA2, with that softlink from./home/nemo to /home/defaultuser, put my Vodafone SIM in slot one, my SD in the other and left everything with default values.
SIM two is activated, network set to automatic

Exept from.sometimes taking a few seconds when switching from WiFi to mobile network everything works fine with.4G and no VoLTE.

I have a Vodafone prepaid SIM.

1 Like

In my opinion, it depends on the provider.
While I had no IPv4 problems with a MedionMobile SIM (MNO: O2 Deutschland), an IPv4 mobile data connection is not possible with my Congstar SIM (MNO: Telekom Deutschland).
Since you’re using a Vodafone SIM, you’re lucky and unaffected.

I only have Vodafone SIMs in use but we could maybe compare the settings provided, sort provider specific stuff out and see if we get an idea of what is going wrong with Telekom?
Do you know where the settings are stored?

1 Like

No offense, but reflashing that fix mobile data connectivity is like a miracle, and you want to believe in.
I am agree that it’s can depend on carrier.

my experiments for a few months with Serbian Yettel 4G:
0. Only IPv4 protocol enabled and 4G disabled.

  1. 3G is working always. If you see “limited” just turn on and off “airplane mod”.
  2. 4G is mostly broken. If you will firstly connect to 3G, than you can switch to 4G and it’s will work.
  3. Switching between cell towers will brake connectivy at some point of time.
  4. Switching between WI-Fi and cellular brake connectivity sometimes.