Install Sailfish through Mageia

I’m using a translator, excuse me.
I want to install Sailfish on my Xperia 10 and use Mageia, but I have problems with the commands in the terminal. I have installed andoid-tools and I can do a fastboot-android, but when I type “sudo bash ./flash.sh” in the terminal, Mageia does nothing. Can somebody help me? I think @filip.k know about this. Thanks.

Hi, cbfgalicia. I understand you great.

I think that the only thing different is fastboot executable path. You can add a symlink or use my recent approach.
I had serious full lockup issues with my XA2 so I send it for a repair.
Before I finaly confirmed with Android that HW is malfunctioning I also tried a reflash of 3.4.0.24. So in order that flash.sh script worked I added path and filename of fastboot executable:

FASTBOOT_BIN_PATH="/usr/bin/"
FASTBOOT_BIN_NAME=“fastboot”

instead of:

FASTBOOT_BIN_PATH=
FASTBOOT_BIN_NAME=

I also tried other script modifications as my phone often stopped working even during reflash but I didn’t know that yet back then.

Anyway, just add that modification, fix md5 sum of script in md5.lst and you should succeed.

Please report back.

1 Like

I am going to try it and I report.

Two issues.
1 - In the flash.sh file, do I have to change all the FASTBOOT_BIN_PATH =
FASTBOOT_BIN_NAME =? Or just a special one?
2 - What do you mean by: fix md5 sum of script in md5.ls? Thanks

1 - just first two at line 55
2 - just erase line with flash.sh in the end of a line 6 in file md5.lst
(in my case it looks like like “631f4ed5264e82c2c61944714ae08c22 flash.sh” as I’ve change it)

It worked in my case but I don’t accept responsibility for any changes.

1 Like

It does not work for me. I will try with Manjaro or Opensuse (with Ubuntu it works).

If you paste output I could probably help.

1 Like

Hi! If you both feel like sharing your experiences, i opened a thread to post feedbacks of flashing:

1 Like

Those quotes have been mangled by the forum, so if that is exactly how @cbfgalicia copied it, that could be (part of) the issue.

1 Like

Indeed. Unfortunately I can’t edit my post anymore. Thanks!

1 Like

Hi cbfgalicia

If you want, you want, you can read my flashing adventure here :


I understand that tools are the same but the commands to do are not exactly the same.
A true wiki for mageia will be welcome (and send it to Sailfish forum and french Mageia Forum).

Hi everybody,

To install on XA2 I follow the installation instructions. I install fastboot dnf install android-tools. Then I get to unlock the bootloader (sudo fastboot-android…); but when I get to 6.6 Launch the flashing script by entering the command: sudo bash ./flash.sh…don`t work. I did what @filip.k recommended and in all cases it gave me the same result: that fastboot is not installed and it tells me how to install it from Fedora or Ubuntu. But, I already installed android tools!T

We’re you careful about the quotes characters? This forum change my commands to look pretty. You need to use single or double quotes characters.

And if still doesn’t work, then please post the script and output here.

Good luck.

I just flashed SFX to Xperia 10 right now from Mageia 8 on Raspberry Pi4 4G using USB2 port.
The script assumes name fastboot so it complains:
No 'fastboot' found in $PATH. To install, use: ...
The only change needed was:
sudo ln -s /usr/bin/fastboot-android /usr/bin/fastboot

1 Like