Experiences Sharing: Flashing Sailfish X from my Linux Distribution, Hit or Miss?

Hi Sailors!
I was reading in the forum stories of experiences while flashing Sailfish X from a linux desktop with more, or less, success.

Could we share your experiences here?
Success or fails.
Please, if you wish to reply and share your story, indicate your distribution and its version, and some other technical details if possible (type of usb port can matter for exemple…).

I guess sharing infos may spare time for some of us!

1 Like

Linux Mint, newest Versions with Cinnamon and Mate, USB2, XPERIA X & XA2

Flashed three or four times since 2017 without problems.

Debian Testing, USB2, XA2.

Flashed in 2019-08 w/out problems.

Fedora 30 and 32 worked without problems!

I’m running Mint on a ASRock X570M Pro4 motherboard, none of the ports work for flashing (USB 3.1, 3.2, nor the 3.2 USB-C). The same install worked just fine for flashing in my old build with a ASRock Rack C226M WS.

Just realized i had a spare USB port on an add-in card (Sunix UPD2018), and lo and behold… it seems to work. (at least fastboot getvar is reliable)

I flashed my Sony Xperia X in summer 2017, I think. It should have been on openSUSE Tumbleweed or perhaps LEAP, with an ASUS ZenBook from 2015. No problems whatsoever as I recall, I read carefully and followed the instructions and did nothing outside the box :slight_smile:

Failure with a Dell laptop/Ubuntu and Sony Xperia XA2 due to an issue with USB port compatibility (there is a Zendesk article about this). I tried some of the workarounds without success, but luckily I had a desktop PC that worked (also Ubuntu).

In Mageia 7 I had to fix the name and path of the fastboot (install package is called android-tools) in the script flash.sh. I didn’t test yet if both additions are needed as my Xperia HW was malfunctioning and it’s currently unavailable to me.

FASTBOOT_BIN_PATH="/usr/bin/"
FASTBOOT_BIN_NAME=“fastboot”

Of course as with any change of script I also had to adjust it’s md5 checksum line 6 in file md5.lst (with output of md5 flash.sh) so that script selfcheck checksum test passed.

After that it worked flawlessly on USB3 on Asus desktop motherboard B85M-E.

No issues here on Linux either. Manjaro Linux, up-to-date kernel and system. Tested without issues on XA2 Plus, X10 and Gemini PDA.

Guix 1.1 and 1.2. No problems flashing in 2020

February 2021: Arch Linux on latest updates on a Dell Latitude E7450 laptop. Flashing SailfishX 4.0 to an Xperia X F5121 (including backing up the DRM keys, which required flashing Android twice) went almost without a problem. There was an issue with one of the tools/steps, where I had to use an older version to get it to work (I’d need to look up the details).

1 Like

I just flashed SFX to Xperia 10 right now from Mageia 8 on Raspberry Pi4 4G using USB2 port.
The script assumes name fastboot so it complains:
No 'fastboot' found in $PATH. To install, use: ...
The only change needed was:
sudo ln -s /usr/bin/fastboot-android /usr/bin/fastboot

1 Like