Increase volume with headsets on xperia x10iii

I don’t know if it’s a bug but I find the volume settings of headsets on my Xperia 10III far too low. Comparing them with my former XA2 Ultra they are really very low even when they should be at maximum.

Does anybody know how to increase the maximum volumes in a SailfishOS setup?

Since I am using my phone mostly for listening to music and podcasts this audio-failure is a serious drawback.

And as always I’m just tempted to switch to a googleless android and be done with it …

So if anybody could help me out with this I’d be extremely glad!

Thanks in advance


I read and tested it was possible.

Find the correct device with:

pactl list sinks short

Adjust with:

pactl set-sink-volume 3 200‰


Some time later, I had no phone sound/mic anymore.
I messed a bit and changed the wrong device a first. I might not put it back correctly. I am not sure at all it is related. I also tried a new BT device prior to loose sound.
Some reported to get the sound back after two reboots.
So be prudent.

1 Like

Have you seen/tried this?

nice hint! but the setting gets lost when i disconnect the headset and reconnect it. i created a little script to recreate the sound setting. now i just need it to show up on my screen instead of hiding in /usr/local/bin … :slight_smile:

# adjust volume of runnng bluetooth device to 150%
NUMMER=$(pactl list sinks short | grep RUNN | awk '{print $1}')
pactl set-sink-volume $NUMMER 150%

no problems with phone sounds until now …


Thanks for sharing your script!

1 Like

The tool qCommand on openrepos(storeman) could make executing this script more user friendly .

1 Like

Yesterday I also found a way to make it run from the screen. my script can be run as a simple application. to create the application, i copied the script to /usr/local/bin and created an application file : ~defaultuser/.local/share/applications/volume-up.desktop:

[Desktop Entry]
Comment=Terminal Script

this creates an icon (duplicate of media) with the name Volume-Up on the screen that runs the script and so increases the audio of the active bluetooth headset to 150%. if somebody finds a better icon, please tell me. i was too lazy to look for one or even make one myself.

better would be some basic pulseaudio config or something that runs on connecting with a bluetooth headset, but i couldn’t find anything about this (and this might be beyond my abilities).

of course i got the idea for the app from somewhere, mainly from here:


Thanks for this. Unfortunately there are some occasions where pactl list doesn’t show me my connected Bluetooth headphones.

is there any sound running on those headphones, @filip.k ?

1 Like

Yes. But of course not loud enough. It happens about one of 10 times. Note that I turn off BT when not needed.
I’ll try to restart Bluetooth service next time I’ll encounter it.

It seems that there is another topic dealing with this issue :