[hybris-recovery] Password not accepted

OS VERSION: DUAL-Sailfish_OS-Jolla-


Tried on 2 different XA2 Dual.
SSH password not accepted when trying to connect to the phone booted in recovery mode.
Into Jolla Recovery v2.0, choice #5, SSHD launched.
The exact same procedure working with SFOS_4.3.0.15/DUAL-Sailfish_OS-Jolla-


Linux terminal, USB cable, XA2


  • Power button + Vol UP pressed
  • fastboot boot /…/SFOS_4.4.0.58/DUAL-Sailfish_OS-Jolla-
  • telnet
  • choice #5 (launch sshd)
  • Y
  • Enter lockcode + [Enter]
    -Try to connect to the above sshd from another terminal with ssh or sshfs


“recovery” password accepted after entering sshfs -o idmap=user,allow_other root@ /mnt/sfos
as with ...Jolla-


Password refused




Linux Debian Mate-terminal, working with previous versions of hybris-recovery.img

1 Like

I get the same issue on my old Jolla. I had to disable the password to use recovery mode factory reset.

Edit: I misunderstood the main message. It’s not exactly the same problem. On Jolla I tried a factory reset it only worked once a disabled password/security code.

Disable the recovery SSHD password?
How do you do that?
You can still use the “old” recovery from, it still works btw.

Still present in
@Jolla is there a new password for sshd, instead of recovery ?
Thanks :–)

Are you refering to this article? https://jolla.zendesk.com/hc/en-us/articles/360002996893

Edit: No computer these days to verify.
But it might be that I neglected the fingerprint.
Ssh complains about it when changed but sshfs doesn’t.
And I’m not sure anymore having tried to simply connect to the phone with ssh.

The phones are on the
The recovery image which are problematic for me are the and 64.
The phones boot in recovery mode and should be connected through ssh with choice 5.
I usually mount the phones’ filesystem into the PC with sshfs after having opened the encrypted partition.
Since, the password ‘recovery’ is refused.

Back home I can test again.
I confirm that I cannot connect to the sshd server launched from within hybris-recovery.img's Jolla Recovery.
It works with versions prior to
But on .58 and .64, the password is refused when I try to connct with ssh or sshfs.

This is not a problem as I have the prior versions that are working.
No big deal. Just to inform Jolla.

@ric9k I take it this is the same issue that you were discussing in the General section too?

As it happens we already had a bug logged internally following your discussion on General, but I’ve added this bug to it and tagged it as “tracked”. If there’s new info to share on it we’ll do our best to add it here.

Thanks for highlighting the issue.

Oh, I ve been reporting on two places I’m sorry. Yes, it is the same subject/issue.

The sshd recovery password is also refused on the Xperia X with and

For the recall:
Boot the phone in recovery

fastboot boot ./Xperia_X_Single-Sailfish_OS-Jolla-

choice #5

Then try to login vis ssh from another terminal window

ssh root@

password: recovery