[hybris-recovery 4.4.0.58] Password not accepted

REPRODUCIBILITY: 100%
OS VERSION: 4.4.0.58 DUAL-Sailfish_OS-Jolla-4.4.0.58-h4113-0.0.9.24/hybris-recovery.img
HARDWARE: XA2
UI LANGUAGE: -
REGRESSION: Yes

DESCRIPTION:

Tried on 2 different XA2 Dual.
SSH password not accepted when trying to connect to the phone booted in recovery mode.
Into Jolla Recovery v2.0, choice #5, SSHD launched.
The exact same procedure working with SFOS_4.3.0.15/DUAL-Sailfish_OS-Jolla-4.3.0.15-h4113-0.0.9.9/hybris-recovery.img

PRECONDITIONS:

Linux terminal, USB cable, XA2

STEPS TO REPRODUCE:

  • Power button + Vol UP pressed
  • fastboot boot /…/SFOS_4.4.0.58/DUAL-Sailfish_OS-Jolla-4.4.0.58-h4113-0.0.9.24/hybris-recovery.img
  • telnet 10.42.66.66
  • choice #5
  • Y
  • Enter lockcode + [Enter]

EXPECTED RESULT:

“recovery” password accepted after entering sshfs -o idmap=user,allow_other root@10.42.66.66:/ /mnt/sfos
as with ...Jolla-4.3.0.15-h4113-0.0.9.9/hybris-recovery.img

ACTUAL RESULT:

Password refused

MODIFICATIONS:

none

ADDITIONAL INFORMATION:

Linux Debian Mate-terminal, working with previous versions of hybris-recovery.img

1 Like

I get the same issue on my old Jolla. I had to disable the password to use recovery mode factory reset.

Edit: I misunderstood the main message. It’s not exactly the same problem. On Jolla I tried a factory reset it only worked once a disabled password/security code.

Disable the recovery SSHD password?
How do you do that?
You can still use the “old” recovery from 4.3.0.15, it still works btw.

Still present in 4.4.0.64.
@Jolla is there a new password for sshd, instead of recovery ?
Thanks :–)