Hutspot for aarch64?

No devices are shown and the Pull-Down-Menu just shows the normal thing where you would put in your credentials

It should look like that, whats happens if you check the status of the librespot service while hutspot is running?

Also these options are enable in my hutspot

Also maybe a silly question but did you enable to service for librespot like below?

systemctl --user enable librespot

Okay, I have now enabled and started the librespot service (I forgot last time). The Device shows up in devices, but Hutspot still says that Librespot isn’t available. Maybe I have a different Hutspot-Version?

Does it let you register your credentials if you hold down on the device listed? I had to do that once and now it lets me set as current whenever i open Hutspot

No it doesn’t. If I hold down on the device and choose to enter credentials, nothing happens. Also, if I choose to enter Librespot-credentials from the Pull-Down-Menu, again nothing happens

With Hutspot open, go to the terminal and check the output of systemctl --user status librespot

Also have you got a cache directory from an older librespot version, maybe a conflict, could try adding .old onto librespot cache folder and have it made again when Hutspot opens

Just to track this, are you all running the 0.4 version from chum?

Yes I’m using the latest version from Chum and using my librespot package thats linked above and it works good for me so far.

Only thing i cant seem to work out is how to adjust the volume when playing music using the side rockers or media volume slider from pull down menu, can only adjust the volume from the device page, is this just the way it works?

Ok, I’ll see if I can find the time to install with your lib. I’m a bit swamped.

This states that librespot is “Running”.

I’ve tried that - no result, it still doesn’t work. When I select the option in Hutspot to put in my Librespot credentials, nothing happens.

Yes, I do.

1 Like

Would you mind sharing the source so I can try to get it to build on obs? Or was it one of those ‘curse, and say incantations’ builds not amenable to ci/cd?


What i used is above, i changed the Cargo.toml to what i needed and added my User folder for the service in the contrib folder.

I then put it on my phone and built it with Cargo using:

cargo build --release --features "alsa-backend pulseaudio-backend"

Then i used the following to make the rpm:

cargo install cargo-generate-rpm
strip -s target/release/librespot
cargo generate-rpm

Info on generate-rpm for reference

Ok, thanks! I’ll have a look a the sources and see if I can get them into some semblance of distribution ready. I’m not sure cargo build is supported on obs, but we’ll see …

Hi, i experience the same Problems as Schniki12 described when trying to connect to Librespot from Hutspot on my Xperia 10II.
BTW: i couldn’t install hutspot from Chum GUI (App just didn’t show up) and had to install it from Terminal. Don’t know if this is anyhow related with my problems conntecting to librespot.
Apart from that: Thanks to everyone here who is working on bringing back Hutspot für aarch64 devices! I’m following this threat for a long time since Hutspot is the one App i miss most since changing from XperiaX to 10II.

You’ll need to use the one from Chum.

Remove the one you installed and go back to Chum, go to the application list and search for Hutspot and then pull down and choose Show all packages.

Hopefully this will help you

1 Like

I’m still trying to figure this one out, what happens if you pull up from the devices page and login? Mine has a white page with -

Spotify authorization redirected

If that still doesn’t help, Hutspot does create a config and cache in the below places


You could always trying backing those up and starting from scratch as thats what i did on this device.

I opened Hutspot, logged into my spotify account by pulling up on devices or settings page and choosing login, then after that i registered my credentials with librespot and after that it let my activate my device and use it. Sometimes i might have to close Hutspot and reopen for the device to show and 90% of the time its fine

1 Like

Thanks for your help!
I managed to install Hutspot from Chum:GUI with your advice, Hutspot itself seems to work as i can connect to my spotify premium account and play Music from a Spotify Connect Radio from it.
Connecting to Librespot and playing music on the phone still does not work: when pulling down in “Devices” menu and choosing Librespot login, nothing happens. In Devices List “Sailfish, Smartphone” is greyed out and Status is “inactive”. Long Press on “Sailfish, Smartphone” and choosing conntect via Authorisation-Blob has no effect either.
I activatet librespot via command line (systemctl --user start librespot) and Status is “running”
(Maybe some phrases are not precise, i use the phone in german language)

Thanks and best regards Peter

Loggin in to Hutspot isn’t the problem, this works perfectly fine. I can also play music with my custom librespot script running, that’s not the Problem.

This is exactly the problem I have. The menu entry for putting in librespot-credentials is just doing nothing.

1 Like

I think i remember what i did to get it working now, as i just did a fresh install of all the packages and ran into the same problem, so i did the below -

/usr/bin/librespot --cache /home/defaultuser/.cache /librespot --name Sailfish --bitrate 320 --initial-volume 80 --device-type smartphone --backend pulseaudio --username USERNAME --password PASSWORD

Run the above once in the terminal with your spotify details then just cancel it once the command finishes, as for some reason it wont do the command properly the first time by just opening Hutspot. Once i did that i could reopen Hutspot and activate it, even rebooted just to verify it.

Could you let me know if that works?


Sorry, didn’t work for me. :disappointed: But i have to admit that i’m quite a rookie when it comes to handle things from terminal (although i use sailfish since 2013 :grinning: )

Here is my output when trying out the command you suggested: