Hutspot for aarch64?

I just edited my post as there was a line break at --device-type smartphone, could you copy and paste the command again with replacing the USERNAME and PASSWORD with your details

A successful command should look like this, just so your aware

No, it still doesn’t work…

Hi, recently, my Hutspot stopped working. Everytime I select a device it tells me „Failed to transfer to Xperia10III:404:Not found“. I tried other Librespot configurations and other devices running Spotify Desktop, but it gives me the exact same error, even when the device isn’t called „Xperia10III“ anymore.

Has anyone an idea what could be the problem here? Two weeks ago, it was workinv just fine and I didn’t change anything.

Where are you getting hutspot? I don’t see it in Chum at all. I’m on 4.5. I’ve built librespot from source.

Interested as well, i always assumed it wasn’t available for aarch64. Would love to see it ported though

EDIT: if you have the settings in the chum gui set to ‘show applications only’ you won’t see it. It’s listed as a package. I probably should add some meta data to the rpm.

Go to settings and turn ‘Show applications only’ off. Or use zypper se hutspot from the cli.

1 Like

Thanks Mark - although i can’t find it in Chum GUI

Ok it works when also searching for packages indeed :slight_smile:
However how about Librespot?

It’s my understanding that Hutspot needs a Spotify player, such as Librespot, to work?

Yes, it does require librespot which I was not able to package to date. I need to go back to Hutspot for aarch64? - #73 by anon81302120 at some point. @anon81302120 built with cargo directly on device.

Thanks, poetaster. I was able to install hutspot by changing the Chum settings. It does work now, except that it will ask to authenticate every time the app starts and it doesn’t remember credentials. That’s quite inconvenient. I have, of course, checked the “Remember me” option.

Is anybody experiencing the same? I have not tried to use the external browser for authentication, due to the fact that on my 10 II starting the browser puts the OOM killer into a kind of psycho mood and then usually all other apps get killed.

It could be that the app is not finding the preferences. it’s probably being default sailjailed … but I’m really not sure. org.nemomobile.configuration is being used to save the data so it’s probably in the big fat dconf store which is a bit pita. You could try to launch from a terminal and see what, if any, debug output hits the terminal. But, the big hash used for auth may be stored separately. Please have a look if you see any data under:


It might be that the hash is not being found because of sailjail.

EDIT: it’s also possible that the hash / device info is stored in the librespot context, which make it really bitchy, since librespot is not running in a context to give it access to data from hutspot …

so, long story, you could/should try to modify the hutspot.desktop using the ™ @nephros override method:

Copy the hutspot.desktop file to /etc/sailjail/applications and add:

1 Like

Does it use ‘web auth’ for that with a web page at spotify?

Yes. It shows me some spotify login page in-app and also the option to open the browser to that same page. The authentication works, but I have to do it every time hutspot closes - which also happens every time I switch networks.

BTW: Disabling sandboxing did indeed fix the issue.

Great! I’ll look at baking that into the desktop file in the chum version.

EDIT, so, NOW you only have to autenticate once?

Yes, after disabling the sandbox I authenticated. I then killed the app and opened it again and it immediately worked, without having to authenticate again.

1 Like

I had the problem that I couldn’t start and stop librespot from hutspot. After adding the sailjail line to the desktop file, everything works, thanks a lot!

1 Like

Interestingly, the problem I had then, fixed itself only to show up now again. I really don’t know what causes this problem to appear/disappear at random.
Is Spotify blocking Hutspot sometimes?
I already tried to remove and re-install Hutspot with no success. Even tried to re-authenticate but it didn’t fix the problem. I also tried different versions of Librespot, everything with no success.

It would be really cool if someone here could give me a hint what could be the problem. Otherwise, I will have to wait for the problem to (hopefully) fix itself once again. :upside_down_face:

I have to admit I STILL don’t have a spotify account (I hate those dickheads) but will try to go there since I had the bloody idea to maintain the chum build. It’ll take a bit of time. It requires a paid account, or? Thanks!