How to make phonehook work in

I have tried to get phonehook to work but it doesn’t work. Need help if it works?

I assume this is the 64bit version by adel, I see no message from you asking about an update, the last version was in May 2021, no doubt some parts of SFOS has changed since then.

What does “it doesn’t work” really mean?, does it install but not run?, what errors/notifications are given by your device?

As with any questions we ask, the more information you give, the better the chance of getting some help.

It’s likely that user “adel” is no longer using SaifishOS, but at the very least, go direct and ask.


It installs but doesn’t work. There is no service process. Needed newer version. Version witch I installed is phonehook-0.10.0-1.aarch64.rpm.

It works when you disable Sailjail.


Don’t know how to do it…

In /usr/share/applications
edit phonehook.desktop (as Admin)
add line:


Save File, restart App, Start Daemon - Et Voila!


Might be easier to run in terminal…
echo -e "[X-Sailjail]\nSandboxing=Disabled" > /etc/sailjail/applications/phonehook.desktop

Thank’s. Now it works but it doesn’t find any numbers.

No, it is not, and it doesn’t. It places a new desktop file in /etc/sailjail/applications. It never touches the original desktop file in /usr/share/applications.

1 Like

Oops, I misread that. Sorry.

1 Like

Still it doesn’t work…

Can you pinpoint what is not working?
I’m assuming you’ve got the app up and running at least. That was the point of my command, and it does work on my X10III.

It works otherwise, but not names and numbers when you search by name, for example. And when the call comes, there is a popup with no results. I live in Finland and I tried it with local app Fonecta.

OK, this is all a matter for app developers and nothing I can help with. Unfortunately, I think development is not active any more.
Maybe some other dev can help.

Fonecta seems to be an Android app. What does that have to do with anything?

1 Like

Before it worked even though it was an android app

So which app is it really that you are trying to use?
Before as with Jolla 1 / Jolla C / Xperia X?
I think these things were a bit more integrated with the previous Android runtime. But i definitely don’t think they are any more.

Sony xperia 10 III is my phone. And app is Fonecta. Finnish app caller id.

Then your app title, and much of the discussion, is gravely misleading in that it mentions the native app “phonehook”. That has nothing to do with some Android app, which is unlikely to work.

Perhaps there is a misunderstanding. As I recall, Fonecta app is one of the sources available in Phonehook. But I think it does not work anymore, maybe the api has changed or something.

So I think the problem might be in the (Finnish) sources, not phonehook itself.

1 Like