High battery drainage Xperia 10 III

REPRODUCIBILITY: Randomly, after few hours, few days or even couple of weeks from boot-up
REGRESSION: Did occur with also


Battery consumption current jumps from 100-200 mAmps to 400-500 mAmps and stays as high as that.
Note! Draw current observed via “Battery Buddy” application from OpenRepos.

It has happened now 3 or 4 times to me now in couple of months. The phone feels warmer than normal while happening.

I have had telephone app + Android apps Telegram and Signal running while it happens. But today I didn’t have Android App support running at all, I had Fernschreiber and Whisperfish running instead.

One thing I am suspecting a bit, that could be possible trigger; playing (Youtube) via Jolla browser. But I’m not 100% sure about this - it’s just a feeling.

I can retrieve logs if needed. But in that case please let me know what to fetch and how and from where (?) I’m not that tech savvy that I could retrieve based on my own knowledge about SFOS.

ps. My brother has the same problem with Xperia 10 (not III like I have), but his telephone draws always 400+ mAmps.


Wifi NOT on (I hardly ever use Wi-Fi, I have not witnessed a link to it)
Bluetooth NOT on
Adaptive screen light is on, but set to lowest
Tried with AND without Android App Support, seems to have no effect, occurs even when Android App Support is OFF


  1. Boot up the device
  2. Use phone with your apps
  3. Notice one day that battery percentage numbers go down fast


Normal battery current draw 100-200 mAmps. Higher drainige only on app usage.


High continuous draw 400-500 mAmps. Draw never goes lower than about 400 mAmps.
Shutting down all apps have not helped to lower drainige. It stays at 400-500 mAmps.
Rebooting phone does reset this drainige back to “normal” 100-200 mAmps.


I do not have a single modification installed, pure Sailfish OS

EDIT 31.7.2022: improved readability of the original post, not the contents


This has been known to cause unnecessary load on other hardware (10mk1 specifically) - you could try turning this off and see if it makes the problem go away.

On pure unmodified SFOS you can try launching the CSD tool and choose the “Power consumers” option so see which processes cause some load. CSD is launched by going to Settings → About Product → Tab on the “Build” five times.

A bit more insight can be gained from using top or htop (command line) or crest, or collectd/systemdatascope, but the latter is only available on third party app stores (Openrepos, Chum).


Thanks a lot Nephros!
I’ll try these out when the symptoms next time appear.

My XA2 Ultra at idle goes as low as 60-70 mAh. The X10 III idles at twice higher current, even in Flight mode. I’ve never seen values lower than 110 mAh on it, even with manual brightness set to minimum (too dark for normal use). Switching between automatic and manual brightness doesn’t seem to have any effect.

Hence, battery time doesn’t seem to be any better than on XA2 Ultra, despite 30% bigger battery, because power consumption seems to be 30-50% higher, too.

Idle power consumption of 100 mAh means that such a huge battery can only provide two days of standby, i.e. when doing nothing (100 mAh * 24 hours = 2400 mAh per day). At 200 mAh it can barely last one day. Those are pretty bad values. They probably get slightly lower when the display turns off, but it is still nowhere near the XA2 Ultra idling at 50-70 mAh with the display on.

P.S. Battery Buddy shows reverse current values on the X10 III (negative for discharging, positive for charging) whereas on the XA2U it shows positive for discharging and negative for charging…

Thank you Wetab73 for your input. I didn’t know that it could be possible that phone would idle lower than 100mA.
In my experiences 90mA was the absolute lowest value that I saw X10 III idling.

I did try those too and my experiences were the same;
Fiddling with display brightness didn’t do any noticeable change, on average consumption stayed on ~110-120mA.
Nor did the flight mode either. No effect whatsoever, which is quite interesting…

You could contact Direc85 about the reversed polarity prefixes in the Battery Buddy. He might want to know about that glitch and fix it.

For my XA2 Ultra it is enough to just not touch it for a couple of seconds and its power consumption (as shown in Battery Buddy) goes down to 60-70 mAh range (and quite often even 55-58 mAh) with only occasional spikes to 100-120 mAh. Compared to this, the X10 III is an energy hog, eating twice as much power at idle…

It’s probably not a Battery Buddy issue because I’ve seen it being reported this reverse way in some other battery app, too. So it must be reported so by the device itself.

Can I get the battery consumption as output of Battery Buddy while connected per ssh to the Xperia 10 III ? Most of the time the display is off and I’d like to know the IDLE consumption in this case.

You’ll need to contact @Direc85, I haven’t got a clue about that unfortunately. Hope you’ll get it to work somehow, would be interesting to know.
Is there any other app that could log consumption values…(?)

cat /sys/class/power_supply/battery/current_now is what you are looking for. Or install powertop.

Thanks for the ping @lumen!

Unfortunately Battery Buddy doesn’t log the drawn current value, as it’s not yet needed in charger control part, which also does the logging. I have also been planning to implement separate value logging, but haven’t gotten around to it yet. I’ll implement one or another next, I think.

Meanwhile, you could try running this command in terminal, on-device, with no cables attached:

while [ true ]; do sleep 1; cat /sys/class/power_supply/battery/current_now; done

Then lock the screen when it’s running. It should now output the current draw from/to the battery once every second - if the process isn’t suspended by the phone, which does happen. Do note that the value is in microamps, so drop the last three digits to get milliamps.

I tested this for a little on my X10III, and I’m getting about 40mA…50mA readings, with occasional 90mA…100mA spikes. The basic “display on, lowest brightness, Battery Buddy showing the current” reading is about 120mA for me with spikes to 250mA or so, sometimes up to 400mA. This was in countryside with 3G and low traffic, so if you’re in a city on 4G with a lot of traffic on the network, power consumption will be (significantly?) higher.

Another thing you could try is running top or htop on your device via SSH via WLAN, without cables attached. It doesn’t give you power consumption, but top processes instead, which would be more specific.

I hope this gets you started!

1 Like

To compare, with display off, readings from /sys/class/power_supply/battery/current_now on the XA2 Ultra look like this:

  • lowest: 11-12 mAh (some 10-20% of readings)
  • most often: 19-22-25 mAh
  • highest: 30, 37 mAh
  • two single occasional spikes to 48 and 62 mAh.

So this confirms that compared to the XA2 Ultra the 10 III is an energy hog. Which is quite surprising as with its chipset manufactured in 8 vs 14 nanometers it is said to be much more power efficient. Clearly, it isn’t. At least with SFOS onboard.

Edit to the above: giving the XA2U mote time reveals quite frequent readings of as little as 8-10 mAh (some 20-30%) and readings in the 20-30 mAh range being the most frequent.

Hi direc85, thanks for your command. I measured the following:

  • Xperia 10 iii with
  • display: lowest value, Ambiente Drei
  • only WiFi enabled, everything else disabled (only very few other WIFI clients nearby)
  • all apps closed, waited 5 seconds
  • started to measure 20s seconds with display on: mean value 194 mA

Measure with display off didn’t work in the same way. Therefore I used htop per ssh:

I discovered a strange thing: After about 5 seconds htop freezed for some seconds, then I saw the following picture:

Some time ago I meant, this would be a problem of “Situations”, which is not installed now.

Does anyone observe the same behaviour and do someone know the cause for it?

When the screen is off and there is no charger connected, the phone goes into power save mode. This includes SSH over WLAN, which pauses htop, too. I’ve seen it with XA2, too, it’s expected behavior. It makes the investigation a bit harder, though…

Ok, I did a reboot and during charging, I didn’t observe the behavior above. Thanks.
So, with display off, I’d have to write the measure values in a file, perhaps.

New measurement with Battery Buddy
Hi again,
with Battery Buddy I set my charging limit to 85 %.
Then I started the charging of the phone with:

  • everything disabled, except “don’t disturb”-mode
  • background information: microG is installed, 5 apps are allowed to send “push-notifications”

In the morning, I got this results from the logs:
The battery discharged from 85% to 77% in 9 h and 13 minutes.

Mean value: discharging 1% of the battery in 69,1 minutes.

  1. Can someone confirm this amount of discharging of the phone?
  2. This is several times higher as I’m used to with my previous “Moto G9 Play”, which lasts several days without charging.
  3. IMHO there should be potential to save more battery power, if the suspend mode of the Xperia 10 III could be optimized.
  4. I hope there will be an improvement in a future update.

Yes, I too get similar mean idle/display off power consumption of around 1% per hour. Which matches @direc85’s measurements of 40-50 mAh. In a similar state, my XA2 Ultra averages to some 20-25 mAh. But the worst thing is that it is enough to just turn on the screen for the 10 III to start consuming 120+ mAh, whereas the XA2 Ultra in such state eats ~60 mAh.

Perhaps a newer kernel than 4.19.188 is working more efficient.
Does anyone tried a newer kernel rsp. exists for sailfishOS a schedule similar to:

Updating kernel would require updating the AOSP binaries, too, but getting Sailfish to support it is a lot of work, even for minor updates. It would also require the users to flash the new AOSP themselves, which isn’t currently well documented, nor is it “a quick and simple update” to so. The newer AOSP package also bumps Android major version, so it’s double the hassle, likely even worse than that.

TL;DR One doesn’t simply update the kernel :frowning:

1 Like

I was aware that I would not do it for myself, but was curious, if some devs tried this. With Ubuntu it was recommended to use the newest distribution for rather new hardware (or to install the appropriate “linux-generic-hwe-xx.04” some time ago).

Is it known, when a new kernel (perhaps 5.x) will be delivered with sailfish?

What were typical times between “greater changes” with the kernel in the past (because I’m newbee in sailfish)?