Headset media buttons don't work with Android apps

REPRODUCIBILITY (% or how often): Always
HARDWARE (Jolla1, Tablet, XA2,…): XA2
REGRESSION: (compared to previous public release: Yes, No, ?):


(Continuation of Headset media buttons don't work with Android apps - together.jolla.com)
My headphones have media buttons (play/pause, volume up, volume down), and they work great with the standard SFOS media player app.

However, I want to use them with Android apps such as Spotify, but they don’t seem to work.

  • Play/pause button: Does not work at all, including double-press to skip current song and triple-press to rewind. Everything works fine with SFOS media player.
  • Volume up & volume down: Only works when device is “awake” (I have to press the power button to turn on the screen); when playing from the SFOS media player I can also change volume when the device is locked (screen completely off), which is very comfortable. I can’t do that when playing media from an Android app, instead I always have to “wake up” the device.

This is the same with the phone’s own volume buttons: They always work when I’m using the SFOS media player, but if I’m playing from Android media apps I always have to “wake up” the device.

I’m not sure where the problem lies; the MPRIS interface to Spotify works without problems (I can see and use the media buttons on the lockscreen), and the headphone buttons work with the Media Player app.

I’ve experienced this problem since the start of Android support for XA2, and it’s still present with the latest versions:

UPDATE: This issue is still present in, exactly as described above.

UPDATE 18.11.2019: This issue is still present, still exactly as described above.

UPDATE 03.02.2020: Issue still present in

UPDATE 17.04.2020: Issue still present in

UPDATE 01.10.2020: Issue still present in


Have a headset with media buttons, and an Android music player app such as Spotify.


  1. Launch Spotify app, start playing music
  2. Lock phone
  3. Try using headset media buttons to do anything


Volume should change, play/pause should work, next/previous track (using double and triple press on play/pause button) should work.


Nothing happens. When pressing the lock button to “wake up” the phone, it is possible to at least change volume, but none of the other actions work.

Is this a sailfish or alien dalvik bug?

From discussions back on TJC it seems like a Sailfish bug. The buttons on the lockscreen work fine, so the MPRIS interface to aliendalvik media players works as it should.

@pilino Do you have time to attend the next community meeting? Community meeting on IRC 12th Nov 2020

edit: I’ll try to join the meeting and discuss it with jolla

The answer of Jolla from the last meeting: “we haven’t had an opportunity to prepare an answer for you yet unfortunately, would need to move to next meeting, apologies!”

There is a workaround till we see a fix for that problem: https://together.jolla.com/question/174156/bug-bluetooth-media-control-with-android-apps-and-native-apps/?answer=190869#post-id-190869

You can find the whole discussion in the meeting log - https://irclogs.sailfishos.org/logs/%23sailfishos-meeting/%23sailfishos-meeting.2020-11-12.log.html

1 Like

@sailr Thanks for taking this up at the community meeting! I do not have the time to attend these, but I’m following the progress :slight_smile:

1 Like

Some additional information for future reference: (since I cannot edit my previous post for whatever reason :unamused:)

I’m using a wired headset when this problem occurs. I don’t have a bluetooth headset to test with in the first place, and I suppose those fixes do not affect this issue.

Since the last update I can use the media buttons in my car to skip songs, change volume, etc. which is great :slightly_smiling_face:
Unfortunately it still doesn’t work for my wired headset.

Can confirm that this still doesn’t work for me either, the problems as described in the original post are still present in

Update: In, the volume buttons finally work from the locked/asleep state, but the playback controls (play/pause, skip/fast-forward, back/rewind) still do not work.

I believe the volume buttons are just intermittent in general:

(Although they have been very good for me on my Xperia 10 II)

Since the 4.2 update it works like intended. Can you confirm this?

Indeed, it has worked very well since the update to 4.2 and 4.3 :+1:

1 Like