Headphone jack to speaker is VERY low volume, same as the phone speakers in fact

REPRODUCIBILITY (% or how often): Always
BUILD ID = OS VERSION (Settings > About product): Fresh Install of
HARDWARE (XA2, X10, X10 II, …): Xperia X

REGRESSION: (compared to previous public release: Yes, No, ?): Worked well previously on 3.X on a different phone of the same model


If I plug my Sony speaker into my SailfishX phone the volume is so low I have to put it maximum then hold it to my ear to hear it.
Sony speaker works very well with my old Nokia MusicXpress or my N808 and was also fine with my previous Sailfish phone of the same model but v.3 OS.


  1. Plug in wire from speaker to headohone jack


Sound you can hear


A slight whisper in the distance


Patchamanger does not work in Sailfish 4 yet so cannot install a max volume patch. This speaker works fine, something changed in Sailfish to not allow any volume.
How can I change this please?


Have you tried other cables? Other speakers? Have you tried an amp? Maybe “Audio Output Switcher” is needed because it isn’t piping to the correct output?


The cable worked fine before and works fine with other phones. My headphones are also quite on this phone and were previously ok. I do not have an amp nor another speaker but this speaker worked well with Sailfish 2.x and 3.x

I tried audio output switcher as suggested and going through all the choices it did not help in this matter, though playing through the phone speaker and “headset” external speaker the phone speaker drowns out the small sounds from the external speaker which should be much, much louder.

I cannot connect via bluetooth to test as bluetooth isn’t working anymore in 4.1

Same here! So frustrating, because I like the convenience of carrying a library of music with me. Whether I plug my Xperia XA-2 into headphones, a portable speaker, or a HiFi, the volume is way too low, also after dismissing the audio level warning (by clicking “yes, I understand”) and turning it up to the max. This cannot be right.

Edit: I’m currently on Sailfish OS 4.1, but this issue was present also in earlier versions.

1 Like