Harbour-tasks app

New topic to discuss the harbour-tasks app, a todo/task manager that syncs with caldav (for eg. nextcloud, fruux). Continuation of the discussion from Nextcloud Tasks Sync with SFOS

1 Like

@vige sure, I added the target to my SDK and uploaded the rpm to openrepos. What’s nag?

https://www.horde.org/apps/nag

Some testing results:

  • Yes, it works with nag
  • It’s a bit annoying that the description field only shows about two lines at a time- I have tasks with long descriptions
  • You really should not have pkgconfig(sailfishsecrets) in the Requires -field of the spec file - it should be only in the BuildRequires. Now I have a gazillion unnecessary devel packages on my device :frowning:
1 Like

Before I reply, I must say I’m a bit demotivated by your negative wording. I created this app to scratch an itch, and shared it because maybe other people would find it useful. I do this in my precious free time, free of charge. So if people are going to tell me the app annoys them, and are going to frown at me, I will simply remove the app from openrepos, make the repo private, and develop it just for myself.

I was going to work on the app this afternoon, but the motivation has gone and I’m going to work on other projects now to let the negativity that I now associate with this project eb a bit before I pick it up again.

What is nag?

I noticed that too, I need to increase the size.

How do I declare a runtime dependency on sailfishsecrets? I need sailfishsecrets, the app won’t work without it. If I don’t declare the run-time dependency, it will not be installed in the emulator.

I’m sorry, I definitely didn’t mean to demotivate you, just the opposite actually. I appreciate your effort and the fact that you have made it available for others to enjoy. I’m not annoyed by your app, I’m annoyed because it’s not perfect (for me). And please also remember that I’m not a native English speaker so the words I choose are not always the best ones, so please accept my apology.

I believe “Requires: libsailfishsecrets” is what you need. I didn’t try it though.

3 Likes

Thanks for the clarification. For what it’s worth, I’m not a native speaker of English either. I’m glad it’s a misunderstanding! Aopology accepted :slight_smile:

That seems to do the trick indeed, just tried with a freshly installed emulator and it installs the daemon and the library when I install the app. I’ll change that in future versions. Thanks!

1 Like

I have in my spec file:
Requires: sailfishsecretsdaemon
Requires: libsailfishsecrets
Requires: libsailfishsecretsplugin
Requires: libsailfishcrypto
Requires: libsailfishcryptoplugin
Requires: sailfishsecretsdaemon-cryptoplugins-default
Requires: sailfishsecretsdaemon-secretsplugins-default

But the SDK emulator still doesn’t get the sailfishsecrets daemon (works on device though after installing the rpm). Is it too much? Is there a way to force the emulator to install the daemon? Would prefer to avoid reinstalling the SDK, it had a good run of successful updates for over a year.

I have Requires: sailfishsecretsdaemon-secretsplugins-default in the Nextcloud Talk app and that was always sufficient. src

1 Like

This is what I have now, and it is sufficient to install and run the app on a freshly installed emulator:

Requires:   libsailfishsecrets
Requires:   sailfishsecretsdaemon
Requires:   sailfishsecretsdaemon-secretsplugins-default
BuildRequires:  pkgconfig(sailfishsecrets)
2 Likes