GS290 installation

Hello everyone, I’m a new user of sailfish and like the OS very much. It has everything I need, so I think it will become my main OS. My phone is a Gigaset GS290. I have 2 questions, perhaps someone can answer them.
I installed Sailfish with the UBPorts Installer. My 1st question: is there is another installation method for this phone without getting the Volla name on the starting screen an in the product informations in the settings?
My 2nd question: does the GS290 get OTA updates?
Thanks for reading.

2 Likes

Welcome to SFos.
pls use search before posting… https://forum.sailfishos.org/search?q=volla

2 Likes

I did, but I did not find the answers. Thanks.

https://www.piggz.co.uk/sites/pgz/blog/volla-manual-install

What version is installed? 3.4 or newer?

If it’s 3.4, ota will not work. From > 4, it should.

One downside. Currently shooting videos and screen captures are broken in 4.x.

3 Likes

Thanks, I have 4.3 installed. That means, the phone will receive 4.4 sooner or later. That’s good news.

Oops, firefox says there is a security risk with the piggz web site…

When 4.4 is ready you can do an update easily on the command line:

ssu re 4.4.0.58 
ssu ur 
zypper ref 
zypper dup

If you’re comfortable with that approach. I like it because I see exactly what’s happening :slight_smile: Which is often more than I really want to know, after all :slight_smile:

1 Like

What am I talking about. I already did that on my main phone. I’m running 4.4.0.58.

Hmmm. Maybe it’s not OTA at all and I just have my ‘habits’.

@piggz am I telling fairy tails?

Edit: @piggz, your cert on the web server ran out of time.

I’m running 4.4.0.58 on Volla Phone and and i think it’s the latest version.

That all sounds very good. Thanks for the answers. The more I play with the phone and Sailfish, the more I like it, no love it.

1 Like

For updating I did on CLI on my Volla phone:

devel-su
ssu release 4.4.0.64
pkcon refresh
version –dup

Worked like a charm, now running SFOS 4.4.0.64 on my Volla phone.

edit: The update was not visible in Settings/updates.

2 Likes

Great, this worked here too. I am also on 4.4.0.64 now. :slightly_smiling_face:

Am I right, after installing a GS290 manually (link above) I still have the Volla name on the phone, because the build is made for Volla?

Have to add bad news: the camera is black now, it worked on 4.3. :frowning_face:

1 Like

The hostname ‘VollaPhone’ is defined in settings/WLAN/pulldownMenu/Advanced/Hostname. You can change it to what you prefer.

did you update directly from 4.3.0.15 to 4.4.0.64 without the step to 4.4.0.58 between?

Yes I did. But in the meantime I went back to 4.3. with the UBPorts Installer. The camera is a must have for me for scanning QR codes.
Does the camera work with 4.4.0.58?

Yes, the camera always worked. I got my Volla phone abt. 2 months ago and flashed to 4.3.0.15 using UBports Installer. Later I updated to 4.4.0.58 using CLI as written above. Again later, as 4.4.0.64 was published, I updated in the same way because the GUI updater never saw any update, but CLI update did always work.

As said, camera always worked, but I didn’t test Advanced Camera because I read about it’s problems with v. 4.4, Sailjail and so on and I don’t know if they were solved yet in the mean time. So the above is regarding the Jolla Camera app, not the Advanced Camera.

If camera works in V. 4.3.0.15, maybe update in two steps, 4.3.0.15 → 4.4.0.58 → 4.4.0.64 works better, so I hope, and did so on my Volla.

edit: As I got the phone abt 2 months ago, there was Ubuntu Touch installed before I flashed to 4.3.0.15.

camera failed on my phone with the Jolla camera app. I did not test advanced camera so far.
Ok, perhaps I will try the update again during the next days.
Maybe there are some differences between the real Volla and the GS290? I don’t know. Perhaps I will buy a real Volla too. The next model looks interesting. But it I will need some time to create a Sailfish build for it I guess. On the other side it costs much money for a 4G phone today. Does it make sense investing so much in 4G when 5G is coming up? I hoped for a price drop of the original Volla, but… Another idea is switching to Xperia 10 III and Sailfish X. It’s a dilemma.

1 Like

Update in two steps:

ssu re 4.4.0.58 
ssu ur 
zypper ref 
zypper dup

and then as @Seven.of.nine did,

ssu release 4.4.0.64
ssu ur 
zypper ref 
zypper dup

I know that @piggz just got some fixes in. For me, volla and gs290 same thing, camera STILLs worked but video was borked and screensnapshots caused reboot. I’m not sure if the fixes made it into the release, But I’ll test now.

1 Like

Sadly, no :slight_smile: The same problems on both. The GS290 is a solid middleclass phone, better than the Xperia 10ii. I think the 10iii would be somewhat better. I have a vola, two GS290s and an Xperia 10 ii. All work reasonably well but I find performance for media stuff better on the GS290/Volla.

@piggz is already working on the port for the next volla, so that will soon also be an option. Thanks @piggz!

Did/does video recording with a camera app work? Does Screensnapshots work?

Checked right now on Volla phone: Video camera does NOT work. I can start the recording with the button, but get no feedback. Monitor image goes slow and sticky. After pushing the button again for stopping, the app sticks. Have to minimize and then close it by long tapping + x. No file is created on phone or SD card.