GPS stopped working

I have many 3-digit and 4-digit numbered satellites without getting a fix, so the correlation between the number of digits and getting a fix must be a local peculiarity at your end. Other than that I can echo the frustrations about the unreliability in getting a fix - sometimes fairly fast, other times hardly at all.

I must admit I was sceptical about WiFi affecting the GPS. However I have tried this about 4 times so far with and without WLAN enabled. So far whenever WLAN is off the GPS fix is pretty quick. Not lightning fast as it perhaps should be but certainly very acceptable and within usually 30 or so seconds.

I’ll keep trying this method. Now all I need is for Android apps that use GPS to stop freezing and then you need to restart Android support.

2 Likes

Even if this does help, it can’t be ‘normal’ to have to turn the wifi off just to get a GPS fix - and I don’t have to do this on my Android XA2 to make GPS work (it just works out of the box). There must be something else going on here, either with Sailfish itself, or with the way that Sailfish interfaces with the hardware or its drivers.

2 Likes

I agree, It’s definitely not normal. I was passing on my experience to at least help XA2 owners to be able to use the GPS even though they have to use a work around.

Further, it might not only help other users but also tracking the bug

I have to say I am very skeptical about WLAN affecting getting a fix. I have XA2 with sailfish and my wife has same phone with android. They are different like nignt and day in operation. Android allways work sailfish is very sloow getting fix. Both phones are in mint condition. This is a clear sw bug , no excuses…
it is not something user have messed themselves or hardware problems related like some people are keen to hint. Of course there are diiferent cases but we all know it has never worked.

1 Like

When I had the stock Android on my XA2 Ultra, it was getting a fix within seconds. Then, on SFOS 4.1 it became a nightmare. Then, on Lineage 18.1 it got very quick again. And now, back to SFOS 4.3.0.12, so far I didn’t have enough patience (and time to waste) to get a fix even just once.

So it’s not even a comparison between two XA2’s. It’s how the same unit behaves differently depending on what OS it is flashed with. Therefore, WLAN is extremely unlikely to have anything to do with it (and surely not in terms of WiFi waves “eclipsing” GPS signal) because if it was so then it’d be affecting every OS in a similar degree, and not just SFOS.

2 Likes

hence its a deal breaker for me , i stopped using SFOS ( purchased ) XA2 single sim.
but since i normally in a hurry to drive to places so cannot rely on SFOS due to non functional , buggy GPS software .

other things i have managed to live with but GPS is a deal breaker .
hope it get fixed soon,

I Cannot rate sailfish os a daily driver its still in factory mode , Beta testing mode , not a fully functionally OS sadly .

2 Likes

I was very sceptical too. Out of curiosity I tried it, every time so far with WLAN switched off the GPS has acquired a position lock within 30 seconds. With WLAN switched on the GPS takes forever to find its location.

That is even after shifting location by several hundred kilometres between each lock.

At least give email it a try. It will help prove or disprove what has been suggested.

1 Like

Does GPS get a fix when WIFI is off because:

  • it abandons to search for help online and rely on the offline data?
    or
  • there are less radio perturbations?

To be sure to make a trustable test, we must not forget to uncheck the online option in advanced GPS settings.

That is a very good point. In the past, and prior to 2019, when access to Mozilla online location services was free, Sailfish both used and supported this function. Since it is no longer free Sailfish stopped using it, although strangely the option in settings is still there. Perhaps Jolla didn’t properly remove this function and, in some way, Sailfish gets stuck yrying to use something it can’t (and before anybody asks, yes I do have the hangover Online MLS function unchecked in settings and still have huge GPS fix problems ).

1 Like

Hello, I agree GPS is dealbreaker for me too. Just think about how many services and apps depend on loction information and one will understand how much we miss when this not working. An exmple from reallife: In finland car parking lot is paid for using an mobile app. People have got fines for parking even they have used this app, because location is false their car is just not in the place or parking lot they paid for. Even this is off course a responsibility of user to check the correct location , accidents happen and if you are busy you kind of epect that devices work. We Jolla users are unable to use those services…who wants to sit on parking lot and wait for a fix for an hour or so ?

2 Likes

First of all, I appreciate the issue with GPS on the XA2 has caused a lot of frustration for many users. Back when this thread started it looked like the issue might be fixed by the offline MLS packages, but clearly this hasn’t been the case for all XA2 users.

We’ve tried to replicate this internally with many different XA2 devices, but unfortunately haven’t been able to. This makes it difficulty to devise a fix.

Would someone here who can reliably reproduce the problem be willing to test out some changes? You’d need to have an XA2 running latest Sailfish OS 4.3.0, and experience GPS either not working at all or taking a long time (5 mins or more) to get a lock. You’ll also need devel/SSH access to your phone, and be willing to reflash your phone if necessary.

5 Likes

[offtopic]
I feel shocked.
This should be forbidden and illegal until laws are written to make smartphones mandatory (!= my taste).
If the smartphone is not mandatory for everyone, then people without phones should have the same rights/accesses as everyone (≃my taste).
[/offtopic] Sorry, couldn’t resist!

Though I experiment a moderate fail of the GPS, it still doesn’t work as it should, I belive.
So I could be one of these guys.
Unfortunately, these GPS probs are very random.
Hard to warranty GPS will function when you go to a new place for work (time is money).
Hard to warranty GPS will not work when you should find why it doesn’t work :–)

But anyway, definitely interested to dig in deeper!

I just tested an XA2 Single I didn’t deeply tried yet as it is a spare one.
Freshly flashed with licence.
Personal settings on, on, off (online).
Positionning On and GPSInfo running.
Wifi On, GPRS Data Off, 4G On, Bt off.
Tested on a window with approx 160° of clear sky view:
15h05 (begin): 0/0
15H10: 0/24
15H20: 6/27
15H30: 7/27

In short, 15mn to get a fix w/o online services.
Don’t know if that’s “bad enough” to make tests, knowing there is no A-GPS.

But from what I read, aren’t there other online services we could use to speed up the fix?

Thanks for replying, and for the very clear description. Just to clarify one point, did you also have one of the MLS positioning packages installed? If I’m following you correctly, the second “on” in this list (“Offline position lock”) will only be useful if the correct package is installed.

Oh yes, I forgot this.
Yes, I have the western EU one from Jolla.
Indeed, in Settings, Pos is on, Offline is on, Online is off.

Thanks again. In this case, 15 minutes to get a fix definitely sounds like long enough to test against. If you close GPSInfo for 10 mins and then reopen it, it would be useful to know whether you get a fix much quicker the next time. Also after a day with GPSInfo closed.

Would you be willing to test out the changes? If so, either @mal or I would get in touch privately with more info.

1 Like

Ok.
Shutting off the GPSInfo +positioning and test again tomorrow.

1 Like

I think the MLS services question is a red herring. Doesn’t MLS services use the cellular radio rather than the WLAN connection.

I have only been turning WLAN off when I have got a fast GPS lock on.