GPS stopped working

Hi there,
It seems here are some (good?) news regarding GPS on XA2.
I have 4 XA2, some simple SIM, some double.
All purchased used with andriod 9 on them.
Some have a SFOS license, some not.
All have SFOS 4.3
I installed the Western European positioning package, Gpsinfo and Pure maps.
Positioning options are on custom settings and all options selected in custom, Mozilla conditions accepted.
On 3 of them (language set to French), Pure Maps gives my position with approx 15m. precision.
i.e. the one used ATM uses 7 sats of 23.
The 4th XA2 (language set to English) is still acquiring sats (0/7) after 20mn. It seems hard…

GPS work equally with or without SIM inserted.

Tu sum up, 3 of 4 seem to have an usable GPS.

The 4th XA2 device did not get a position after more than 1 hour of waiting.
I changed the language to French and rebooted.
Then, It found a position within less than 10 minutes.
Can that be related to language change or was that just the 10 minutes more it needed to finish building the almanac or collect data?

Will someone with GPS problems on an XA2 try to change language to French and set the same options I did to see if it has an influence?

I tried it. While my results aren’t conclusive I didn’t see any improvement by changing languages.

1 Like

Well, ok, thanks AlanBreen for trying.
In this case, there was just 10 minutes missing…
But at least, 4 XA2 have a working GPS.

1 hour and 10 minutes, srsly… “I have working GPS”. My GPS experience is awfull. I use XA2 as my main phone and when I needed GPS I took my old Jolla 1 from the shelf. No SIM, no wifi, gets a fix outside in less then 3 maybe 5 minutes. As XA2 is my main phone I used GPS to compare, so going with both phones. I cant remember XA2 ever made a fix before J1. Sometimes I could use J1 GPS for an hour or more and XA2 was still „finding” itself. Sometimes XA2 made a fix few minutes after J1, sometimes 10-15 minutes later. Mostly after an 1 hour+ I was bored with XA2 searching and disabled GPS to save battery life.

Original phone, no major drops, screen cracks or whatever (I still have working J1 in almost perfect condition after 4 years of daily usage!).

edit: out of curiosity tried it today (not used it for half a year+). GPS on, high precision, mobile data on, positioning installed. 30 minute walking, nice weather. No fix. Forgot to disable GPS and mobile data, after two hours+ in a house, still no signal. So no changes in 4.3. Still not working.

1 Like

Thanks for the report.
This trick didn’t help for me (XA2 4.3)
(out the window) It sees 29 sats and uses 6 in plane mode (no emissions, just position reception).
When I turn off plane mode and turn wifi on, GPSInfo report is the same (6/29)
All this after 5-10 min. with “warm start”.

Really weird!
As some guys reported, it was working at the beginning and today, it took ages to get a fix outside the house…

This is very unsatisfying dear Jolla.
3 weeks ago I had some free money (I didnt make a lot) but decided to support you bu paying for full version of Sailfish X to slowly realize that one service which I rely on and seems to be like an integral part of todays phone is not working or working 50/50 in perfect conditions. This bug report started Jul 2020 and from that moment you did NOTHING but few comments about some tests that showed you there is no bug. What tests? We are the testing community and we say IT DOESNT WORK (Anybody agrees with me? :slight_smile: ) Jolla do something with that!
You fail to mention problems with basic functionality when you took my money.

Xperia XA2, no problems on android.
Gonna mention one thing. My Old N900 gets gpx fix within few seconds…
What it shows? It can be done right so do it!

Since I never had GPS issues I did not read the thread yet.

Your observation may explain why I do not have the problem: when I am leaving the house/office I always switch WIFI (WLAN) off and use mobile data connection only. I only use GPS outside and always switch it off when I do not need it. So in my use cases I am using either GPS or WIFI. I switch location (GPS) on when actually needed. It typically takes only a couple of seconds to get a GPS fix (Xperia 10 ii, XA2, both with SFOS 4.3).

Maybe this helps tracking down the bug …

1 Like

“GPS stopped working”? Lucky you, mine never really started working. On SFOS, of course, because if flashed back to Android it magically revives.

Right as I’m writing this, it’s been laying by the window for half an hour now, stuck with 24 visible / 0 in use.

EDIT: 30 minutes later, 22 in view 0 in use.

An utter disaster, out of any measurable crappiness scale.

1 Like

I don’t see how WiFi and the GPS are inter-related.

The GPS problem is the most annoying i ever had with Sailfish. I use a Pro1. While i always get a fix, it usually takes at least 15 minutes to get a fix. Besides the Pro1 i use a Xperia X. Same behaviour even so getting a fix is a little bit faster, but anyway far away from acceptable. Getting a fix after 10 minutes if everthing goes well and sun is shining is not acceptable. I have no problems in waiting a little bit longer but getting a fix after ages if it is cloudy is a mess and simply as it is unusable. The annoying thing is, that i got a fix within seconds, when Mozilla Location Service was still available. While i can understand that this service is not available anymore because of some patent issues, i absolutely have no empathy for Jolla in not being transparent and telling us what they are planning to do, to solve the issues. And that after over a year since MLS isn’t available anymore. Why is it so hard to be open to the community?


Please Jolla, communicate on this point!
Thank you.


Me neither. However, @Seven.of.nine suggests that there might some relation. That is why I shared my observation.

WIFI is a transmitter with abt 100 mW transmitting power very close to the high sensitive GPS receiver that receives very weak signals from satellite in 20.000 km altitude → WIFI transmitting signal maybe blocks first stage of GPS receiver and worses S/N ratio of the GPS signal.

I do not really know, but as ham radio amateur, this is my first idea.

edit: my phone is a Xperia 10


Yes, but seeing that my Android XA2 gets a fix in seconds, and this is an identical phone model to my Sailfish XA2 which can take over an hour to get a fix in similar circumstances, then wouldn’t any phone hardware based signal interference which supposedly stops the SFOS XA2 getting a fix also do the same for thr Android XA2?


Same here with XA2 and X before. I deactivate WiFi, GSM, GPS etc when not needed. No problems with gps but it usually takes some minutes to get a fix. I do use navigation on a regular basis with native and Android apps.

It seems really random now. 2 days ago it got a fix in less than 10 minutes. Now no matter how I manipulate the settings it’s just stuck seeing 0/0 satelites all the time for like 3 hours. Gonna flash back to android to see if it really is soft/midware problem with my device.

Is there a guide how to flash it back to android? I never thought I would have to do it, but yeah, I want it working so now its a testing device

Jolla please it is time for you to stand up

A working GPS isn’t the one that occasionally gets a fix.

1 Like

See this guide:
Reverting Xperia device to Android OS and reinstalling Sailfish OS

1 Like

With me it always looks like this (see picture 1 and picture 2).
After 10 - 50 seconds the satellites are always displayed like this (picture 1). Only when the 3 digit satellite numbers are added I get a fix. and that takes between 2 minutes to 1 hour.

1 Like